aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/gnocl
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-08-20 21:57:26 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-08-20 21:57:26 +0000
commitd51274e6ba53372f59693f311f26d01b3ac3e05d (patch)
treeeb47397708dcfbf7f554a2db65c9501e74e36c59 /x11-toolkits/gnocl
parentaf655ec14a08a03ccfdfe42c05fb77e82b9a0b43 (diff)
downloadports-d51274e6ba53372f59693f311f26d01b3ac3e05d.tar.gz
ports-d51274e6ba53372f59693f311f26d01b3ac3e05d.zip
Add gnocl, GTK+ and GNOME bindings for Tcl.
PR: 55619 Submitted by: stephane
Notes
Notes: svn path=/head/; revision=87407
Diffstat (limited to 'x11-toolkits/gnocl')
-rw-r--r--x11-toolkits/gnocl/Makefile49
-rw-r--r--x11-toolkits/gnocl/distinfo1
-rw-r--r--x11-toolkits/gnocl/pkg-descr12
-rw-r--r--x11-toolkits/gnocl/pkg-plist2
4 files changed, 64 insertions, 0 deletions
diff --git a/x11-toolkits/gnocl/Makefile b/x11-toolkits/gnocl/Makefile
new file mode 100644
index 000000000000..11993963c098
--- /dev/null
+++ b/x11-toolkits/gnocl/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: gnocl
+# Date created: 15 August 2003
+# Whom: Stephane Legrand <stephane@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnocl
+PORTVERSION= 0.5.10
+CATEGORIES= x11-toolkits devel
+MASTER_SITES= http://www.dr-baum.net/gnocl/
+
+MAINTAINER= stephane@FreeBSD.org
+COMMENT= GTK+ and Gnome extension for Tcl
+
+BUILD_DEPENDS= ${LOCALBASE}/include/tcl8.4/tcl.h:${PORTSDIR}/lang/tcl84
+
+USE_GMAKE= yes
+USE_BZIP2= yes
+INSTALLS_SHLIB= yes
+
+BUILD_WRKSRC= ${WRKSRC}/src
+CFLAGS+= -I${LOCALBASE}/include/tcl8.4
+
+USE_X_PREFIX= yes
+USE_GNOME= libgnomecanvas
+
+GNOCL_CANVAS_FILE="lib/libgnoclCanvas.so.1"
+
+.if defined(WITHOUT_CANVAS)
+ALL_TARGET= gnocl
+USE_GNOME= gtk20
+GNOCL_CANVAS_FILE= "@comment "
+.endif
+
+.if defined(WITH_GNOME)
+GNOCL_USE_GNOME:=1
+USE_GNOME+= libgnomeui
+.endif
+
+PLIST_SUB+= GNOCL_CANVAS_FILE=${GNOCL_CANVAS_FILE}
+
+do-install:
+ ${INSTALL_DATA} ${BUILD_WRKSRC}/gnocl.so ${PREFIX}/lib/libgnocl.so.1
+ if ${TEST} -f ${BUILD_WRKSRC}/gnoclCanvas.so; then \
+ ${INSTALL_DATA} ${BUILD_WRKSRC}/gnoclCanvas.so ${PREFIX}/lib/libgnoclCanvas.so.1; \
+ fi; \
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/gnocl/distinfo b/x11-toolkits/gnocl/distinfo
new file mode 100644
index 000000000000..266f8da3a24a
--- /dev/null
+++ b/x11-toolkits/gnocl/distinfo
@@ -0,0 +1 @@
+MD5 (gnocl-0.5.10.tar.bz2) = 1d1b01c536a58e217cf4f069d5113210
diff --git a/x11-toolkits/gnocl/pkg-descr b/x11-toolkits/gnocl/pkg-descr
new file mode 100644
index 000000000000..77f2671707bc
--- /dev/null
+++ b/x11-toolkits/gnocl/pkg-descr
@@ -0,0 +1,12 @@
+gnocl is a GTK+ and Gnome extension for the programming language
+Tcl. It provides easy to use commands to build quickly GTK+ and
+Gnome compliant user interfaces including the Gnome canvas widget
+and drag and drop support.
+
+gnocl can be compiled in three flavors:
+
+* GTK only
+* GTK and the Gnome canvas widget
+* GTK, the Gnome canvas widget and Gnome UI libs.
+
+WWW: http://www.dr-baum.net/gnocl/index.html
diff --git a/x11-toolkits/gnocl/pkg-plist b/x11-toolkits/gnocl/pkg-plist
new file mode 100644
index 000000000000..8bad19df9b9e
--- /dev/null
+++ b/x11-toolkits/gnocl/pkg-plist
@@ -0,0 +1,2 @@
+lib/libgnocl.so.1
+%%GNOCL_CANVAS_FILE%%