aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/gtk-sharp30
diff options
context:
space:
mode:
authorMark Felder <feld@FreeBSD.org>2018-06-16 15:56:41 +0000
committerMark Felder <feld@FreeBSD.org>2018-06-16 15:56:41 +0000
commit85936160101d4e257e3a84b497be4f27591ba576 (patch)
tree1d6f88bb289550ee35d6c765f793c8166d8776b1 /x11-toolkits/gtk-sharp30
parentde6843f3910c66953f78b816f9a38862eb4e1401 (diff)
downloadports-85936160101d4e257e3a84b497be4f27591ba576.tar.gz
ports-85936160101d4e257e3a84b497be4f27591ba576.zip
Update Mono to 5.10.1.47
This brings a more modern Mono release to the ports tree. After discussions with others in the Mono community I targeted the mono 5.10.1.47 release which is the latest release in the "Visual Studio" release channel. This is considered to be the most stable and widely tested, which makes it a good candidate for us. We may upgrade to 5.12 after additional testing or introduce another Mono package for users who require testing against a newer release; this has yet to be determined. - Build from official release tarballs - Now include BoringSSL per upstream guidelines [1] - Remove ACCEPTANCE_TESTS, not being updated by upstream - No long require glib; Mono includes their own replacement - USES=display:tests required for some tests - Remove broken for armv6, armv7: file now available [2] - Mark as LLD safe as mono changed how it handles TLS [3] Changelog: http://www.mono-project.com/docs/about-mono/releases/5.10.0/ PR: 222271 [1] PR: 221236 [2] PR: 218885 [3] PR: 211367 Approved by: dbn Differential Revision: https://reviews.freebsd.org/D15780
Notes
Notes: svn path=/head/; revision=472555
Diffstat (limited to 'x11-toolkits/gtk-sharp30')
-rw-r--r--x11-toolkits/gtk-sharp30/Makefile2
-rw-r--r--x11-toolkits/gtk-sharp30/files/patch-gtk_gui-thread-check_profiler_gui-thread-check.c9
2 files changed, 10 insertions, 1 deletions
diff --git a/x11-toolkits/gtk-sharp30/Makefile b/x11-toolkits/gtk-sharp30/Makefile
index 35ffd125d2d0..9ac7e4da327b 100644
--- a/x11-toolkits/gtk-sharp30/Makefile
+++ b/x11-toolkits/gtk-sharp30/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gtk-sharp
PORTVERSION= 2.99.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11-toolkits
MASTER_SITES= GNOME
PKGNAMESUFFIX= 30
diff --git a/x11-toolkits/gtk-sharp30/files/patch-gtk_gui-thread-check_profiler_gui-thread-check.c b/x11-toolkits/gtk-sharp30/files/patch-gtk_gui-thread-check_profiler_gui-thread-check.c
new file mode 100644
index 000000000000..614f3e3247ea
--- /dev/null
+++ b/x11-toolkits/gtk-sharp30/files/patch-gtk_gui-thread-check_profiler_gui-thread-check.c
@@ -0,0 +1,9 @@
+--- gtk/gui-thread-check/profiler/gui-thread-check.c.orig 2018-06-11 18:44:28 UTC
++++ gtk/gui-thread-check/profiler/gui-thread-check.c
+@@ -93,6 +93,5 @@ mono_profiler_startup (const char *desc)
+
+ mono_profiler_install (NULL, NULL);
+ mono_profiler_install_enter_leave (simple_method_enter, NULL);
+- mono_profiler_set_events (MONO_PROFILE_ENTER_LEAVE);
+ }
+