aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/gtk20
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2002-11-17 00:31:19 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2002-11-17 00:31:19 +0000
commit040a50454d53f9a5d672cb4e3ba53fbe9c322322 (patch)
tree514482b97eac346383ae3c138ec1d292a5768278 /x11-toolkits/gtk20
parent3ff5dd401514f8218c486739ad4a80c95e153725 (diff)
downloadports-040a50454d53f9a5d672cb4e3ba53fbe9c322322.tar.gz
ports-040a50454d53f9a5d672cb4e3ba53fbe9c322322.zip
Fix a bug that caused spurious crashes in metacity.
Special thanks goes to James Pole <james.pole@paradise.net.nz>, and Marc Recht <marc@informatik.uni-bremen.de> who provided information to GNOME's Bugzilla. More details on this bug can be found at: http://bugzilla.gnome.org/show_bug.cgi?id=97992 http://bugzilla.gnome.org/show_bug.cgi?id=94806 Obtained from: GNOME CVS
Notes
Notes: svn path=/head/; revision=70275
Diffstat (limited to 'x11-toolkits/gtk20')
-rw-r--r--x11-toolkits/gtk20/Makefile1
-rw-r--r--x11-toolkits/gtk20/files/patch-gdk_x11_gdkwindow-x11.c17
2 files changed, 18 insertions, 0 deletions
diff --git a/x11-toolkits/gtk20/Makefile b/x11-toolkits/gtk20/Makefile
index 5a7f53baf5fc..058ca497c8b7 100644
--- a/x11-toolkits/gtk20/Makefile
+++ b/x11-toolkits/gtk20/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gtk
PORTVERSION= 2.0.8
+PORTREVISION= 1
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_GNOME:S,%SUBDIR%,sources/gtk+/2.0,} \
ftp://ftp.gtk.org/pub/gtk/v2.0/ \
diff --git a/x11-toolkits/gtk20/files/patch-gdk_x11_gdkwindow-x11.c b/x11-toolkits/gtk20/files/patch-gdk_x11_gdkwindow-x11.c
new file mode 100644
index 000000000000..404e798d5bce
--- /dev/null
+++ b/x11-toolkits/gtk20/files/patch-gdk_x11_gdkwindow-x11.c
@@ -0,0 +1,17 @@
+This is a temporary patch. It is already in GNOME CVS, and will be merged in
+the next gtk+-2.0.x release. More details on what this patch fixes can be
+found at:
+
+http://bugzilla.gnome.org/show_bug.cgi?id=94806
+
+--- gdk/x11/gdkwindow-x11.c.orig Sat Nov 16 19:25:15 2002
++++ gdk/x11/gdkwindow-x11.c Sat Nov 16 19:26:16 2002
+@@ -202,6 +202,8 @@
+ &window_attributes);
+ drawable_impl->colormap =
+ gdk_colormap_lookup (window_attributes.colormap);
++ if (drawable_impl->colormap)
++ g_object_ref (drawable_impl->colormap);
+ }
+
+ return drawable_impl->colormap;