aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/gtk20
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2002-11-10 21:30:13 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2002-11-10 21:30:13 +0000
commit92e51de86bfa256240d58346161202b92ac77b8d (patch)
tree4bfc8467c6683fc26bf1795ebb4fefc71ad14800 /x11-toolkits/gtk20
parentd4e40f0105e92cf90a218bbc93f9069764c3d0f7 (diff)
downloadports-92e51de86bfa256240d58346161202b92ac77b8d.tar.gz
ports-92e51de86bfa256240d58346161202b92ac77b8d.zip
Update to 2.0.8.
Notes
Notes: svn path=/head/; revision=69848
Diffstat (limited to 'x11-toolkits/gtk20')
-rw-r--r--x11-toolkits/gtk20/Makefile3
-rw-r--r--x11-toolkits/gtk20/distinfo2
-rw-r--r--x11-toolkits/gtk20/files/patch-gdk-pixbuf_io-gif.c26
3 files changed, 2 insertions, 29 deletions
diff --git a/x11-toolkits/gtk20/Makefile b/x11-toolkits/gtk20/Makefile
index f6bd80a1add7..5a7f53baf5fc 100644
--- a/x11-toolkits/gtk20/Makefile
+++ b/x11-toolkits/gtk20/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gtk
-PORTVERSION= 2.0.7
-PORTREVISION= 2
+PORTVERSION= 2.0.8
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_GNOME:S,%SUBDIR%,sources/gtk+/2.0,} \
ftp://ftp.gtk.org/pub/gtk/v2.0/ \
diff --git a/x11-toolkits/gtk20/distinfo b/x11-toolkits/gtk20/distinfo
index 75d1313ba6b4..31204d5fdc85 100644
--- a/x11-toolkits/gtk20/distinfo
+++ b/x11-toolkits/gtk20/distinfo
@@ -1 +1 @@
-MD5 (gnome2/gtk+-2.0.7.tar.bz2) = c9f641a22400660555094506f298e9b8
+MD5 (gnome2/gtk+-2.0.8.tar.bz2) = 3f2fdc357494b9733175d6a7bbf5d786
diff --git a/x11-toolkits/gtk20/files/patch-gdk-pixbuf_io-gif.c b/x11-toolkits/gtk20/files/patch-gdk-pixbuf_io-gif.c
index 474e58bd04b9..e69de29bb2d1 100644
--- a/x11-toolkits/gtk20/files/patch-gdk-pixbuf_io-gif.c
+++ b/x11-toolkits/gtk20/files/patch-gdk-pixbuf_io-gif.c
@@ -1,26 +0,0 @@
---- gdk-pixbuf/io-gif.c.orig Thu Nov 7 18:08:02 2002
-+++ gdk-pixbuf/io-gif.c Thu Nov 7 18:14:25 2002
-@@ -534,13 +534,16 @@
- return 0;
- }
-
--#define CHECK_LZW_SP() if(((guchar *)context->lzw_sp) >= (((guchar *)context->lzw_stack) + sizeof(context->lzw_stack))) { \
-- g_set_error (context->error, \
-- GDK_PIXBUF_ERROR, \
-- GDK_PIXBUF_ERROR_CORRUPT_IMAGE, \
-- _("Stack overflow")); \
-- return -2; \
--}
-+#define CHECK_LZWP_SP() G_STMT_START { \
-+ if ((guchar *)context->lzw_sp >= \
-+ (guchar *)context->lzw_stack + sizeof (context->lzw_stack)) { \
-+ g_set_error (context->error, \
-+ GDK_PIXBUF_ERROR, \
-+ GDK_PIXBUF_ERROR_CORRUPT_IMAGE, \
-+ _("Stack overflow")); \
-+ return -2; \
-+ } \
-+} G_STMT_END
-
- static int
- lzw_read_byte (GifContext *context)