aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/gtkglext
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2013-12-23 13:59:27 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2013-12-23 13:59:27 +0000
commita58bf8b68d9711a5871c35fee1ef4b4040d7de99 (patch)
tree9296d839356f0218800ea958add3425980138234 /x11-toolkits/gtkglext
parentd2b901bed4f12c42c5a18865a4a753f4249eac10 (diff)
downloadports-a58bf8b68d9711a5871c35fee1ef4b4040d7de99.tar.gz
ports-a58bf8b68d9711a5871c35fee1ef4b4040d7de99.zip
- Support staging
- Use new LIB_DEPENDS syntax
Notes
Notes: svn path=/head/; revision=337245
Diffstat (limited to 'x11-toolkits/gtkglext')
-rw-r--r--x11-toolkits/gtkglext/Makefile25
1 files changed, 12 insertions, 13 deletions
diff --git a/x11-toolkits/gtkglext/Makefile b/x11-toolkits/gtkglext/Makefile
index 8e48924ffa1f..49aa44a16f48 100644
--- a/x11-toolkits/gtkglext/Makefile
+++ b/x11-toolkits/gtkglext/Makefile
@@ -13,16 +13,14 @@ COMMENT= OpenGL extension to GTK+
LICENSE= GPLv2
-LIB_DEPENDS= pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
- pcre:${PORTSDIR}/devel/pcre \
- cairo:${PORTSDIR}/graphics/cairo \
- drm:${PORTSDIR}/graphics/libdrm \
- png15:${PORTSDIR}/graphics/png \
- freetype:${PORTSDIR}/print/freetype2 \
- expat:${PORTSDIR}/textproc/expat2 \
- fontconfig:${PORTSDIR}/x11-fonts/fontconfig
-
-OPTIONS_DEFINE= DOCS
+LIB_DEPENDS= libpthread-stubs.so:${PORTSDIR}/devel/libpthread-stubs \
+ libpcre.so:${PORTSDIR}/devel/pcre \
+ libcairo.so:${PORTSDIR}/graphics/cairo \
+ libdrm.so:${PORTSDIR}/graphics/libdrm \
+ libpng15.so:${PORTSDIR}/graphics/png \
+ libfreetype.so:${PORTSDIR}/print/freetype2 \
+ libexpat.so:${PORTSDIR}/textproc/expat2 \
+ libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig
USE_BZIP2= yes
USE_AUTOTOOLS= libtool
@@ -33,7 +31,8 @@ USES= gettext gmake iconv pathfix pkgconfig
USE_GNOME= gdkpixbuf2 gtk20 pangox-compat
USE_LDCONFIG= yes
-NO_STAGE= yes
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-patch:
@@ -45,8 +44,8 @@ post-patch:
post-install:
.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/docs/reference/gtkglext/html/* ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/docs/reference/gtkglext/html/* ${STAGEDIR}${DOCSDIR}/
.endif
.include <bsd.port.mk>