aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/gtkmm24/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2006-10-14 08:54:54 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2006-10-14 08:54:54 +0000
commit29747f458a1eb2ce23b4594b09d0256dd62760b8 (patch)
tree1b71ba5d9ffdd308b6c18130f7c116f5bab5dc12 /x11-toolkits/gtkmm24/Makefile
parent7aad84f808b93baa6a7077ce0b47573b9c4c79a0 (diff)
downloadports-29747f458a1eb2ce23b4594b09d0256dd62760b8.tar.gz
ports-29747f458a1eb2ce23b4594b09d0256dd62760b8.zip
Chase the GNOME X11BASE to LOCALBASE move, and fix the build with the
new freetype2 where needed. Submitted by: mezz, ahze, pav, and many others Approved by: portmgr (implicit, kris)
Notes
Notes: svn path=/head/; revision=175261
Diffstat (limited to 'x11-toolkits/gtkmm24/Makefile')
-rw-r--r--x11-toolkits/gtkmm24/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/x11-toolkits/gtkmm24/Makefile b/x11-toolkits/gtkmm24/Makefile
index fdd2b8f73eb6..eed9bdca8398 100644
--- a/x11-toolkits/gtkmm24/Makefile
+++ b/x11-toolkits/gtkmm24/Makefile
@@ -3,11 +3,11 @@
# Whom: Martin Klaffenboeck <martin.klaffenboeck@gmx.at>
#
# $FreeBSD$
-# $MCom: ports/x11-toolkits/gtkmm24/Makefile,v 1.8 2005/10/20 16:16:50 marcus Exp $
+# $MCom: ports/x11-toolkits/gtkmm24/Makefile,v 1.20 2006/08/22 03:45:28 marcus Exp $
#
PORTNAME= gtkmm
-PORTVERSION= 2.8.8
+PORTVERSION= 2.10.1
PORTREVISION?= 0
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_GNOME}
@@ -22,15 +22,17 @@ LATEST_LINK= gtkmm24
.if !defined(REFERENCE_PORT)
-LIB_DEPENDS= glibmm-2.4.1:${PORTSDIR}/devel/glibmm
+LIB_DEPENDS= glibmm-2.4.1:${PORTSDIR}/devel/glibmm \
+ cairomm-1.0.1:${PORTSDIR}/graphics/cairomm
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
USE_GMAKE= yes
USE_GCC= 3.4
-USE_X_PREFIX= yes
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
USE_GNOME= gnomehack gtk20
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --disable-demos \
--disable-docs \
--disable-examples \
@@ -42,6 +44,8 @@ PLIST_SUB= VERSION="2.4" API_VERSION="2.4"
post-patch:
@${REINPLACE_CMD} -e '/^SUBDIRS =/s/tests//' \
${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's|demo[$$][(]EXEEXT[)]|gtkmm-demo$$(EXEEXT)|g' \
+ ${WRKSRC}/demos/gtk-demo/Makefile.in
.include <bsd.port.mk>