aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/itk
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2010-06-12 03:57:42 +0000
committerMikhail Teterin <mi@FreeBSD.org>2010-06-12 03:57:42 +0000
commit4327ccf070a01753d81028d55df4a6cf300cf60b (patch)
treedafb520ff5fa59643e76f7c69d080f9adfbed8d1 /x11-toolkits/itk
parent2bf8558f48732dbfe34e9ba71ad5d8ad4e8bed49 (diff)
downloadports-4327ccf070a01753d81028d55df4a6cf300cf60b.tar.gz
ports-4327ccf070a01753d81028d55df4a6cf300cf60b.zip
Upgrade itcl to 3.4b1 -- the last version in the 3.x branch.
itk, interestingly, remains at 3.3-RC, so only minor changes there. Allow both to compile against Tcl-8.5. Both will now need to be upgraded to branch 4.x -- a much more involved undertaking. Approved by: maintainer (in January)
Notes
Notes: svn path=/head/; revision=256430
Diffstat (limited to 'x11-toolkits/itk')
-rw-r--r--x11-toolkits/itk/Makefile15
-rw-r--r--x11-toolkits/itk/files/Makefile.lib2
2 files changed, 9 insertions, 8 deletions
diff --git a/x11-toolkits/itk/Makefile b/x11-toolkits/itk/Makefile
index 7acd462715cb..71c207502af4 100644
--- a/x11-toolkits/itk/Makefile
+++ b/x11-toolkits/itk/Makefile
@@ -7,7 +7,7 @@
PORTNAME= itk
PORTVERSION= 3.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11-toolkits tk
MASTER_SITES= SF/incrtcl/%5BIncr%20Tcl_Tk%5D-source/${PORTVERSION}-RC
DISTNAME= ${PORTNAME}${PORTVERSION}
@@ -17,7 +17,7 @@ COMMENT= Object-oriented extension to Tk [incr Tk]
LIB_DEPENDS= itcl.${MAJOR}:${PORTSDIR}/lang/itcl
-USE_TK= 84
+USE_TK= 84+
USE_LDCONFIG= yes
MAKE_ENV+= ${PLIST_SUB} \
SHLIB_MAJOR=${SHLIB_MAJOR} SHLIB_MINOR=${SHLIB_MINOR} \
@@ -31,19 +31,20 @@ MAJOR= ${PORTVERSION:R}
MINOR= ${PORTVERSION:E}
PLIST_SUB+= MAJOR=${MAJOR} MINOR=${MINOR}
ITK_LIB= libitk.so.${MAJOR}
-.if defined(MAKE_JOBS)
-MAKE_ARGS+= -j${MAKE_JOBS}
-.endif
+MAKE_JOBS_SAFE= yes
MANN= Archetype.n Toplevel.n Widget.n itk.n itkvars.n usual.n
ITK_LIB_FILE= ${ITK_LIB}.${SHLIB_MAJOR}
+.if defined(DISPLAY)
+post-build: test
+.else
post-build:
#
- # Consider running ``make test'' now, if the X11 environment
- # is available in this session
+ # DISPLAY is not set, so post-build testing is impossible
#
+.endif
test:
cd ${WRKSRC} && ${SETENV} ITK_LIBRARY=${WRKSRC}/library \
diff --git a/x11-toolkits/itk/files/Makefile.lib b/x11-toolkits/itk/files/Makefile.lib
index 5fbff64a0cd5..fec493992294 100644
--- a/x11-toolkits/itk/files/Makefile.lib
+++ b/x11-toolkits/itk/files/Makefile.lib
@@ -3,7 +3,7 @@ LIB= itk
ITK_LIBRARY= ${PREFIX}/lib/itk${MAJOR}.${MINOR}
CFLAGS+= -I. -I./../generic \
-I${TCL_INCLUDEDIR}/generic \
- -I${PREFIX}/include/itcl${MAJOR}.${MINOR}/ \
+ -I ${PREFIX}/include/itcl${MAJOR}.*/ \
-I${TK_INCLUDEDIR}/generic \
-I${LOCALBASE}/include \
-DHAVE_GETCWD=1 -DNO_VALUES_H=1 -DHAVE_UNISTD_H=1 -DUSE_TERMIOS=1\