aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/kf5-kitemviews
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2016-11-14 16:12:56 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2016-11-14 16:12:56 +0000
commit30a183cdd9faf4c65a08818c285c8d9351e43ad3 (patch)
treedbe08499461c3eea79dce8b1eca87e2699ef0d1c /x11-toolkits/kf5-kitemviews
parent1ff45cdd0ae918b61cf33786436856d37aa2dcfb (diff)
downloadports-30a183cdd9faf4c65a08818c285c8d9351e43ad3.tar.gz
ports-30a183cdd9faf4c65a08818c285c8d9351e43ad3.zip
Importing KDE Frameworks into the ports tree (required for newer KDE Desktop and Applications)
KDE Frameworks is a collection of libraries and software frameworks by KDE that serve as technological foundation for KDE Plasma 5 and KDE Applications distributed under the GNU Lesser General Public License (LGPL) [1]. The work is based on what we have in the KDE testing repo [2]. This is the next big step in updating the KDE Desktop and its Applications to anything less dusty. With this change, `USES=kde:5` is now a valid option. Ports that need to depend on KDE Framework can now set: USES=kde:5 USE_KDE=<framework1> <framework2> ... <frameworkX> For example: www/qupzilla-qt5 can depend on sysutils/kf5-kwallet via: KWALLET_USE= KDE=wallet I would like to thank Raphael and Adriaan for reviewing the ports in the testing repo :) [1] https://en.wikipedia.org/wiki/KDE_Frameworks [2] http://src.mouf.net/area51/log/branches/plasma5 Reviewed by: rakuco, mat, groot_kde.org Approved by: rakuco (maintainer) Differential Revision: https://reviews.freebsd.org/D8329
Notes
Notes: svn path=/head/; revision=426118
Diffstat (limited to 'x11-toolkits/kf5-kitemviews')
-rw-r--r--x11-toolkits/kf5-kitemviews/Makefile16
-rw-r--r--x11-toolkits/kf5-kitemviews/distinfo3
-rw-r--r--x11-toolkits/kf5-kitemviews/pkg-descr5
-rw-r--r--x11-toolkits/kf5-kitemviews/pkg-plist128
4 files changed, 152 insertions, 0 deletions
diff --git a/x11-toolkits/kf5-kitemviews/Makefile b/x11-toolkits/kf5-kitemviews/Makefile
new file mode 100644
index 000000000000..d529967e9e75
--- /dev/null
+++ b/x11-toolkits/kf5-kitemviews/Makefile
@@ -0,0 +1,16 @@
+# Created by: tcberner
+# $FreeBSD$
+
+PORTNAME= kitemviews
+PORTVERSION= ${KDE_FRAMEWORKS_VERSION}
+CATEGORIES= x11-toolkits kde kde-frameworks
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= KF5 widget addons for Qt Model/View
+
+USES= cmake:outsource compiler:c++11-lib kde:5 tar:xz
+USE_KDE= ecm
+USE_QT5= buildtools_build core gui linguisttools qmake_build \
+ testlib widgets
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/kf5-kitemviews/distinfo b/x11-toolkits/kf5-kitemviews/distinfo
new file mode 100644
index 000000000000..9098a2790234
--- /dev/null
+++ b/x11-toolkits/kf5-kitemviews/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1475424086
+SHA256 (KDE/frameworks/5.27.0/kitemviews-5.27.0.tar.xz) = 7daedd694c6e67d6769c87977b18adc1127f4e9836d10fdb0d7130e14188c990
+SIZE (KDE/frameworks/5.27.0/kitemviews-5.27.0.tar.xz) = 2512052
diff --git a/x11-toolkits/kf5-kitemviews/pkg-descr b/x11-toolkits/kf5-kitemviews/pkg-descr
new file mode 100644
index 000000000000..b04d5c49a0df
--- /dev/null
+++ b/x11-toolkits/kf5-kitemviews/pkg-descr
@@ -0,0 +1,5 @@
+KItemViews includes a set of views, which can be used with item models.
+It includes views for categorizing lists and to add search filters to
+flat and hierarchical lists.
+
+WWW: http://api.kde.org/frameworks-api/frameworks5-apidocs/kitemviews/html/index.html
diff --git a/x11-toolkits/kf5-kitemviews/pkg-plist b/x11-toolkits/kf5-kitemviews/pkg-plist
new file mode 100644
index 000000000000..13b86cb4f4e5
--- /dev/null
+++ b/x11-toolkits/kf5-kitemviews/pkg-plist
@@ -0,0 +1,128 @@
+include/KF5/KItemViews/KCategorizedSortFilterProxyModel
+include/KF5/KItemViews/KCategorizedView
+include/KF5/KItemViews/KCategoryDrawer
+include/KF5/KItemViews/KExtendableItemDelegate
+include/KF5/KItemViews/KFilterProxySearchLine
+include/KF5/KItemViews/KListWidgetSearchLine
+include/KF5/KItemViews/KTreeWidgetSearchLine
+include/KF5/KItemViews/KTreeWidgetSearchLineWidget
+include/KF5/KItemViews/KWidgetItemDelegate
+include/KF5/KItemViews/kcategorizedsortfilterproxymodel.h
+include/KF5/KItemViews/kcategorizedview.h
+include/KF5/KItemViews/kcategorydrawer.h
+include/KF5/KItemViews/kextendableitemdelegate.h
+include/KF5/KItemViews/kfilterproxysearchline.h
+include/KF5/KItemViews/kitemviews_export.h
+include/KF5/KItemViews/klistwidgetsearchline.h
+include/KF5/KItemViews/ktreewidgetsearchline.h
+include/KF5/KItemViews/ktreewidgetsearchlinewidget.h
+include/KF5/KItemViews/kwidgetitemdelegate.h
+include/KF5/kitemviews_version.h
+lib/cmake/KF5ItemViews/KF5ItemViewsConfig.cmake
+lib/cmake/KF5ItemViews/KF5ItemViewsConfigVersion.cmake
+lib/cmake/KF5ItemViews/KF5ItemViewsTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/KF5ItemViews/KF5ItemViewsTargets.cmake
+lib/libKF5ItemViews.so
+lib/libKF5ItemViews.so.5
+lib/libKF5ItemViews.so.%%KDE_FRAMEWORKS_VERSION%%
+%%QT_MKSPECDIR%%/modules/qt_KItemViews.pri
+share/locale/af/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/ar/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/as/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/ast/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/be/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/be@latin/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/bg/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/bn/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/bn_IN/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/br/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/bs/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/ca/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/ca@valencia/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/crh/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/cs/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/csb/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/cy/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/da/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/de/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/el/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/en_GB/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/eo/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/es/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/et/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/eu/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/fa/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/fi/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/fr/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/fy/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/ga/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/gd/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/gl/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/gu/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/ha/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/he/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/hi/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/hne/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/hr/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/hsb/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/hu/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/hy/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/ia/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/id/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/is/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/it/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/ja/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/ka/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/kk/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/km/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/kn/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/ko/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/ku/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/lb/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/lt/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/lv/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/mai/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/mk/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/ml/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/mr/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/ms/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/nb/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/nds/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/ne/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/nl/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/nn/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/oc/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/or/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/pa/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/pl/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/ps/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/pt/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/pt_BR/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/ro/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/ru/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/se/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/si/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/sk/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/sl/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/sq/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/sr/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/sr@ijekavian/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/sr@ijekavianlatin/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/sr@latin/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/sv/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/ta/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/te/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/tg/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/th/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/tr/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/tt/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/ug/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/uk/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/uz/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/uz@cyrillic/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/vi/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/wa/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/xh/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/zh_CN/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/zh_HK/LC_MESSAGES/kitemviews5_qt.qm
+share/locale/zh_TW/LC_MESSAGES/kitemviews5_qt.qm