aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/libgnomeuimm/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-06-15 23:09:08 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-06-15 23:09:08 +0000
commiteef3a5a67c88419cc55472e63b14bfc35b16bbaf (patch)
treec4889fce9874a938bd2fefa3b018d813b43afd89 /x11-toolkits/libgnomeuimm/Makefile
parent098bc24e38120f9a170019dd2f3c991fb979ca14 (diff)
downloadports-eef3a5a67c88419cc55472e63b14bfc35b16bbaf.tar.gz
ports-eef3a5a67c88419cc55472e63b14bfc35b16bbaf.zip
Add libgnomeuimm, the C++ bindings for libgnomeui.
Submitted by: Alexander Nedotsukov <bland@mail.ru>
Notes
Notes: svn path=/head/; revision=83070
Diffstat (limited to 'x11-toolkits/libgnomeuimm/Makefile')
-rw-r--r--x11-toolkits/libgnomeuimm/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11-toolkits/libgnomeuimm/Makefile b/x11-toolkits/libgnomeuimm/Makefile
new file mode 100644
index 000000000000..8eda4ce935d1
--- /dev/null
+++ b/x11-toolkits/libgnomeuimm/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: libgnomeuimm
+# Date created: 22 May 2003
+# Whom: Alexander Nedotsukov <bland@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libgnomeuimm
+PORTVERSION= 1.3.16
+CATEGORIES= x11-toolkits gnome
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= gtkmm
+DIST_SUBDIR= gnome2
+
+MAINTAINER= bland@mail.ru
+COMMENT= C++ wrapper for libgnomeui library
+
+LIB_DEPENDS= gnomemm-1.3:${PORTSDIR}/x11/libgnomemm \
+ gnomecanvasmm-2.0:${PORTSDIR}/graphics/libgnomecanvasmm \
+ gconfmm-2.0:${PORTSDIR}/devel/gconfmm \
+ bonobouimm_servers-1.3:${PORTSDIR}/x11-toolkits/libbonobouimm \
+ glademm-2.0:${PORTSDIR}/devel/libglademm
+BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_GNOME= libgnomeui
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
+CONFIGURE_ARGS= --enable-static
+
+.include <bsd.port.mk>