aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/libwnck/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2002-04-24 16:06:45 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2002-04-24 16:06:45 +0000
commitec8563a2daa00635ccc6c6a601f4ec82f9b8625c (patch)
tree59d140704b4989ca53670f75ddd6f0b90537df2e /x11-toolkits/libwnck/Makefile
parent3f6a14b8696883ecf8ad811408965690d003b58b (diff)
downloadports-ec8563a2daa00635ccc6c6a601f4ec82f9b8625c.tar.gz
ports-ec8563a2daa00635ccc6c6a601f4ec82f9b8625c.zip
Add libwnck, an GNOME 2.0 API for building pagers and tasklists.
Reviewed by: sobomax Approved by: sobomax
Notes
Notes: svn path=/head/; revision=58067
Diffstat (limited to 'x11-toolkits/libwnck/Makefile')
-rw-r--r--x11-toolkits/libwnck/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-toolkits/libwnck/Makefile b/x11-toolkits/libwnck/Makefile
new file mode 100644
index 000000000000..4726153e0452
--- /dev/null
+++ b/x11-toolkits/libwnck/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: libwnck
+# Date created: 12 April 2002
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libwnck
+PORTVERSION= 0.7
+CATEGORIES= x11-toolkits gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= pre-gnome2/releases/gnome-2.0-desktop-beta3
+DIST_SUBDIR= gnome2
+
+MAINTAINER= gnome@FreeBSD.org
+
+LIB_DEPENDS= gtk-x11-2.0.0:${PORTSDIR}/x11-toolkits/gtk20
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_BISON= yes
+INSTALLS_SHLIB= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
+
+pre-patch:
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
+ 's|\$\(libdir\)/pkgconfig|\$\(prefix\)/libdata/pkgconfig|g'
+
+.include <bsd.port.mk>