aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/linux-qt33
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2007-05-25 14:16:34 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2007-05-25 14:16:34 +0000
commit3f2976d2e538bcce64f5a9d4b2331f084876d581 (patch)
tree8119008b179f9b51d26865d51c22218d10c575ad /x11-toolkits/linux-qt33
parentbc946f8825e206bcb80de51829ab0b7c622873b5 (diff)
downloadports-3f2976d2e538bcce64f5a9d4b2331f084876d581.tar.gz
ports-3f2976d2e538bcce64f5a9d4b2331f084876d581.zip
Qt sets the standard for high-performance, cross-platform application
development. It includes a C++ class library and tools for cross-platform development and internationalization. This is a port of linux libraries of QT3. WWW: http://trolltech.com/products/qt/qt3
Notes
Notes: svn path=/head/; revision=191787
Diffstat (limited to 'x11-toolkits/linux-qt33')
-rw-r--r--x11-toolkits/linux-qt33/Makefile26
-rw-r--r--x11-toolkits/linux-qt33/distinfo.i3866
-rw-r--r--x11-toolkits/linux-qt33/pkg-descr7
-rw-r--r--x11-toolkits/linux-qt33/pkg-plist.i38624
4 files changed, 63 insertions, 0 deletions
diff --git a/x11-toolkits/linux-qt33/Makefile b/x11-toolkits/linux-qt33/Makefile
new file mode 100644
index 000000000000..347e898de162
--- /dev/null
+++ b/x11-toolkits/linux-qt33/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: linux-qt33
+# Date created: 24 May 2007
+# Whom: Boris Samorodov <bsam@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= qt33
+PORTVERSION= 3.3.4
+CATEGORIES= x11-toolkits linux
+DISTNAME= qt-${PORTVERSION}-${RPMVERSION}
+
+MAINTAINER= bsam@FreeBSD.org
+COMMENT= RPM of QT3
+
+RUN_DEPENDS= ${LINUXBASE}/usr/lib/libfontconfig.so.1:${PORTSDIR}/x11-fonts/linux-fontconfig \
+ ${LINUXBASE}/usr/lib/libmng.so.1:${PORTSDIR}/graphics/linux-libmng \
+ ${LINUXBASE}/usr/lib/libpng12.so.0:${PORTSDIR}/graphics/linux-png
+
+USE_LINUX_RPM= yes
+RPMVERSION= 15.5
+LINUX_DIST_VER= 4
+INSTALLS_SHLIB= yes
+PLIST= pkg-plist.${LINUX_RPM_ARCH}
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/linux-qt33/distinfo.i386 b/x11-toolkits/linux-qt33/distinfo.i386
new file mode 100644
index 000000000000..8ca333dbd9b9
--- /dev/null
+++ b/x11-toolkits/linux-qt33/distinfo.i386
@@ -0,0 +1,6 @@
+MD5 (rpm/i386/fedora/4/qt-3.3.4-15.5.i386.rpm) = 5aa111ea32f15633c47995cefd4266de
+SHA256 (rpm/i386/fedora/4/qt-3.3.4-15.5.i386.rpm) = 5555fa517fddd95162dda31454c1fe59b2a2ba044c7de25456a45cfbd5ee84dd
+SIZE (rpm/i386/fedora/4/qt-3.3.4-15.5.i386.rpm) = 3579405
+MD5 (rpm/i386/fedora/4/qt-3.3.4-15.5.src.rpm) = 0246f9ead583ad0e9cb07b67c60c100f
+SHA256 (rpm/i386/fedora/4/qt-3.3.4-15.5.src.rpm) = a7fe548262634e3299fc63cd80249705647e6246262178ed0e289a54e65fbdf8
+SIZE (rpm/i386/fedora/4/qt-3.3.4-15.5.src.rpm) = 14633006
diff --git a/x11-toolkits/linux-qt33/pkg-descr b/x11-toolkits/linux-qt33/pkg-descr
new file mode 100644
index 000000000000..a7e47269b0bf
--- /dev/null
+++ b/x11-toolkits/linux-qt33/pkg-descr
@@ -0,0 +1,7 @@
+Qt sets the standard for high-performance, cross-platform application
+development. It includes a C++ class library and tools for cross-platform
+development and internationalization.
+
+This is a port of linux libraries of QT3.
+
+WWW: http://trolltech.com/products/qt/qt3
diff --git a/x11-toolkits/linux-qt33/pkg-plist.i386 b/x11-toolkits/linux-qt33/pkg-plist.i386
new file mode 100644
index 000000000000..26e161c07ca1
--- /dev/null
+++ b/x11-toolkits/linux-qt33/pkg-plist.i386
@@ -0,0 +1,24 @@
+etc/ld.so.conf.d/qt-i386.conf
+usr/lib/qt-3.3/lib/libqt-mt.so.3
+usr/lib/qt-3.3/lib/libqt-mt.so.3.3
+usr/lib/qt-3.3/lib/libqt-mt.so.3.3.4
+usr/lib/qt-3.3/lib/libqui.so.1
+usr/lib/qt-3.3/lib/libqui.so.1.0
+usr/lib/qt-3.3/lib/libqui.so.1.0.0
+usr/lib/qt-3.3/plugins/inputmethods/libqimsw-multi.so
+usr/lib/qt-3.3/plugins/inputmethods/libqimsw-none.so
+usr/lib/qt-3.3/plugins/inputmethods/libqsimple.so
+usr/lib/qt-3.3/plugins/inputmethods/libqxim.so
+usr/share/doc/qt-3.3.4/FAQ
+usr/share/doc/qt-3.3.4/LICENSE.QPL
+usr/share/doc/qt-3.3.4/README
+usr/share/doc/qt-3.3.4/README-QT.TXT
+usr/share/doc/qt-3.3.4/README.immodule
+usr/share/doc/qt-3.3.4/changes-3.3.4
+usr/share/doc/qt-3.3.4/changes.immodule
+@dirrm usr/share/doc/qt-3.3.4
+@dirrm usr/lib/qt-3.3/plugins/inputmethods
+@dirrm usr/lib/qt-3.3/plugins
+@dirrm usr/lib/qt-3.3/lib
+@dirrm usr/lib/qt-3.3/bin
+@dirrm usr/lib/qt-3.3