aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/mygui/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-12-01 13:53:44 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-12-01 13:53:44 +0000
commitd7491e475233fd5fd0e66905b0014fec67fdff1d (patch)
tree4ed517b2d26c5a232a6f83d4b4bf924834b61b88 /x11-toolkits/mygui/Makefile
parentdb357a8aa8f49102a3cbe5deae16577fe8d185c3 (diff)
downloadports-d7491e475233fd5fd0e66905b0014fec67fdff1d.tar.gz
ports-d7491e475233fd5fd0e66905b0014fec67fdff1d.zip
- Update to 3.2.2
PR: 204810 Submitted by: tobias.kortkamp@gmail.com
Notes
Notes: svn path=/head/; revision=402736
Diffstat (limited to 'x11-toolkits/mygui/Makefile')
-rw-r--r--x11-toolkits/mygui/Makefile24
1 files changed, 14 insertions, 10 deletions
diff --git a/x11-toolkits/mygui/Makefile b/x11-toolkits/mygui/Makefile
index 89d642613ca3..f701f015d8d7 100644
--- a/x11-toolkits/mygui/Makefile
+++ b/x11-toolkits/mygui/Makefile
@@ -2,24 +2,28 @@
# $FreeBSD$
PORTNAME= mygui
-PORTVERSION= 3.2.1.svn20140422
-PORTREVISION= 1
+PORTVERSION= 3.2.2
+DISTVERSIONPREFIX= MyGUI
CATEGORIES= x11-toolkits graphics devel
-MASTER_SITES= http://mirror.amdmi3.ru/distfiles/
-# SF/my-gui/MyGUI/MyGUI_${PORTVERSION}
-DISTNAME= MyGUI_${PORTVERSION}
MAINTAINER= amdmi3@FreeBSD.org
-COMMENT= Fast, simple and flexible GUI system for Ogre engine
+COMMENT= Fast, simple and flexible GUI system for games and 3D applications
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/COPYING.MIT
LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2 \
- libOgreMain.so:${PORTSDIR}/graphics/ogre3d \
libOIS.so:${PORTSDIR}/devel/ois
-USES= cmake pkgconfig zip dos2unix compiler:c++11-lib
-CMAKE_ARGS= -DMYGUI_BUILD_DEMOS=OFF -DMYGUI_BUILD_DOCS=OFF
+USE_GITHUB= yes
+GH_ACCOUNT= MyGUI
+
+USES= cmake:outsource compiler:c++11-lib ninja pkgconfig
+CMAKE_ARGS+= -DMYGUI_BUILD_DEMOS=FALSE \
+ -DMYGUI_BUILD_TOOLS=FALSE \
+ -DMYGUI_BUILD_DOCS=FALSE \
+ -DMYGUI_RENDERSYSTEM=1 # Dummy
USE_LDCONFIG= yes
-DOS2UNIX_GLOB= *.cpp *.h *.cmake
USE_CXXSTD= c++11
CXXFLAGS+= -fPIC