aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/p5-Gtk2-Ex-Utils/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-08-19 23:05:01 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-08-19 23:05:01 +0000
commitdf2ed5bf4e7e5cc6f58ce4e56275bc32171fd625 (patch)
tree91474c0beeb15229bd8c8ddd71127a6e09038724 /x11-toolkits/p5-Gtk2-Ex-Utils/Makefile
parent1a10d345d893ab0b76f1dfbfc1e675c7d0ed5dca (diff)
downloadports-df2ed5bf4e7e5cc6f58ce4e56275bc32171fd625.tar.gz
ports-df2ed5bf4e7e5cc6f58ce4e56275bc32171fd625.zip
Gtk2-Ex-Utils provides simple utility functions for
Gnome/Gtk2 Perl programming. WWW: http://search.cpan.org/dist/Gtk2-Ex-Utils/ PR: ports/125888 Submitted by: Paul Schmehl <pauls at utdallas.edu>
Notes
Notes: svn path=/head/; revision=218882
Diffstat (limited to 'x11-toolkits/p5-Gtk2-Ex-Utils/Makefile')
-rw-r--r--x11-toolkits/p5-Gtk2-Ex-Utils/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/x11-toolkits/p5-Gtk2-Ex-Utils/Makefile b/x11-toolkits/p5-Gtk2-Ex-Utils/Makefile
new file mode 100644
index 000000000000..f0a8f7b6fd7d
--- /dev/null
+++ b/x11-toolkits/p5-Gtk2-Ex-Utils/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-Gtk2-Ex-Utils
+# Date created: 22 July 2008
+# Whom: Paul Schmehl <pauls@utdallas.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Gtk2-Ex-Utils
+PORTVERSION= 0.09
+CATEGORIES= x11-toolkits perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= pauls@utdallas.edu
+COMMENT= Extra Gtk2 utilities for Gtk2 in perl
+
+BUILD_DEPENDS= p5-Glib2>=1.00:${PORTSDIR}/devel/p5-Glib2 \
+ p5-ExtUtils-Depends>=0.3:${PORTSDIR}/devel/p5-ExtUtils-Depends \
+ p5-ExtUtils-PkgConfig>=1.1:${PORTSDIR}/devel/p5-ExtUtils-PkgConfig \
+ p5-Gtk2>=1.060:${PORTSDIR}/x11-toolkits/p5-Gtk2 \
+ ${SITE_PERL}/${PERL_ARCH}/Cairo.pm:${PORTSDIR}/graphics/p5-Cairo
+RUN_DEPENDS= p5-Glib2>=1.00:${PORTSDIR}/devel/p5-Glib2 \
+ p5-Gtk2>=1.060:${PORTSDIR}/x11-toolkits/p5-Gtk
+
+PERL_CONFIGURE= yes
+
+MAN3= Gtk2::Ex::Constants.3 \
+ Gtk2::Ex::Utils.3
+
+.include <bsd.port.mk>