aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/p5-Prima/Makefile
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2001-12-14 23:53:42 +0000
committerAnton Berezin <tobez@FreeBSD.org>2001-12-14 23:53:42 +0000
commitd3a6f89beed8813f7e33a22c5dce3d05bedbf983 (patch)
treeab6fca987d23b959045e4bea727e5f0c04407c7c /x11-toolkits/p5-Prima/Makefile
parentb19237b6e75430f5e648b3d29d52294d12d400ef (diff)
downloadports-d3a6f89beed8813f7e33a22c5dce3d05bedbf983.tar.gz
ports-d3a6f89beed8813f7e33a22c5dce3d05bedbf983.zip
Add p5-Prima 1.03, an extensible Perl toolkit for multi-platform GUI
development. PR: 31158 Submitted by: dmitry@karasik.eu.org
Notes
Notes: svn path=/head/; revision=51542
Diffstat (limited to 'x11-toolkits/p5-Prima/Makefile')
-rw-r--r--x11-toolkits/p5-Prima/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/x11-toolkits/p5-Prima/Makefile b/x11-toolkits/p5-Prima/Makefile
new file mode 100644
index 000000000000..a03938dc0d09
--- /dev/null
+++ b/x11-toolkits/p5-Prima/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: Prima
+# Date created: 27 July 2001
+# Whom: dmitry@karasik.eu.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= Prima
+PORTVERSION= 1.03
+CATEGORIES= x11-toolkits perl5 graphics
+MASTER_SITES= http://www.prima.eu.org/download/
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= dmitry@karasik.eu.org
+
+LIB_DEPENDS= ungif.5:${PORTSDIR}/graphics/libungif \
+ png.5:${PORTSDIR}/graphics/png \
+ jpeg.9:${PORTSDIR}/graphics/jpeg
+
+PERL_CONFIGURE= yes
+
+test: build
+ cd ${WRKSRC} && make test
+
+post-install:
+ strip ${PREFIX}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/auto/Prima/Prima.so
+
+.include <bsd.port.mk>