aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/pangoxsl/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-01-09 23:10:59 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-01-09 23:10:59 +0000
commit095c9185e8d2c704920e3b4475807f4acb17e887 (patch)
treeecc5d97602e0d22a194f3c62e0a6f0c5ba6f760c /x11-toolkits/pangoxsl/Makefile
parent6a29d2ca544eeddd919d20509f028071a683aaa5 (diff)
downloadports-095c9185e8d2c704920e3b4475807f4acb17e887.tar.gz
ports-095c9185e8d2c704920e3b4475807f4acb17e887.zip
Add pangoxsl, a version of the Pango library with a PDF backend for
creating PDF output. This library also implements several of the inline properties defined by XSL that are not currently implemented by Pango. PR: ports/75971 Submitted by: James Earl <james@icionline.ca>
Notes
Notes: svn path=/head/; revision=126009
Diffstat (limited to 'x11-toolkits/pangoxsl/Makefile')
-rw-r--r--x11-toolkits/pangoxsl/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/x11-toolkits/pangoxsl/Makefile b/x11-toolkits/pangoxsl/Makefile
new file mode 100644
index 000000000000..234636479c46
--- /dev/null
+++ b/x11-toolkits/pangoxsl/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: pangoxsl
+# Date created: 1 January 2005
+# Whom: James Earl
+#
+# $FreeBSD$
+#
+
+PORTNAME= pangoxsl
+PORTVERSION= 1.6.0.0
+CATEGORIES= x11-toolkits
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= pangopdf
+
+MAINTAINER= chero7@telus.net
+COMMENT= Implements Pango library with a PDF backend for PDF output
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_GNOME= gnomehack pango
+INSTALLS_SHLIB= yes
+USE_LIBTOOL_VER=15
+CONFIGURE_ARGS= --disable-gtk-doc \
+ --with-html-dir=${PREFIX}/share/doc
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>