aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/py-gtk2
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2010-05-17 09:40:21 +0000
committerKoop Mast <kwm@FreeBSD.org>2010-05-17 09:40:21 +0000
commit45f3157a88ad828628706cc83694074b83f72ab1 (patch)
tree6925693815fc293e7ec057b24a41b5aa5748c561 /x11-toolkits/py-gtk2
parent43e55b3fc492ea587fe59ead1a3973b2ccf9f0e8 (diff)
downloadports-45f3157a88ad828628706cc83694074b83f72ab1.tar.gz
ports-45f3157a88ad828628706cc83694074b83f72ab1.zip
Make numpy optional, defaulting to off. Because it depends gcc44.
Notes
Notes: svn path=/head/; revision=254480
Diffstat (limited to 'x11-toolkits/py-gtk2')
-rw-r--r--x11-toolkits/py-gtk2/Makefile18
1 files changed, 15 insertions, 3 deletions
diff --git a/x11-toolkits/py-gtk2/Makefile b/x11-toolkits/py-gtk2/Makefile
index 9b77e3c541c1..e09eb9658e47 100644
--- a/x11-toolkits/py-gtk2/Makefile
+++ b/x11-toolkits/py-gtk2/Makefile
@@ -19,10 +19,10 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= A set of Python bindings for GTK+
-BUILD_DEPENDS= ${PYNUMPY} \
+BUILD_DEPENDS= \
${PYTHON_SITELIBDIR}/cairo/__init__.py:${PORTSDIR}/graphics/py-cairo \
${PYTHON_SITELIBDIR}/gtk-2.0/gobject/_gobject.so:${PORTSDIR}/devel/py-gobject
-RUN_DEPENDS= ${PYNUMPY} \
+RUN_DEPENDS= \
${PYTHON_SITELIBDIR}/cairo/__init__.py:${PORTSDIR}/graphics/py-cairo \
${PYTHON_SITELIBDIR}/gtk-2.0/gobject/_gobject.so:${PORTSDIR}/devel/py-gobject
@@ -45,6 +45,18 @@ EXAMPLESDIR= ${PREFIX}/share/examples/py-gtk
CONFLICTS= py*-gtk-0*
+OPTIONS= NUMPY "Enable numpy support (pulls in gcc44)" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_NYMPY)
+BUILD_DEPENDS+= ${PYNUMPY}
+RUN_DEPENDS+= ${PYNUMPY}
+CONFIGURE_ARGS+=--enable-numpy
+.else
+CONFIGURE_ARGS+=--disable-numpy
+.endif
+
#
# Use the same way as the Python port to determine if we want
# threading support.
@@ -74,4 +86,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/THREADS ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>