aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/py-gtk2
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-07-25 20:43:12 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-07-25 20:43:12 +0000
commit9bdf980e0d4d30ca4e8582597f0b40a2c2114390 (patch)
treee64a55c85e93753c10903e0f160acb8221128c11 /x11-toolkits/py-gtk2
parent23f6fcf564c0d957a01c98a585af4c9d24c7e37b (diff)
downloadports-9bdf980e0d4d30ca4e8582597f0b40a2c2114390.tar.gz
ports-9bdf980e0d4d30ca4e8582597f0b40a2c2114390.zip
* Fix detection of i18n support [1]
* Use the new libtool scheme Reported by: Rui Lopes <rui@ruilopes.com> [1]
Notes
Notes: svn path=/head/; revision=114708
Diffstat (limited to 'x11-toolkits/py-gtk2')
-rw-r--r--x11-toolkits/py-gtk2/Makefile8
-rw-r--r--x11-toolkits/py-gtk2/files/patch-configure10
-rw-r--r--x11-toolkits/py-gtk2/files/patch-ltmain.sh19
3 files changed, 6 insertions, 31 deletions
diff --git a/x11-toolkits/py-gtk2/Makefile b/x11-toolkits/py-gtk2/Makefile
index 6eb3862064d6..bfa643ea5972 100644
--- a/x11-toolkits/py-gtk2/Makefile
+++ b/x11-toolkits/py-gtk2/Makefile
@@ -6,7 +6,7 @@
PORTNAME= gtk
PORTVERSION= 2.2.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11-toolkits python
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/pygtk/2.2
@@ -23,7 +23,11 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_GNOME= gnomehack gnometarget libglade2
USE_PYTHON= yes
-USE_LIBTOOL_VER=13
+USE_LIBTOOL_VER=15
+USE_GETTEXT= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-lintl"
+LDFLAGS+= -L${LOCALBASE}/lib
EG_SRC_DIR= ${WRKSRC}/examples
EG_DST_DIR= ${PREFIX}/share/examples/py-gtk
diff --git a/x11-toolkits/py-gtk2/files/patch-configure b/x11-toolkits/py-gtk2/files/patch-configure
deleted file mode 100644
index db094d10bcf0..000000000000
--- a/x11-toolkits/py-gtk2/files/patch-configure
+++ /dev/null
@@ -1,10 +0,0 @@
---- configure.orig Sun Mar 23 21:43:20 2003
-+++ configure Sun Mar 23 21:43:42 2003
-@@ -7958,6 +7958,7 @@
-
- # This can be used to rebuild libtool when needed
- LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
-
- # Always use our own libtool.
- LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/x11-toolkits/py-gtk2/files/patch-ltmain.sh b/x11-toolkits/py-gtk2/files/patch-ltmain.sh
deleted file mode 100644
index 7cefa767ece6..000000000000
--- a/x11-toolkits/py-gtk2/files/patch-ltmain.sh
+++ /dev/null
@@ -1,19 +0,0 @@
---- ltmain.sh.orig Sun Mar 23 21:36:18 2003
-+++ ltmain.sh Sun Mar 23 21:38:57 2003
-@@ -1085,8 +1085,16 @@
- continue
- ;;
-
-+ -pthread)
-+ compile_command="$compile_command -pthread"
-+ finalize_command="$finalize_command -pthread"
-+ compiler_flags="$compiler_flags -pthread"
-+ continue
-+ ;;
-+
- -module)
- module=yes
-+ build_old_libs=no
- continue
- ;;
-