aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/py-tkinter/Makefile
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2013-03-01 20:12:01 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2013-03-01 20:12:01 +0000
commit4e54190b40cb1ff1a2a891114bb7d3e3fe67fe80 (patch)
tree9e4d3fe5352ce6de3984761a86925f44ac9e3e62 /x11-toolkits/py-tkinter/Makefile
parentced553b72215212e3adcf0830cca9fd8982312d1 (diff)
downloadports-4e54190b40cb1ff1a2a891114bb7d3e3fe67fe80.tar.gz
ports-4e54190b40cb1ff1a2a891114bb7d3e3fe67fe80.zip
- Install standard libraries separated as other ports to the same place
with other standard libraries (${PYTHON_LIBDIR}/lib-dynload) - Improve consistency of the Makefile(s) - Whitespace cleanup for the patches
Notes
Notes: svn path=/head/; revision=313167
Diffstat (limited to 'x11-toolkits/py-tkinter/Makefile')
-rw-r--r--x11-toolkits/py-tkinter/Makefile26
1 files changed, 13 insertions, 13 deletions
diff --git a/x11-toolkits/py-tkinter/Makefile b/x11-toolkits/py-tkinter/Makefile
index 93b9235edc81..f69a1c4aa88e 100644
--- a/x11-toolkits/py-tkinter/Makefile
+++ b/x11-toolkits/py-tkinter/Makefile
@@ -1,32 +1,32 @@
-# New ports collection makefile for: py-Tkinter
-# Date created: 12 Jan 1999
-# Whom: Thomas Gellekum <tg@FreeBSD.org>
-#
+# Created by: Thomas Gellekum <tg@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= tkinter
PORTVERSION= ${PYTHON_PORTVERSION}
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= x11-toolkits python
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTFILES= ${PYTHON_DISTFILE}
-MAINTAINER?= python@FreeBSD.org
+MAINTAINER= python@FreeBSD.org
COMMENT= Python bindings to the Tk widget set
-DIST_SUBDIR= python
-PLIST_FILES= %%PYTHON_SITELIBDIR%%/_tkinter.so
USE_PYTHON= yes
USE_PYDISTUTILS=yes
+USE_TK= yes
USE_XZ= yes
-PYDISTUTILS_PKGNAME= Tkinter
-PYDISTUTILS_PKGVERSION= 0.0.0
-USE_TK= 83+
-WRKSRC= ${PYTHON_WRKSRC}/Modules
+
+DIST_SUBDIR= python
DISTINFO_FILE= ${PORTSDIR}/lang/python${PYTHON_SUFFIX}/distinfo
+WRKSRC= ${PYTHON_WRKSRC}/Modules
+
+PYDISTUTILS_INSTALLARGS+= --install-lib ${PYTHON_LIBDIR}/lib-dynload
+PYDISTUTILS_NOEGGINFO= yes
+PYDISTUTILS_PKGNAME= Tkinter
+
+PLIST_FILES= %%PYTHON_LIBDIR%%/lib-dynload/_tkinter.so
.include <bsd.port.pre.mk>