aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/py-tkinter/Makefile
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>2000-04-04 09:53:12 +0000
committerThomas Gellekum <tg@FreeBSD.org>2000-04-04 09:53:12 +0000
commit9c0d74037cd7d9e74084678fb5a53a0fb6c7e374 (patch)
treeb9399ec3ba0c7cb63522a8f7460bbdc4eea87781 /x11-toolkits/py-tkinter/Makefile
parent69f7b9eebc293bad5d507b5094486089ece45d06 (diff)
downloadports-9c0d74037cd7d9e74084678fb5a53a0fb6c7e374.tar.gz
ports-9c0d74037cd7d9e74084678fb5a53a0fb6c7e374.zip
Separate the Python Tk module from the main port. I've been
wanting do to this for a long time now. Now we got rid of the stupid dependency on Tcl/Tk and save some checks in python's makefile. Update the dependent ports accordingly.
Notes
Notes: svn path=/head/; revision=27320
Diffstat (limited to 'x11-toolkits/py-tkinter/Makefile')
-rw-r--r--x11-toolkits/py-tkinter/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/x11-toolkits/py-tkinter/Makefile b/x11-toolkits/py-tkinter/Makefile
new file mode 100644
index 000000000000..8d38458dc6a2
--- /dev/null
+++ b/x11-toolkits/py-tkinter/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: py-Tkinter
+# Version required: 1.5.2
+# Date created: 12 Jan 1999
+# Whom: Thomas Gellekum <tg@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+DISTNAME= py152
+PKGNAME= py-tkinter-1.5.2
+CATEGORIES= x11-toolkits python
+MASTER_SITES= ftp://www.python.org/pub/python/src/ \
+ ftp://ftp.cwi.nl/pub/python/src/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= tg@FreeBSD.org
+
+BUILD_DEPENDS= python:${PORTSDIR}/lang/python
+LIB_DEPENDS= tk82.1:${PORTSDIR}/x11-toolkits/tk82
+RUN_DEPENDS= python:${PORTSDIR}/lang/python
+
+DIST_SUBDIR= python
+WRKSRC= ${WRKDIR}/Python-1.5.2/Modules
+ALL_TARGET= sharedmods
+MAKE_FLAGS= OPT="${CFLAGS}"
+
+PYTHONSCRIPTDIR= ${PREFIX}/lib/python1.5
+
+post-extract:
+ @${CP} ${FILESDIR}/Setup ${WRKSRC}
+ @${CP} ${PYTHONSCRIPTDIR}/config/Makefile.pre.in ${WRKSRC}
+
+do-configure:
+ @(cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${MAKE} -f Makefile.pre.in boot)
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/_tkinter.so ${PYTHONSCRIPTDIR}/site-packages
+
+.include <bsd.port.mk>