aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/qt5-gui
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2017-02-18 19:48:05 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2017-02-18 19:48:05 +0000
commitf3c180c3431372077934f7658922b8a244419bdf (patch)
tree4d04227f02c7fda007ad74be01e1393168277b0b /x11-toolkits/qt5-gui
parent748a0f2465dd8511da6092b69cbe578ce5749586 (diff)
downloadports-f3c180c3431372077934f7658922b8a244419bdf.tar.gz
ports-f3c180c3431372077934f7658922b8a244419bdf.zip
Update Qt5 to 5.7.1, and unify the Qt4 and Qt5 ports some more
* Update Qt5 to 5.7.1 * Move Qt4 binaries to lib/qt4/bin * Move Qt5 libraries to lib/qt5/lib By moving the libraries we should finally be able to get rid of the inplace upgrade bug (see ports bugs 194088, 195105 and 198720): when Qt5's libraries were lying in /usr/local/lib, which would often get added by pkgconfig to the linker paths via dependencies, the already installed libraries were linked against, instead of the ones that were being built. This forced us to make sure, that -L${WRKSRC}/lib was always coming before -L/usr/local/lib in the linker flags. With this change this should no longer be the case. * Rename some ports to match the rest (foo-qtX -> qtX-foo) * Depend on new port misc/qtchooser [see UPDATING & CHANGES] There are several new Qt5 ports which all have been created by Marie Loise Nolden <nolden@kde.org>. Thanks again. PR: 216797 Exp-Run by: antoine Reviewed by: rakuco, mat, groot_kde.org Approved by: rakuco (mentor) Differential Revision: https://reviews.freebsd.org/D9213
Notes
Notes: svn path=/head/; revision=434380
Diffstat (limited to 'x11-toolkits/qt5-gui')
-rw-r--r--x11-toolkits/qt5-gui/Makefile18
-rw-r--r--x11-toolkits/qt5-gui/pkg-plist41
2 files changed, 26 insertions, 33 deletions
diff --git a/x11-toolkits/qt5-gui/Makefile b/x11-toolkits/qt5-gui/Makefile
index e5c4b828186f..7ed14c1fc77a 100644
--- a/x11-toolkits/qt5-gui/Makefile
+++ b/x11-toolkits/qt5-gui/Makefile
@@ -2,7 +2,6 @@
PORTNAME= gui
DISTVERSION= ${QT5_VERSION}
-PORTREVISION= 1
CATEGORIES= x11-toolkits graphics
PKGNAMEPREFIX= qt5-
@@ -22,7 +21,7 @@ LIB_DEPENDS= libdbus-1.so:devel/dbus \
libxkbcommon.so:x11/libxkbcommon
RUN_DEPENDS= xdg-open:devel/xdg-utils
-USES= compiler:features jpeg
+USES= jpeg
USE_GL= gl egl
USE_GNOME= glib20
USE_QT5= core dbus network qmake_build buildtools_build
@@ -70,19 +69,6 @@ RUN_DEPENDS+= ${LOCALBASE}/share/fonts/encodings/encodings.dir:x11-fonts/encodin
CFLAGS_powerpc64= -mminimal-toc
-.include <bsd.port.pre.mk>
-
-# Base GCC fails to build qdrawhelper.cpp:
-# painting/qdrawhelper.cpp: In function 'void qConvertARGB64PMToA2RGB30PM_sse2(uint*, const QRgba64*, int)':
-# painting/qdrawhelper.cpp:1276: note: use -flax-vector-conversions to permit conversions between vectors with differing element types or numbers of subparts
-# painting/qdrawhelper.cpp:1276: error: cannot convert 'int __vector__' to 'long long int __vector__' for argument '1' to 'long long int __vector__ __builtin_ia32_psrlqi128(long long int __vector__, int)'
-# painting/qdrawhelper.cpp:1277: error: cannot convert 'int __vector__' to 'long long int __vector__' for argument '1' to 'long long int __vector__ __builtin_ia32_psrlqi128(long long int __vector__, int)'
-# painting/qdrawhelper.cpp:1278: error: cannot convert 'int __vector__' to 'long long int __vector__' for argument '1' to 'long long int __vector__ __builtin_ia32_psrlqi128(long long int __vector__, int)'
-# painting/qdrawhelper.cpp:1282: error: cannot convert 'int __vector__' to 'long long int __vector__' for argument '1' to 'long long int __vector__ __builtin_ia32_psrlqi128(long long int __vector__, int)'
-.if ${COMPILER_TYPE} == gcc && ${COMPILER_VERSION} <= 42
-CXXFLAGS+= -flax-vector-conversions
-.endif
-
post-build:
.for d in ${MORE_WRKSRCS}
@cd ${WRKSRC}/${d} && \
@@ -97,4 +83,4 @@ post-install:
${MAKE_ARGS} ${INSTALL_TARGET}
.endfor
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11-toolkits/qt5-gui/pkg-plist b/x11-toolkits/qt5-gui/pkg-plist
index 4f20f2a8425b..d2e3003bc4bc 100644
--- a/x11-toolkits/qt5-gui/pkg-plist
+++ b/x11-toolkits/qt5-gui/pkg-plist
@@ -555,6 +555,7 @@
%%QT_INCDIR%%/QtPlatformHeaders/QGLXNativeContext
%%QT_INCDIR%%/QtPlatformHeaders/QPlatformHeaderHelper
%%QT_INCDIR%%/QtPlatformHeaders/QWGLNativeContext
+%%QT_INCDIR%%/QtPlatformHeaders/QWaylandWindowFunctions
%%QT_INCDIR%%/QtPlatformHeaders/QWindowsWindowFunctions
%%QT_INCDIR%%/QtPlatformHeaders/QXcbIntegrationFunctions
%%QT_INCDIR%%/QtPlatformHeaders/QXcbScreenFunctions
@@ -569,6 +570,7 @@
%%QT_INCDIR%%/QtPlatformHeaders/qglxnativecontext.h
%%QT_INCDIR%%/QtPlatformHeaders/qplatformheaderhelper.h
%%QT_INCDIR%%/QtPlatformHeaders/qtplatformheadersversion.h
+%%QT_INCDIR%%/QtPlatformHeaders/qwaylandwindowfunctions.h
%%QT_INCDIR%%/QtPlatformHeaders/qwglnativecontext.h
%%QT_INCDIR%%/QtPlatformHeaders/qwindowswindowfunctions.h
%%QT_INCDIR%%/QtPlatformHeaders/qxcbintegrationfunctions.h
@@ -585,7 +587,9 @@
%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qbasicfontdatabase_p.h
%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qcoretextfontdatabase_p.h
%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qdbusmenuadaptor_p.h
+%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qdbusmenubar_p.h
%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qdbusmenuconnection_p.h
+%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qdbusmenuregistrarproxy_p.h
%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qdbusmenutypes_p.h
%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qdbusplatformmenu_p.h
%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qdbustrayicon_p.h
@@ -603,7 +607,8 @@
%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qevdevkeyboardmanager_p.h
%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qevdevmousehandler_p.h
%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qevdevmousemanager_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qevdevtablet_p.h
+%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qevdevtablethandler_p.h
+%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qevdevtabletmanager_p.h
%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qevdevtouchhandler_p.h
%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qevdevtouchmanager_p.h
%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qeventdispatcher_glib_p.h
@@ -627,7 +632,9 @@
%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qmacmime_p.h
%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qopenglcompositor_p.h
%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qopenglcompositorbackingstore_p.h
+%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qrasterbackingstore_p.h
%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qstatusnotifieritemadaptor_p.h
+%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qt_egl_p.h
%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qtslib_p.h
%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qunixeventdispatcher_qpa_p.h
%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qwindowsguieventdispatcher_p.h
@@ -638,22 +645,22 @@
%%QT_INCDIR%%/QtPlatformSupport/QtPlatformSupportDepends
%%QT_INCDIR%%/QtPlatformSupport/QtPlatformSupportVersion
%%QT_INCDIR%%/QtPlatformSupport/qtplatformsupportversion.h
-%%QT_LIBDIR%%/cmake/Qt5Gui/Qt5GuiConfig.cmake
-%%QT_LIBDIR%%/cmake/Qt5Gui/Qt5GuiConfigExtras.cmake
-%%QT_LIBDIR%%/cmake/Qt5Gui/Qt5GuiConfigVersion.cmake
-%%QT_LIBDIR%%/cmake/Qt5Gui/Qt5Gui_QComposePlatformInputContextPlugin.cmake
-%%QT_LIBDIR%%/cmake/Qt5Gui/Qt5Gui_QGifPlugin.cmake
-%%QT_LIBDIR%%/cmake/Qt5Gui/Qt5Gui_QICOPlugin.cmake
-%%QT_LIBDIR%%/cmake/Qt5Gui/Qt5Gui_QIbusPlatformInputContextPlugin.cmake
-%%QT_LIBDIR%%/cmake/Qt5Gui/Qt5Gui_QJpegPlugin.cmake
-%%QT_LIBDIR%%/cmake/Qt5Gui/Qt5Gui_QMinimalIntegrationPlugin.cmake
-%%QT_LIBDIR%%/cmake/Qt5Gui/Qt5Gui_QOffscreenIntegrationPlugin.cmake
-%%QT_LIBDIR%%/cmake/Qt5Gui/Qt5Gui_QTuioTouchPlugin.cmake
-%%QT_LIBDIR%%/cmake/Qt5Gui/Qt5Gui_QXcbEglIntegrationPlugin.cmake
-%%QT_LIBDIR%%/cmake/Qt5Gui/Qt5Gui_QXcbGlxIntegrationPlugin.cmake
-%%QT_LIBDIR%%/cmake/Qt5Gui/Qt5Gui_QXcbIntegrationPlugin.cmake
-%%QT_LIBDIR%%/cmake/Qt5OpenGLExtensions/Qt5OpenGLExtensionsConfig.cmake
-%%QT_LIBDIR%%/cmake/Qt5OpenGLExtensions/Qt5OpenGLExtensionsConfigVersion.cmake
+%%QT_CMAKEDIR%%/Qt5Gui/Qt5GuiConfig.cmake
+%%QT_CMAKEDIR%%/Qt5Gui/Qt5GuiConfigExtras.cmake
+%%QT_CMAKEDIR%%/Qt5Gui/Qt5GuiConfigVersion.cmake
+%%QT_CMAKEDIR%%/Qt5Gui/Qt5Gui_QComposePlatformInputContextPlugin.cmake
+%%QT_CMAKEDIR%%/Qt5Gui/Qt5Gui_QGifPlugin.cmake
+%%QT_CMAKEDIR%%/Qt5Gui/Qt5Gui_QICOPlugin.cmake
+%%QT_CMAKEDIR%%/Qt5Gui/Qt5Gui_QIbusPlatformInputContextPlugin.cmake
+%%QT_CMAKEDIR%%/Qt5Gui/Qt5Gui_QJpegPlugin.cmake
+%%QT_CMAKEDIR%%/Qt5Gui/Qt5Gui_QMinimalIntegrationPlugin.cmake
+%%QT_CMAKEDIR%%/Qt5Gui/Qt5Gui_QOffscreenIntegrationPlugin.cmake
+%%QT_CMAKEDIR%%/Qt5Gui/Qt5Gui_QTuioTouchPlugin.cmake
+%%QT_CMAKEDIR%%/Qt5Gui/Qt5Gui_QXcbEglIntegrationPlugin.cmake
+%%QT_CMAKEDIR%%/Qt5Gui/Qt5Gui_QXcbGlxIntegrationPlugin.cmake
+%%QT_CMAKEDIR%%/Qt5Gui/Qt5Gui_QXcbIntegrationPlugin.cmake
+%%QT_CMAKEDIR%%/Qt5OpenGLExtensions/Qt5OpenGLExtensionsConfig.cmake
+%%QT_CMAKEDIR%%/Qt5OpenGLExtensions/Qt5OpenGLExtensionsConfigVersion.cmake
%%QT_LIBDIR%%/libQt5Gui.prl
%%QT_LIBDIR%%/libQt5Gui.so
%%QT_LIBDIR%%/libQt5Gui.so.5