aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/qwt6-designerplugin
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2011-08-19 16:53:51 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2011-08-19 16:53:51 +0000
commit5e2b828c974f208e34c666d1be7066483eb6233a (patch)
tree19f4fb8f80fcabb9464ff93d33b41b8af1b21942 /x11-toolkits/qwt6-designerplugin
parent0623506f9db3bafb4613c8046d621db01990608d (diff)
downloadports-5e2b828c974f208e34c666d1be7066483eb6233a.tar.gz
ports-5e2b828c974f208e34c666d1be7066483eb6233a.zip
Update to 6.0.1
Notes
Notes: svn path=/head/; revision=280019
Diffstat (limited to 'x11-toolkits/qwt6-designerplugin')
-rw-r--r--x11-toolkits/qwt6-designerplugin/Makefile15
-rw-r--r--x11-toolkits/qwt6-designerplugin/distinfo4
-rw-r--r--x11-toolkits/qwt6-designerplugin/files/patch-designer__designer.pro36
-rw-r--r--x11-toolkits/qwt6-designerplugin/pkg-plist3
4 files changed, 39 insertions, 19 deletions
diff --git a/x11-toolkits/qwt6-designerplugin/Makefile b/x11-toolkits/qwt6-designerplugin/Makefile
index 26238059e407..1fffee1bf3b5 100644
--- a/x11-toolkits/qwt6-designerplugin/Makefile
+++ b/x11-toolkits/qwt6-designerplugin/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= qwt
-PORTVERSION= 5.2.2
+PORTVERSION= 6.0.1
CATEGORIES= x11-toolkits devel
MASTER_SITES= SF
PKGNAMESUFFIX= -designerplugin
@@ -14,19 +14,24 @@ PKGNAMESUFFIX= -designerplugin
MAINTAINER= makc@FreeBSD.org
COMMENT= Qt Designer plugin for Qwt
-LIB_DEPENDS= qwt.5:${PORTSDIR}/x11-toolkits/qwt5
+LIB_DEPENDS= qwt6.6:${PORTSDIR}/x11-toolkits/qwt6
USE_QT_VER= 4
QT_COMPONENTS= designer moc_build qmake_build rcc_build
USE_BZIP2= yes
USE_GMAKE= yes
-QMAKE_ARGS+= -unix -recursive CONFIG+=QwtDesigner \
+QMAKE_ARGS+= -recursive CONFIG+=QwtDesigner \
PLUGINDIR=${PREFIX}/${QT_PLUGINDIR_REL}
HAS_CONFIGURE= yes
MAKE_JOBS_SAFE= yes
-PORTSCOUT= limit:^5\.
-STRIP_FILES= ${QT_PLUGINDIR_REL}/designer/libqwt_designer_plugin.so
+LATEST_LINK= qwt6${PKGNAMESUFFIX}
+
+PLIST_FILES= ${QT_PLUGINDIR_REL}/designer/libqwt6_designer_plugin.so
+PLIST_DIRSTRY= ${QT_PLUGINDIR_REL}/designer \
+ ${QT_PLUGINDIR_REL}
+
+STRIP_FILES= ${QT_PLUGINDIR_REL}/designer/libqwt6_designer_plugin.so
CONFIGURE_WRKSRC= ${WRKSRC}/designer
BUILD_WRKSRC= ${CONFIGURE_WRKSRC}
diff --git a/x11-toolkits/qwt6-designerplugin/distinfo b/x11-toolkits/qwt6-designerplugin/distinfo
index 0f837a9b9013..53a6de37c2f9 100644
--- a/x11-toolkits/qwt6-designerplugin/distinfo
+++ b/x11-toolkits/qwt6-designerplugin/distinfo
@@ -1,2 +1,2 @@
-SHA256 (qwt-5.2.2.tar.bz2) = 36bf2ee51ca9c74fde1322510ffd39baac0db60d5d410bb157968a78d9c1464b
-SIZE (qwt-5.2.2.tar.bz2) = 2083193
+SHA256 (qwt-6.0.1.tar.bz2) = 3fe19dd5962d705632fc2ef616b009299de6cf1e702538296924dbfdc8003cb2
+SIZE (qwt-6.0.1.tar.bz2) = 2437570
diff --git a/x11-toolkits/qwt6-designerplugin/files/patch-designer__designer.pro b/x11-toolkits/qwt6-designerplugin/files/patch-designer__designer.pro
index 030bd15ede67..2ed1b8eef61d 100644
--- a/x11-toolkits/qwt6-designerplugin/files/patch-designer__designer.pro
+++ b/x11-toolkits/qwt6-designerplugin/files/patch-designer__designer.pro
@@ -1,11 +1,29 @@
---- ./designer/designer.pro.orig 2008-05-01 17:43:56.000000000 +0400
-+++ ./designer/designer.pro 2008-05-03 02:21:17.000000000 +0400
-@@ -123,7 +123,7 @@
- RESOURCES += \
- qwt_designer_plugin.qrc
-
-- target.path = $$[QT_INSTALL_PLUGINS]/designer
-+ target.path = $$PLUGINDIR/designer
- INSTALLS += target
+--- ./designer/designer.pro.orig 2011-08-01 14:33:53.000000000 +0000
++++ ./designer/designer.pro 2011-08-19 15:46:20.185856767 +0000
+@@ -18,7 +18,7 @@
+ CONFIG += warn_on
+
+ TEMPLATE = lib
+- TARGET = qwt_designer_plugin
++ TARGET = qwt6_designer_plugin
+
+ DESTDIR = plugins/designer
+
+@@ -35,7 +35,7 @@
}
+
+ IPATH = $${INCLUDEPATH}
+- qtAddLibrary(qwt)
++ qtAddLibrary(qwt6)
+ INCLUDEPATH = $${IPATH}
+
+ contains(QWT_CONFIG, QwtDll) {
+@@ -64,7 +64,7 @@
+
+ RESOURCES += qwt_designer_plugin.qrc
+
+- target.path = $${QWT_INSTALL_PLUGINS}
++ target.path = $$PLUGINDIR/designer
+ INSTALLS += target
}
+ else {
diff --git a/x11-toolkits/qwt6-designerplugin/pkg-plist b/x11-toolkits/qwt6-designerplugin/pkg-plist
deleted file mode 100644
index 14e3c7ba01c2..000000000000
--- a/x11-toolkits/qwt6-designerplugin/pkg-plist
+++ /dev/null
@@ -1,3 +0,0 @@
-%%QT_PLUGINDIR_REL%%/designer/libqwt_designer_plugin.so
-@dirrmtry %%QT_PLUGINDIR_REL%%/designer
-@dirrmtry %%QT_PLUGINDIR_REL%%