aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/ruby-goocanvas
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2010-11-27 03:32:41 +0000
committerSteve Wills <swills@FreeBSD.org>2010-11-27 03:32:41 +0000
commit132e1e4550c1452bb2f20429bb6b9a8712b11b19 (patch)
tree9fff9947bc6591c5bd2480f0f58ec4d0b0b99b9a /x11-toolkits/ruby-goocanvas
parent78d32293a961a432bc346ccc71ef955fc4f27768 (diff)
downloadports-132e1e4550c1452bb2f20429bb6b9a8712b11b19.tar.gz
ports-132e1e4550c1452bb2f20429bb6b9a8712b11b19.zip
- Update to 0.90.5
- create ports for vte, gstreamer, gtksourceview2, poppler and goocanvas modules - sort depends in meta port - remove patch to ruby-gtk2 that's merged upstream - remove old gtksourceview module which seems broken Submitted by: swills (myself) Approved by: wxs (mentor)
Notes
Notes: svn path=/head/; revision=265240
Diffstat (limited to 'x11-toolkits/ruby-goocanvas')
-rw-r--r--x11-toolkits/ruby-goocanvas/Makefile51
-rw-r--r--x11-toolkits/ruby-goocanvas/pkg-descr3
-rw-r--r--x11-toolkits/ruby-goocanvas/pkg-plist24
3 files changed, 78 insertions, 0 deletions
diff --git a/x11-toolkits/ruby-goocanvas/Makefile b/x11-toolkits/ruby-goocanvas/Makefile
new file mode 100644
index 000000000000..25917243f71b
--- /dev/null
+++ b/x11-toolkits/ruby-goocanvas/Makefile
@@ -0,0 +1,51 @@
+# New ports collection makefile for: ruby-goocanvas
+# Date created: 2010-11-19
+# Whom: Steve Wills <swills@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= goocanvas
+PORTVERSION= ${RUBY_GNOME_PORTVERSION}
+CATEGORIES= x11-toolkits gnome ruby
+MASTER_SITES= ${RUBY_GNOME_MASTER_SITES}
+MASTER_SITE_SUBDIR= ${RUBY_GNOME_MASTER_SITE_SUBDIR}
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ${RUBY_GNOME_DISTNAME}
+DIST_SUBDIR= ruby
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Ruby binding for goocanvas
+
+LIB_DEPENDS= goocanvas.3:${PORTSDIR}/graphics/goocanvas
+BUILD_DEPENDS+= rubygem-pkg-config>=1.0.7:${PORTSDIR}/devel/rubygem-pkg-config \
+ ${RUBY_SITEARCHLIBDIR:S/${PREFIX}/${LOCALBASE}/}/cairo.so:${PORTSDIR}/graphics/ruby-cairo
+RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR:S/${PREFIX}/${LOCALBASE}/}/gtk2.so:${PORTSDIR}/x11-toolkits/ruby-gtk2 \
+ ${RUBY_SITEARCHLIBDIR:S/${PREFIX}/${LOCALBASE}/}/cairo.so:${PORTSDIR}/graphics/ruby-cairo
+
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+CONFIGURE_ARGS= --with-pkg-config-dir=${LOCALBASE}/libdata/pkgconfig
+
+.include "${.CURDIR}/../../x11/ruby-gnome2/Makefile.common"
+
+WRKSRC= ${RUBY_GNOME_WRKSRC}/goocanvas
+INSTALL_TARGET= site-install
+
+DOCS= ChangeLog README
+
+post-patch: general-patch
+
+post-install:
+.if !defined(NOPORTEXAMPLES)
+ @${MKDIR} ${RUBY_MODEXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/sample/* ${RUBY_MODEXAMPLESDIR}/
+.endif
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${RUBY_MODDOCDIR}
+.for f in ${DOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/ruby-goocanvas/pkg-descr b/x11-toolkits/ruby-goocanvas/pkg-descr
new file mode 100644
index 000000000000..b02173ed1134
--- /dev/null
+++ b/x11-toolkits/ruby-goocanvas/pkg-descr
@@ -0,0 +1,3 @@
+Ruby/Goocanvas is a Ruby binding of Goocanvas.
+
+WWW: http://ruby-gnome2.sourceforge.jp/
diff --git a/x11-toolkits/ruby-goocanvas/pkg-plist b/x11-toolkits/ruby-goocanvas/pkg-plist
new file mode 100644
index 000000000000..d61aa09f7330
--- /dev/null
+++ b/x11-toolkits/ruby-goocanvas/pkg-plist
@@ -0,0 +1,24 @@
+libdata/pkgconfig/ruby-goocanvas.pc
+%%RUBY_SITELIBDIR%%/goocanvas.rb
+%%RUBY_SITEARCHLIBDIR%%/goocanvas.so
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ChangeLog
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/README
+%%PORTEXAMPLES%%%%RUBY_MODEXAMPLESDIR%%/demo-arrowhead.rb
+%%PORTEXAMPLES%%%%RUBY_MODEXAMPLESDIR%%/demo-fifteen.rb
+%%PORTEXAMPLES%%%%RUBY_MODEXAMPLESDIR%%/demo-primitives.rb
+%%PORTEXAMPLES%%%%RUBY_MODEXAMPLESDIR%%/demo.rb
+%%PORTEXAMPLES%%%%RUBY_MODEXAMPLESDIR%%/flower.png
+%%PORTEXAMPLES%%%%RUBY_MODEXAMPLESDIR%%/scalability-demo.rb
+%%PORTEXAMPLES%%%%RUBY_MODEXAMPLESDIR%%/simple-demo.rb
+%%PORTEXAMPLES%%%%RUBY_MODEXAMPLESDIR%%/table-demo.rb
+%%PORTEXAMPLES%%%%RUBY_MODEXAMPLESDIR%%/toroid.png
+%%PORTEXAMPLES%%%%RUBY_MODEXAMPLESDIR%%/units-demo.rb
+%%PORTEXAMPLES%%%%RUBY_MODEXAMPLESDIR%%/widgets-demo.rb
+%%PORTEXAMPLES%%@dirrm %%RUBY_MODEXAMPLESDIR%%
+%%PORTEXAMPLES%%@dirrmtry %%RUBY_EXAMPLESDIR%%
+%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%
+%%PORTDOCS%%@dirrmtry %%RUBY_DOCDIR%%
+@dirrmtry %%RUBY_SITEARCHLIBDIR%%
+@dirrmtry %%RUBY_SITELIBDIR%%
+@dirrmtry lib/ruby/site_ruby
+@dirrmtry lib/ruby