aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/soqt/Makefile
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2003-06-26 14:29:11 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2003-06-26 14:29:11 +0000
commit586e52491f7bd939cd3fef091fb6e39d290a4474 (patch)
tree2fb55bacb99a3a3aa3dc4c5210d8292aa62eed27 /x11-toolkits/soqt/Makefile
parent9ef2d8ff847b1f889287157119142154c5361189 (diff)
downloadports-586e52491f7bd939cd3fef091fb6e39d290a4474.tar.gz
ports-586e52491f7bd939cd3fef091fb6e39d290a4474.zip
Add port soqt, Qt GUI component toolkit library for Coin.
It is compatible with SGI and TGS Open Inventor, and the API is based on the API of the InventorXt GUI component toolkit. PR: 49072 Submitted by: Roland Jesse <roland.jesse@gmx.net>
Notes
Notes: svn path=/head/; revision=83663
Diffstat (limited to 'x11-toolkits/soqt/Makefile')
-rw-r--r--x11-toolkits/soqt/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/x11-toolkits/soqt/Makefile b/x11-toolkits/soqt/Makefile
new file mode 100644
index 000000000000..c56378cb4d58
--- /dev/null
+++ b/x11-toolkits/soqt/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: SoQt
+# Date created: 10 March 2003
+# Whom: roland.jesse@gmx.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= SoQt
+PORTVERSION= 1.0.2
+CATEGORIES= x11-toolkits
+MASTER_SITES= ftp://ftp.coin3d.org/pub/coin/src/
+DIST_SUBDIR= KDE
+
+MAINTAINER= roland.jesse@gmx.net
+COMMENT= Qt toolkit library for Coin
+
+LIB_DEPENDS= Coin.40:${PORTSDIR}/graphics/Coin
+
+USE_QT_VER= 3
+USE_LIBTOOL= yes
+CONFIGURE_ENV+= QTDIR=${QT_PREFIX} CXXFLAGS="-pthread"
+CONFIGURE_ARGS+= --with-pthread=yes --with-coin=${X11BASE}
+# avoid renaming of soqt-config and soqt-config.1
+CONFIGURE_TARGET= --target=""
+MAKE_ENV+= QTDIR=${QT_PREFIX}
+INSTALLS_SHLIB= yes
+MAN1= soqt-config.1
+
+.include <bsd.port.mk>