aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/vte3
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2015-08-08 14:11:03 +0000
committerKoop Mast <kwm@FreeBSD.org>2015-08-08 14:11:03 +0000
commit2e3498cdeff150c705d9de90aa463e749bd54db7 (patch)
tree1498726d2e1238e2fca3f69f751e441daa3fde97 /x11-toolkits/vte3
parent652724b9ab96d404a700b6a2896f2c77d493c428 (diff)
* Remove 8.x patch.
* Make OSVERSION conditionals check OPSYS == FreeBSD. And add check for OPSYS == DragonFly, since they don't have zlib.pc in there base [1] * Remove old reinplace that didn't apply anymore. And the thing it was supposed to handle is done elsewhere in the Makefile. Reported by: marino@ [1] Tested by: marino@
Notes
Notes: svn path=/head/; revision=393730
Diffstat (limited to 'x11-toolkits/vte3')
-rw-r--r--x11-toolkits/vte3/Makefile12
-rw-r--r--x11-toolkits/vte3/files/extra-patch-gnome-pty-helper_gnome-utmp.c40
2 files changed, 3 insertions, 49 deletions
diff --git a/x11-toolkits/vte3/Makefile b/x11-toolkits/vte3/Makefile
index 1457507c724e..96e1eddcaa09 100644
--- a/x11-toolkits/vte3/Makefile
+++ b/x11-toolkits/vte3/Makefile
@@ -48,12 +48,8 @@ PLIST_SUB= VERSION=2.91
.include <bsd.port.options.mk>
-.if ${OSVERSION} < 900007
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-gnome-pty-helper_gnome-utmp.c
-.endif
-
-.if ${OSVERSION} < 1000000
-CFLAGS+= -lz
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000000 || ${OPSYS} == DragonFly
+LIBS+= -lz
.endif
post-patch:
@@ -62,7 +58,7 @@ post-patch:
${WRKSRC}/src/Makefile.in
.endif
# zlib.pc only is available on 10.1-R and newer.
-.if ${OSVERSION} < 1000000
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000000 || ${OPSYS} == DragonFly
@${REINPLACE_CMD} -e 's|gio-unix-2.0 zlib|gio-unix-2.0|g' \
${WRKSRC}/configure
.endif
@@ -74,8 +70,6 @@ post-patch:
.endif
@${REINPLACE_CMD} -e 's|(AM_MAKEFLAGS) install-exec-hook|(AM_MAKEFLAGS)|g' \
${WRKSRC}/gnome-pty-helper/Makefile.in
- @${REINPLACE_CMD} -e 's|zlib"|"|g' \
- ${WRKSRC}/configure
.include <bsd.port.mk>
diff --git a/x11-toolkits/vte3/files/extra-patch-gnome-pty-helper_gnome-utmp.c b/x11-toolkits/vte3/files/extra-patch-gnome-pty-helper_gnome-utmp.c
deleted file mode 100644
index bc0877bf5f3a..000000000000
--- a/x11-toolkits/vte3/files/extra-patch-gnome-pty-helper_gnome-utmp.c
+++ /dev/null
@@ -1,40 +0,0 @@
---- gnome-pty-helper/gnome-utmp.c.orig Sat Oct 28 23:15:53 2006
-+++ gnome-pty-helper/gnome-utmp.c Sat Oct 28 23:15:40 2006
-@@ -258,10 +258,18 @@ write_logout_record (char *login_name, v
- #endif
-
- if (utmp)
-+#if defined(__FreeBSD__)
-+ logout (put.ut_line);
-+#else
- update_utmp (&put);
-+#endif
-
- if (wtmp)
-+#if defined(__FreeBSD__)
-+ logwtmp (put.ut_line, "", "");
-+#else
- update_wtmp (WTMP_OUTPUT_FILENAME, &put);
-+#endif
-
- free (ut);
- }
-@@ -347,10 +355,18 @@ write_login_record (char *login_name, ch
- # endif
- #endif
- if (utmp)
-+#if defined(__FreeBSD__)
-+ login (ut);
-+#else
- update_utmp (ut);
-+#endif
-
- if (wtmp)
-+#if defined(__FreeBSD__)
-+ logwtmp (ut->ut_line, ut->ut_name, ut->ut_host);
-+#else
- update_wtmp (WTMP_OUTPUT_FILENAME, ut);
-+#endif
-
- if (lastlog)
- update_lastlog(login_name, ut);