aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/wlroots
diff options
context:
space:
mode:
authorEmmanuel Vadot <manu@FreeBSD.org>2020-02-28 11:26:28 +0000
committerEmmanuel Vadot <manu@FreeBSD.org>2020-02-28 11:26:28 +0000
commite849de04cdc80e74f52f39a0629b6a73b5983225 (patch)
tree85db70209d96d4951a8f0ae27d60b15842450694 /x11-toolkits/wlroots
parent30fde5da214f61fe295be9122f569f8fd36a2090 (diff)
downloadports-e849de04cdc80e74f52f39a0629b6a73b5983225.tar.gz
ports-e849de04cdc80e74f52f39a0629b6a73b5983225.zip
x11-toolkits/wlroots: Add mesa-dri to RUN_DEPEND
wlroots will try to create a GBM device and this need the gbm drivers from mesa. Fixes running any wayland compositor depending on wlroots on a fresh install. Example: $ pkg install sway alacritty $ sway gbm: failed to open any driver (search paths /usr/local/lib/dri) gbm: Last dlopen error: Cannot open "/usr/local/lib/dri/i965_dri.so" failed to load driver: i965 gbm: failed to open any driver (search paths /usr/local/lib/dri) gbm: Last dlopen error: Cannot open "/usr/local/lib/dri/kms_swrast_dri.so" failed to load driver: kms_swrast gbm: failed to open any driver (search paths /usr/local/lib/dri) gbm: Last dlopen error: Cannot open "/usr/local/lib/dri/swrast_dri.so" failed to load swrast driver 2020-02-28 12:21:31 - [backend/drm/renderer.c:19] Failed to create GBM device 2020-02-28 12:21:31 - [backend/drm/backend.c:203] Failed to initialize renderer 2020-02-28 12:21:31 - [backend/backend.c:163] Failed to open DRM device 12 2020-02-28 12:21:31 - [backend/backend.c:304] Failed to open any DRM device 2020-02-28 12:21:31 - [sway/server.c:47] Unable to create backend Approved by: jbeich (maintainer) Differential Revision: https://reviews.freebsd.org/D23853
Notes
Notes: svn path=/head/; revision=527328
Diffstat (limited to 'x11-toolkits/wlroots')
-rw-r--r--x11-toolkits/wlroots/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/x11-toolkits/wlroots/Makefile b/x11-toolkits/wlroots/Makefile
index cce9c8606a17..c3a3eeb11483 100644
--- a/x11-toolkits/wlroots/Makefile
+++ b/x11-toolkits/wlroots/Makefile
@@ -2,7 +2,7 @@
PORTNAME= wlroots
DISTVERSION= 0.10.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= x11-toolkits
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
@@ -22,7 +22,8 @@ LIB_DEPENDS= libudev.so:devel/libudev-devd \
libwayland-egl.so:graphics/wayland \
libinput.so:x11/libinput \
libxkbcommon.so:x11/libxkbcommon
-RUN_DEPENDS= libudev-devd>=0.4.1:devel/libudev-devd
+RUN_DEPENDS= libudev-devd>=0.4.1:devel/libudev-devd \
+ mesa-dri>0:graphics/mesa-dri
USES= compiler:c11 gl meson pkgconfig xorg
USE_GITHUB= yes