aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/wxgtk28/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
commit3e4ed01146cfe2bdca465bd0e4d199341f62a0b6 (patch)
treed573ea09b2bf6be67cb497df199932da9e2707c4 /x11-toolkits/wxgtk28/Makefile
parent40049f4af2200d0dcf33596508688623fc75f764 (diff)
downloadports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.tar.gz
ports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.zip
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Notes
Notes: svn path=/head/; revision=211584
Diffstat (limited to 'x11-toolkits/wxgtk28/Makefile')
-rw-r--r--x11-toolkits/wxgtk28/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/x11-toolkits/wxgtk28/Makefile b/x11-toolkits/wxgtk28/Makefile
index 7dd6aaae3bc4..f21d7dc8ff29 100644
--- a/x11-toolkits/wxgtk28/Makefile
+++ b/x11-toolkits/wxgtk28/Makefile
@@ -7,9 +7,9 @@
PORTNAME= wx
PORTVERSION= 2.8.7
+PORTREVISION= 1
CATEGORIES= x11-toolkits
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= wxwindows
+MASTER_SITES= SF/wxwindows
PKGNAMESUFFIX= ${WXGTK_FLAVOR}
DISTNAME= wxGTK-${PORTVERSION:rc1=-rc1}
@@ -23,8 +23,8 @@ LIB_DEPENDS+= png.5:${PORTSDIR}/graphics/png\
mspack.1:${PORTSDIR}/archivers/libmspack
USE_BZIP2= yes
-USE_X_PREFIX= yes
-USE_GL= yes
+USE_XORG= x11 sm xxf86vm xinerama
+USE_GL= glu
USE_GMAKE= yes
USE_ICONV= yes
USE_GNOME= gtk20 gconf2
@@ -44,7 +44,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}"\
LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"\
WXCONFIG_CPPFLAGS="${PTHREAD_CFLAGS}"\
PTHREAD_LIBS="${PTHREAD_LIBS}"\
- X11BASE="${X11BASE}"
+ X11BASE="${LOCALBASE}"
PLIST= ${.CURDIR}/pkg-plist
WXGTK_FLAVOR?= gtk2
@@ -54,7 +54,7 @@ PORTREVISION= 0
.endif
.if ${WXGTK_FLAVOR} != "gtk2-common"
-RUN_DEPENDS= ${X11BASE}/include/wx-2.8/wx/wx.h:${PORTSDIR}/x11-toolkits/wxgtk28-common
+RUN_DEPENDS= ${LOCALBASE}/include/wx-2.8/wx/wx.h:${PORTSDIR}/x11-toolkits/wxgtk28-common
.endif
.if ${WXGTK_FLAVOR:M*-common} != ""
@@ -70,7 +70,7 @@ INSTALL_WRKSRC= ${BUILD_WRKSRC}
.if ${WXGTK_FLAVOR} != "gtk2-contrib-common"
USE_WX= 2.8
-RUN_DEPENDS= ${X11BASE}/include/wx-2.8/wx/stc/stc.h:${PORTSDIR}/x11-toolkits/wxgtk28-contrib-common
+RUN_DEPENDS= ${LOCALBASE}/include/wx-2.8/wx/stc/stc.h:${PORTSDIR}/x11-toolkits/wxgtk28-contrib-common
.if ${WXGTK_FLAVOR:M*-unicode*} != ""
WX_UNICODE= yes