aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/wxgtk29
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2004-06-27 21:17:17 +0000
committerMax Khon <fjoe@FreeBSD.org>2004-06-27 21:17:17 +0000
commit40852f28b2019d3dca560de9fd6afecdbf4fcfd8 (patch)
tree0d293705b88525e0d4af5e3d188b4408def9caf8 /x11-toolkits/wxgtk29
parentb2aba9d5bc5f6b45a3b83441f95428a5530c73a2 (diff)
downloadports-40852f28b2019d3dca560de9fd6afecdbf4fcfd8.tar.gz
ports-40852f28b2019d3dca560de9fd6afecdbf4fcfd8.zip
New ports:
wxWidgets 2.5.2 (development branch) + contributed libraries and utils.
Notes
Notes: svn path=/head/; revision=112414
Diffstat (limited to 'x11-toolkits/wxgtk29')
-rw-r--r--x11-toolkits/wxgtk29/Makefile103
-rw-r--r--x11-toolkits/wxgtk29/distinfo2
-rw-r--r--x11-toolkits/wxgtk29/files/patch-Makefile.in37
-rw-r--r--x11-toolkits/wxgtk29/files/patch-configure55
-rw-r--r--x11-toolkits/wxgtk29/files/patch-contrib-Makefile.in9
-rw-r--r--x11-toolkits/wxgtk29/files/patch-contrib-src-Makefile.in28
-rw-r--r--x11-toolkits/wxgtk29/files/patch-contrib-src-animate-Makefile.in11
-rw-r--r--x11-toolkits/wxgtk29/files/patch-contrib-src-deprecated-Makefile.in11
-rw-r--r--x11-toolkits/wxgtk29/files/patch-contrib-src-fl-Makefile.in11
-rw-r--r--x11-toolkits/wxgtk29/files/patch-contrib-src-gizmos-Makefile.in11
-rw-r--r--x11-toolkits/wxgtk29/files/patch-contrib-src-ogl-Makefile.in11
-rw-r--r--x11-toolkits/wxgtk29/files/patch-contrib-src-plot-Makefile.in11
-rw-r--r--x11-toolkits/wxgtk29/files/patch-contrib-src-stc-Makefile.in11
-rw-r--r--x11-toolkits/wxgtk29/files/patch-contrib-src-svg-Makefile.in11
-rw-r--r--x11-toolkits/wxgtk29/files/patch-contrib-src-xrc-Makefile.in11
-rw-r--r--x11-toolkits/wxgtk29/files/patch-contrib-utils-Makefile.in12
-rw-r--r--x11-toolkits/wxgtk29/files/patch-wx-config.in11
-rw-r--r--x11-toolkits/wxgtk29/pkg-descr4
-rw-r--r--x11-toolkits/wxgtk29/pkg-plist26
19 files changed, 386 insertions, 0 deletions
diff --git a/x11-toolkits/wxgtk29/Makefile b/x11-toolkits/wxgtk29/Makefile
new file mode 100644
index 000000000000..6bb41471d0fd
--- /dev/null
+++ b/x11-toolkits/wxgtk29/Makefile
@@ -0,0 +1,103 @@
+# New ports collection makefile for: wxgtk2-devel
+# Date created: June 27, 2004
+# Whom: fjoe@FreeBSD.ORG
+#
+# $FreeBSD$
+#
+
+PORTNAME= wx
+PORTVERSION= 2.5.2
+PORTREVISION?= 0
+CATEGORIES= x11-toolkits
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= wxwindows
+PKGNAMESUFFIX= ${WXGTK_FLAVOR}-devel
+DISTNAME= wxGTK-${PORTVERSION}
+
+MAINTAINER?= fjoe@FreeBSD.org
+COMMENT?= The wxWidgets GUI toolkit with GTK+ bindings (devel version)
+
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
+ jpeg.9:${PORTSDIR}/graphics/jpeg \
+ tiff.4:${PORTSDIR}/graphics/tiff \
+ expat.5:${PORTSDIR}/textproc/expat2
+
+CONFLICTS= wxgtk-*
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_GL= yes
+USE_GMAKE= yes
+USE_ICONV= yes
+USE_GNOME= gtk20
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-libpng=sys \
+ --with-libjpeg=sys \
+ --with-libtiff=sys \
+ --with-zlib=sys \
+ --with-expat=sys \
+ --with-opengl \
+ --enable-gtk2
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include \
+ -I${X11BASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -liconv \
+ -L${X11BASE}/lib" \
+ PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
+ PTHREAD_LIBS="${PTHREAD_LIBS}"
+PLIST= ${.CURDIR}/pkg-plist
+
+WXGTK_FLAVOR?= gtk2
+
+.if ${WXGTK_FLAVOR} != "gtk2-common"
+RUN_DEPENDS= ${X11BASE}/include/wx/wx.h:${PORTSDIR}/x11-toolkits/wxgtk2-common-devel
+.endif
+
+.if ${WXGTK_FLAVOR:M*-common} != ""
+NO_BUILD= yes
+INSTALL_TARGET= install-common
+.else
+INSTALLS_SHLIB= yes
+.endif # *-common
+
+.if ${WXGTK_FLAVOR:M*-contrib*} != "" || ${WXGTK_FLAVOR:M*-utils*} != ""
+.if ${WXGTK_FLAVOR:M*-utils*} != ""
+BUILD_WRKSRC= ${WRKSRC}/contrib/utils
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+.else
+BUILD_WRKSRC= ${WRKSRC}/contrib
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+.endif # *-utils*
+
+.if ${WXGTK_FLAVOR} != "gtk2-contrib-common"
+RUN_DEPENDS= ${X11BASE}/include/wx/stc/stc.h:${PORTSDIR}/x11-toolkits/wxgtk2-contrib-common-devel
+
+.if ${WXGTK_FLAVOR:M*-unicode*} != ""
+LIB_DEPENDS+= wx_baseu-2.5.2:${PORTSDIR}/x11-toolkits/wxgtk2-unicode-devel
+.else
+LIB_DEPENDS+= wx_base-2.5.2:${PORTSDIR}/x11-toolkits/wxgtk2-devel
+.endif
+
+post-patch:
+ @${FIND} ${WRKSRC}/contrib -name Makefile.in -print0 | ${XARGS} -0 ${REINPLACE_CMD} \
+ -e "s,@CXXFLAGS@,${CFLAGS} `${WXGTK_CONFIG} --cxxflags`," \
+ -e "s,@CFLAGS@,${CFLAGS} `${WXGTK_CONFIG} --cflags`," \
+ -e "s,@CPPFLAGS@,,"
+.endif # !gtk2-contrib-common
+.endif # *-contrib* || *-utils*
+
+.include <bsd.port.pre.mk>
+
+.if ${WXGTK_FLAVOR:M*-unicode*} != ""
+.if ${OSVERSION} < 500000
+IGNORE= Systems prior to FreeBSD 5.0 currently out of support
+.else
+CONFIGURE_ARGS+=--enable-unicode
+.endif
+
+WXGTK_CONFIG= ${X11BASE}/bin/wxgtk2u-2.5-config
+.else
+WXGTK_CONFIG= ${X11BASE}/bin/wxgtk2-2.5-config
+.endif # *-unicode*
+
+.include <bsd.port.post.mk>
diff --git a/x11-toolkits/wxgtk29/distinfo b/x11-toolkits/wxgtk29/distinfo
new file mode 100644
index 000000000000..7c24033cdccf
--- /dev/null
+++ b/x11-toolkits/wxgtk29/distinfo
@@ -0,0 +1,2 @@
+MD5 (wxGTK-2.5.2.tar.bz2) = b45874428b0164bfa5bd1a5a11b3eb4a
+SIZE (wxGTK-2.5.2.tar.bz2) = 6579255
diff --git a/x11-toolkits/wxgtk29/files/patch-Makefile.in b/x11-toolkits/wxgtk29/files/patch-Makefile.in
new file mode 100644
index 000000000000..966de5b3e9df
--- /dev/null
+++ b/x11-toolkits/wxgtk29/files/patch-Makefile.in
@@ -0,0 +1,37 @@
+--- Makefile.in.orig Mon May 31 18:11:50 2004
++++ Makefile.in Sun Jun 27 21:12:13 2004
+@@ -23,6 +23,7 @@
+ SONAME_FLAG = @SONAME_FLAG@
+ STRIP = @STRIP@
+ INSTALL_PROGRAM = @INSTALL_PROGRAM@
++INSTALL_SCRIPT = @INSTALL_SCRIPT@
+ INSTALL_DATA = @INSTALL_DATA@
+ INSTALL_DIR = @INSTALL_DIR@
+ srcdir = @srcdir@
+@@ -6927,11 +6928,13 @@
+
+ all: $(__wxregex___depname) $(__wxzlib___depname) $(__wxpng___depname) $(__wxjpeg___depname) $(__wxtiff___depname) $(__wxodbc___depname) $(__wxexpat___depname) $(__monodll___depname) $(__monolib___depname) $(__basedll___depname) $(__baselib___depname) $(__netdll___depname) $(__netlib___depname) $(__coredll___depname) $(__corelib___depname) $(__advdll___depname) $(__advlib___depname) $(__odbcdll___depname) $(__odbclib___depname) $(__dbgriddll___depname) $(__dbgridlib___depname) $(__htmldll___depname) $(__htmllib___depname) $(__xmldll___depname) $(__xmllib___depname) $(__gldll___depname) $(__gllib___depname) $(__sound_sdl___depname) $(__macos_res___depname) $(__cocoa_res___depname)
+
+-install: all $(__install_wxregex___depname) $(__install_wxzlib___depname) $(__install_wxpng___depname) $(__install_wxjpeg___depname) $(__install_wxtiff___depname) $(__install_wxodbc___depname) $(__install_wxexpat___depname) $(__install_monodll___depname) $(__install_monolib___depname) $(__install_basedll___depname) $(__install_baselib___depname) $(__install_netdll___depname) $(__install_netlib___depname) $(__install_coredll___depname) $(__install_corelib___depname) $(__install_advdll___depname) $(__install_advlib___depname) $(__install_odbcdll___depname) $(__install_odbclib___depname) $(__install_dbgriddll___depname) $(__install_dbgridlib___depname) $(__install_htmldll___depname) $(__install_htmllib___depname) $(__install_xmldll___depname) $(__install_xmllib___depname) $(__install_gldll___depname) $(__install_gllib___depname) $(__install_sound_sdl___depname) $(__install_afm___depname) $(__install_gsafm___depname) install-wxconfig locale_install $(__macos_res_install___depname) $(__cocoa_res_install___depname)
++install: all $(__install_wxregex___depname) $(__install_wxzlib___depname) $(__install_wxpng___depname) $(__install_wxjpeg___depname) $(__install_wxtiff___depname) $(__install_wxodbc___depname) $(__install_wxexpat___depname) $(__install_monodll___depname) $(__install_monolib___depname) $(__install_basedll___depname) $(__install_baselib___depname) $(__install_netdll___depname) $(__install_netlib___depname) $(__install_coredll___depname) $(__install_corelib___depname) $(__install_advdll___depname) $(__install_advlib___depname) $(__install_odbcdll___depname) $(__install_odbclib___depname) $(__install_dbgriddll___depname) $(__install_dbgridlib___depname) $(__install_htmldll___depname) $(__install_htmllib___depname) $(__install_xmldll___depname) $(__install_xmllib___depname) $(__install_gldll___depname) $(__install_gllib___depname) $(__install_sound_sdl___depname) install-wxconfig $(__macos_res_install___depname) $(__cocoa_res_install___depname)
++ $(INSTALL_DIR) $(DESTDIR)$(includedir)/wx/include/$(TOOLCHAIN_NAME)/wx
++ (cd ./ ; $(INSTALL_DATA) lib/wx/include/$(TOOLCHAIN_NAME)/wx/setup.h $(DESTDIR)$(includedir)/wx/include/$(TOOLCHAIN_NAME)/wx)
++
++install-common: $(__install_afm___depname) $(__install_gsafm___depname) locale_install
+ $(INSTALL_DIR) $(DESTDIR)$(datadir)/aclocal
+ (cd $(srcdir) ; $(INSTALL_DATA) wxwin.m4 $(DESTDIR)$(datadir)/aclocal)
+- $(INSTALL_DIR) $(DESTDIR)$(libdir)/wx/include/$(TOOLCHAIN_NAME)/wx
+- (cd ./ ; $(INSTALL_DATA) lib/wx/include/$(TOOLCHAIN_NAME)/wx/setup.h $(DESTDIR)$(libdir)/wx/include/$(TOOLCHAIN_NAME)/wx)
+ $(INSTALL_DIR) $(DESTDIR)$(includedir)
+ for f in $(ALL_HEADERS); do \
+ if test ! -d $(DESTDIR)$(includedir)/`dirname $$f` ; then \
+@@ -7371,8 +7374,7 @@
+
+ install-wxconfig:
+ $(INSTALL_DIR) $(DESTDIR)$(bindir)
+- $(INSTALL_PROGRAM) wx$(TOOLCHAIN_NAME)-config $(DESTDIR)$(bindir)
+- (cd $(DESTDIR)$(bindir) && rm -f wx-config && $(LN_S) wx$(TOOLCHAIN_NAME)-config wx-config)
++ $(INSTALL_SCRIPT) wx$(TOOLCHAIN_NAME)-config $(DESTDIR)$(bindir)
+
+ locale_install:
+ $(INSTALL_DIR) $(DESTDIR)$(datadir)/locale
diff --git a/x11-toolkits/wxgtk29/files/patch-configure b/x11-toolkits/wxgtk29/files/patch-configure
new file mode 100644
index 000000000000..ebac7a916f95
--- /dev/null
+++ b/x11-toolkits/wxgtk29/files/patch-configure
@@ -0,0 +1,55 @@
+--- configure.orig Mon May 31 18:11:50 2004
++++ configure Sun Jun 27 20:13:50 2004
+@@ -32707,7 +32707,7 @@
+ fi
+ ;;
+ *-*-freebsd*)
+- THREAD_OPTS="-kthread lthread $THREAD_OPTS c_r"
++ THREAD_OPTS="$PTHREAD_LIBS"
+ ;;
+ *-*-darwin* | *-*-cygwin* )
+ THREAD_OPTS=""
+@@ -32744,6 +32744,12 @@
+ echo $ECHO_N "checking whether pthreads work without any flags... $ECHO_C" >&6
+ ;;
+
++ -pthread|-l*)
++ echo "$as_me:$LINENO: checking for the pthreads library $flag" >&5
++echo $ECHO_N "checking for the pthreads library $flag... $ECHO_C" >&6
++ THREADS_LINK="$flag"
++ ;;
++
+ -*)
+ echo "$as_me:$LINENO: checking whether pthreads work with $flag" >&5
+ echo $ECHO_N "checking whether pthreads work with $flag... $ECHO_C" >&6
+@@ -34014,6 +34020,7 @@
+ fi
+ fi
+ fi
++TOOLCHAIN_DEFS="${TOOLCHAIN_DEFS} ${PTHREAD_CFLAGS}"
+
+ if test "$WXGTK20" = 1 ; then
+ cat >>confdefs.h <<_ACEOF
+@@ -34134,7 +34141,7 @@
+ OPTIMISE="-O"
+ fi
+ fi
+-
++OPTIMISE=
+
+ if test "x$WXWIN_COMPATIBILITY_2_2" = "xyes"; then
+ cat >>confdefs.h <<\_ACEOF
+@@ -40123,6 +40130,13 @@
+
+ case "${BAKEFILE_HOST}" in
+ *-*-linux* )
++ SONAME_FLAG="-Wl,-soname,"
++ USE_SOVERSION=1
++ USE_SOVERLINUX=1
++ USE_SOSYMLINKS=1
++ ;;
++
++ *-*-freebsd* )
+ SONAME_FLAG="-Wl,-soname,"
+ USE_SOVERSION=1
+ USE_SOVERLINUX=1
diff --git a/x11-toolkits/wxgtk29/files/patch-contrib-Makefile.in b/x11-toolkits/wxgtk29/files/patch-contrib-Makefile.in
new file mode 100644
index 000000000000..20b4b5800f89
--- /dev/null
+++ b/x11-toolkits/wxgtk29/files/patch-contrib-Makefile.in
@@ -0,0 +1,9 @@
+--- contrib/Makefile.in.orig Sun Jun 27 21:46:24 2004
++++ contrib/Makefile.in Sun Jun 27 21:46:44 2004
+@@ -16,3 +16,6 @@
+
+ install:
+ cd src; $(MAKE) install
++
++install-common:
++ cd src; $(MAKE) install-common
diff --git a/x11-toolkits/wxgtk29/files/patch-contrib-src-Makefile.in b/x11-toolkits/wxgtk29/files/patch-contrib-src-Makefile.in
new file mode 100644
index 000000000000..c8ae3832f26e
--- /dev/null
+++ b/x11-toolkits/wxgtk29/files/patch-contrib-src-Makefile.in
@@ -0,0 +1,28 @@
+--- contrib/src/Makefile.in.orig Mon May 31 18:12:16 2004
++++ contrib/src/Makefile.in Mon Jun 28 00:28:54 2004
+@@ -1,15 +1,23 @@
+ # $Id: Makefile.in,v 1.16 2003/08/17 12:48:18 VS Exp $
+
+-CONTRIB_SUBDIRS=fl gizmos mmedia ogl plot stc svg xrc deprecated animate #applet
++CONTRIB_SUBDIRS=fl gizmos ogl plot stc svg xrc deprecated animate #applet mmedia
+
+-all:
++@COND_UNICODE_1@wxregexu_depname= wxregexu
++
++all: $(wxregexu_depname)
+ @for d in $(CONTRIB_SUBDIRS); do (cd $$d && $(MAKE)); done
+
++wxregexu:
++ cd ../.. && $(MAKE) lib/libwxregexu.a
++
+ clean:
+ @for d in $(CONTRIB_SUBDIRS); do (cd $$d && $(MAKE) clean); done
+
+ install:
+ @for d in $(CONTRIB_SUBDIRS); do (cd $$d && $(MAKE) install); done
++
++install-common:
++ @for d in $(CONTRIB_SUBDIRS); do (cd $$d && $(MAKE) install-common); done
+
+ uninstall:
+ @for d in $(CONTRIB_SUBDIRS); do (cd $$d && $(MAKE) uninstall); done
diff --git a/x11-toolkits/wxgtk29/files/patch-contrib-src-animate-Makefile.in b/x11-toolkits/wxgtk29/files/patch-contrib-src-animate-Makefile.in
new file mode 100644
index 000000000000..4e5875295e52
--- /dev/null
+++ b/x11-toolkits/wxgtk29/files/patch-contrib-src-animate-Makefile.in
@@ -0,0 +1,11 @@
+--- contrib/src/animate/Makefile.in.orig Sun Jun 27 21:38:11 2004
++++ contrib/src/animate/Makefile.in Sun Jun 27 21:38:20 2004
+@@ -172,6 +172,8 @@
+ all: $(__animatedll___depname) $(__animatelib___depname)
+
+ install: all $(__install_animatedll___depname) $(__install_animatelib___depname)
++
++install-common:
+ $(INSTALL_DIR) $(DESTDIR)$(includedir)
+ for f in wx/animate/animate.h; do \
+ if test ! -d $(DESTDIR)$(includedir)/`dirname $$f` ; then \
diff --git a/x11-toolkits/wxgtk29/files/patch-contrib-src-deprecated-Makefile.in b/x11-toolkits/wxgtk29/files/patch-contrib-src-deprecated-Makefile.in
new file mode 100644
index 000000000000..237d6931053c
--- /dev/null
+++ b/x11-toolkits/wxgtk29/files/patch-contrib-src-deprecated-Makefile.in
@@ -0,0 +1,11 @@
+--- contrib/src/deprecated/Makefile.in.orig Sun Jun 27 21:38:26 2004
++++ contrib/src/deprecated/Makefile.in Sun Jun 27 21:38:52 2004
+@@ -199,6 +199,8 @@
+ all: $(__deprecateddll___depname) $(__deprecatedlib___depname)
+
+ install: all $(__install_deprecateddll___depname) $(__install_deprecatedlib___depname)
++
++install-common:
+ $(INSTALL_DIR) $(DESTDIR)$(includedir)
+ for f in wx/deprecated/expr.h wx/deprecated/prop.h wx/deprecated/propform.h wx/deprecated/proplist.h wx/deprecated/resource.h wx/deprecated/setup.h wx/deprecated/tbarsmpl.h wx/deprecated/treelay.h wx/deprecated/wxexpr.h; do \
+ if test ! -d $(DESTDIR)$(includedir)/`dirname $$f` ; then \
diff --git a/x11-toolkits/wxgtk29/files/patch-contrib-src-fl-Makefile.in b/x11-toolkits/wxgtk29/files/patch-contrib-src-fl-Makefile.in
new file mode 100644
index 000000000000..094280a521fc
--- /dev/null
+++ b/x11-toolkits/wxgtk29/files/patch-contrib-src-fl-Makefile.in
@@ -0,0 +1,11 @@
+--- contrib/src/fl/Makefile.in.orig Sun Jun 27 21:34:52 2004
++++ contrib/src/fl/Makefile.in Sun Jun 27 21:35:37 2004
+@@ -203,6 +203,8 @@
+ all: $(__fldll___depname) $(__fllib___depname)
+
+ install: all $(__install_fldll___depname) $(__install_fllib___depname)
++
++install-common:
+ $(INSTALL_DIR) $(DESTDIR)$(includedir)
+ for f in wx/fl/antiflickpl.h wx/fl/bardragpl.h wx/fl/barhintspl.h wx/fl/cbcustom.h wx/fl/controlbar.h wx/fl/dynbarhnd.h wx/fl/dyntbar.h wx/fl/dyntbarhnd.h wx/fl/fldefs.h wx/fl/frmview.h wx/fl/garbagec.h wx/fl/gcupdatesmgr.h wx/fl/hintanimpl.h wx/fl/newbmpbtn.h wx/fl/panedrawpl.h wx/fl/rowdragpl.h wx/fl/rowlayoutpl.h wx/fl/toolwnd.h wx/fl/updatesmgr.h; do \
+ if test ! -d $(DESTDIR)$(includedir)/`dirname $$f` ; then \
diff --git a/x11-toolkits/wxgtk29/files/patch-contrib-src-gizmos-Makefile.in b/x11-toolkits/wxgtk29/files/patch-contrib-src-gizmos-Makefile.in
new file mode 100644
index 000000000000..fae5de6b9501
--- /dev/null
+++ b/x11-toolkits/wxgtk29/files/patch-contrib-src-gizmos-Makefile.in
@@ -0,0 +1,11 @@
+--- contrib/src/gizmos/Makefile.in.orig Sun Jun 27 21:35:44 2004
++++ contrib/src/gizmos/Makefile.in Sun Jun 27 21:35:55 2004
+@@ -181,6 +181,8 @@
+ all: $(__gizmosdll___depname) $(__gizmoslib___depname)
+
+ install: all $(__install_gizmosdll___depname) $(__install_gizmoslib___depname)
++
++install-common:
+ $(INSTALL_DIR) $(DESTDIR)$(includedir)
+ for f in wx/gizmos/dynamicsash.h wx/gizmos/editlbox.h wx/gizmos/ledctrl.h wx/gizmos/multicell.h wx/gizmos/splittree.h wx/gizmos/statpict.h wx/gizmos/gizmos.h; do \
+ if test ! -d $(DESTDIR)$(includedir)/`dirname $$f` ; then \
diff --git a/x11-toolkits/wxgtk29/files/patch-contrib-src-ogl-Makefile.in b/x11-toolkits/wxgtk29/files/patch-contrib-src-ogl-Makefile.in
new file mode 100644
index 000000000000..cb94093057e1
--- /dev/null
+++ b/x11-toolkits/wxgtk29/files/patch-contrib-src-ogl-Makefile.in
@@ -0,0 +1,11 @@
+--- contrib/src/ogl/Makefile.in.orig Sun Jun 27 22:44:07 2004
++++ contrib/src/ogl/Makefile.in Sun Jun 27 22:44:25 2004
+@@ -193,6 +193,8 @@
+ all: $(__ogldll___depname) $(__ogllib___depname)
+
+ install: all $(__install_ogldll___depname) $(__install_ogllib___depname)
++
++install-common:
+ $(INSTALL_DIR) $(DESTDIR)$(includedir)
+ for f in wx/ogl/basic.h wx/ogl/basicp.h wx/ogl/bmpshape.h wx/ogl/canvas.h wx/ogl/composit.h wx/ogl/constrnt.h wx/ogl/divided.h wx/ogl/drawn.h wx/ogl/drawnp.h wx/ogl/lines.h wx/ogl/linesp.h wx/ogl/mfutils.h wx/ogl/misc.h wx/ogl/ogldiag.h wx/ogl/ogl.h; do \
+ if test ! -d $(DESTDIR)$(includedir)/`dirname $$f` ; then \
diff --git a/x11-toolkits/wxgtk29/files/patch-contrib-src-plot-Makefile.in b/x11-toolkits/wxgtk29/files/patch-contrib-src-plot-Makefile.in
new file mode 100644
index 000000000000..152bf7473082
--- /dev/null
+++ b/x11-toolkits/wxgtk29/files/patch-contrib-src-plot-Makefile.in
@@ -0,0 +1,11 @@
+--- contrib/src/plot/Makefile.in.orig Sun Jun 27 21:36:28 2004
++++ contrib/src/plot/Makefile.in Sun Jun 27 21:36:37 2004
+@@ -171,6 +171,8 @@
+ all: $(__plotdll___depname) $(__plotlib___depname)
+
+ install: all $(__install_plotdll___depname) $(__install_plotlib___depname)
++
++install-common:
+ $(INSTALL_DIR) $(DESTDIR)$(includedir)
+ for f in wx/plot/plot.h wx/plot/plot_dwn.bmp wx/plot/plot_enl.bmp wx/plot/plot_shr.bmp wx/plot/plot_up.bmp wx/plot/plot_zin.bmp wx/plot/plot_zot.bmp wx/plot/wxplot.rc; do \
+ if test ! -d $(DESTDIR)$(includedir)/`dirname $$f` ; then \
diff --git a/x11-toolkits/wxgtk29/files/patch-contrib-src-stc-Makefile.in b/x11-toolkits/wxgtk29/files/patch-contrib-src-stc-Makefile.in
new file mode 100644
index 000000000000..5053151bf229
--- /dev/null
+++ b/x11-toolkits/wxgtk29/files/patch-contrib-src-stc-Makefile.in
@@ -0,0 +1,11 @@
+--- contrib/src/stc/Makefile.in.orig Sun Jun 27 21:36:48 2004
++++ contrib/src/stc/Makefile.in Sun Jun 27 21:36:56 2004
+@@ -286,6 +286,8 @@
+ all: $(__stcdll___depname) $(__stclib___depname)
+
+ install: all $(__install_stcdll___depname) $(__install_stclib___depname)
++
++install-common:
+ $(INSTALL_DIR) $(DESTDIR)$(includedir)
+ for f in wx/stc/stc.h; do \
+ if test ! -d $(DESTDIR)$(includedir)/`dirname $$f` ; then \
diff --git a/x11-toolkits/wxgtk29/files/patch-contrib-src-svg-Makefile.in b/x11-toolkits/wxgtk29/files/patch-contrib-src-svg-Makefile.in
new file mode 100644
index 000000000000..e41c53fd4030
--- /dev/null
+++ b/x11-toolkits/wxgtk29/files/patch-contrib-src-svg-Makefile.in
@@ -0,0 +1,11 @@
+--- contrib/src/svg/Makefile.in.orig Sun Jun 27 21:37:03 2004
++++ contrib/src/svg/Makefile.in Sun Jun 27 21:37:16 2004
+@@ -171,6 +171,8 @@
+ all: $(__svgdll___depname) $(__svglib___depname)
+
+ install: all $(__install_svgdll___depname) $(__install_svglib___depname)
++
++install-common:
+ $(INSTALL_DIR) $(DESTDIR)$(includedir)
+ for f in wx/svg/dcsvg.h; do \
+ if test ! -d $(DESTDIR)$(includedir)/`dirname $$f` ; then \
diff --git a/x11-toolkits/wxgtk29/files/patch-contrib-src-xrc-Makefile.in b/x11-toolkits/wxgtk29/files/patch-contrib-src-xrc-Makefile.in
new file mode 100644
index 000000000000..aafcaa405758
--- /dev/null
+++ b/x11-toolkits/wxgtk29/files/patch-contrib-src-xrc-Makefile.in
@@ -0,0 +1,11 @@
+--- contrib/src/xrc/Makefile.in.orig Sun Jun 27 21:37:21 2004
++++ contrib/src/xrc/Makefile.in Sun Jun 27 21:37:44 2004
+@@ -258,6 +258,8 @@
+ all: $(__xrcdll___depname) $(__xrclib___depname)
+
+ install: all $(__install_xrcdll___depname) $(__install_xrclib___depname)
++
++install-common:
+ $(INSTALL_DIR) $(DESTDIR)$(includedir)
+ for f in wx/xrc/xmlres.h wx/xrc/xh_all.h wx/xrc/xh_bmp.h wx/xrc/xh_bmpbt.h wx/xrc/xh_bttn.h wx/xrc/xh_cald.h wx/xrc/xh_chckb.h wx/xrc/xh_chckl.h wx/xrc/xh_choic.h wx/xrc/xh_combo.h wx/xrc/xh_dlg.h wx/xrc/xh_frame.h wx/xrc/xh_gauge.h wx/xrc/xh_gdctl.h wx/xrc/xh_html.h wx/xrc/xh_listb.h wx/xrc/xh_listc.h wx/xrc/xh_menu.h wx/xrc/xh_notbk.h wx/xrc/xh_panel.h wx/xrc/xh_radbt.h wx/xrc/xh_radbx.h wx/xrc/xh_scrol.h wx/xrc/xh_scwin.h wx/xrc/xh_sizer.h wx/xrc/xh_slidr.h wx/xrc/xh_spin.h wx/xrc/xh_split.h wx/xrc/xh_statbar.h wx/xrc/xh_stbmp.h wx/xrc/xh_stbox.h wx/xrc/xh_stlin.h wx/xrc/xh_sttxt.h wx/xrc/xh_text.h wx/xrc/xh_toolb.h wx/xrc/xh_tree.h wx/xrc/xh_unkwn.h wx/xrc/xh_wizrd.h; do \
+ if test ! -d $(DESTDIR)$(includedir)/`dirname $$f` ; then \
diff --git a/x11-toolkits/wxgtk29/files/patch-contrib-utils-Makefile.in b/x11-toolkits/wxgtk29/files/patch-contrib-utils-Makefile.in
new file mode 100644
index 000000000000..acbcfacb0b56
--- /dev/null
+++ b/x11-toolkits/wxgtk29/files/patch-contrib-utils-Makefile.in
@@ -0,0 +1,12 @@
+--- contrib/utils/Makefile.in.orig Mon Jun 28 03:47:07 2004
++++ contrib/utils/Makefile.in Mon Jun 28 03:47:23 2004
+@@ -5,6 +5,9 @@
+ all:
+ @for d in $(CONTRIB_UTILS); do (cd $$d && $(MAKE)); done
+
++install:
++ @for d in $(CONTRIB_UTILS); do (cd $$d && $(MAKE) install); done
++
+ clean:
+ @for d in $(CONTRIB_UTILS); do (cd $$d && $(MAKE) clean); done
+
diff --git a/x11-toolkits/wxgtk29/files/patch-wx-config.in b/x11-toolkits/wxgtk29/files/patch-wx-config.in
new file mode 100644
index 000000000000..99fb6adf332c
--- /dev/null
+++ b/x11-toolkits/wxgtk29/files/patch-wx-config.in
@@ -0,0 +1,11 @@
+--- wx-config.in.orig Mon May 31 18:11:50 2004
++++ wx-config.in Sun Jun 27 20:08:21 2004
+@@ -230,7 +230,7 @@
+ includes=" -I${includedir}"
+ fi
+
+- includes="-I${libdir}/wx/include/${TOOLCHAIN_NAME}$includes"
++ includes="-I${includedir}/wx/include/${TOOLCHAIN_NAME}$includes"
+
+ # in inplace case we need to also add path to contrib headers -- do it
+ # unconditionally as they might be used and we have no way of knowing if
diff --git a/x11-toolkits/wxgtk29/pkg-descr b/x11-toolkits/wxgtk29/pkg-descr
new file mode 100644
index 000000000000..67f1f41d315b
--- /dev/null
+++ b/x11-toolkits/wxgtk29/pkg-descr
@@ -0,0 +1,4 @@
+wxWidgets (formerly known as wxWindows) is a C++ GUI framework for platform
+independent software development. On FreeBSD the Gtk toolkit is used.
+
+WWW: http://www.wxwidgets.org/
diff --git a/x11-toolkits/wxgtk29/pkg-plist b/x11-toolkits/wxgtk29/pkg-plist
new file mode 100644
index 000000000000..0af111d8925e
--- /dev/null
+++ b/x11-toolkits/wxgtk29/pkg-plist
@@ -0,0 +1,26 @@
+bin/wxgtk2-2.5-config
+include/wx/include/gtk2-2.5/wx/setup.h
+lib/libwx_base-2.5.so
+lib/libwx_base-2.5.so.2
+lib/libwx_base-2.5.so.2.0.0
+lib/libwx_base_net-2.5.so
+lib/libwx_base_net-2.5.so.2
+lib/libwx_base_net-2.5.so.2.0.0
+lib/libwx_base_xml-2.5.so
+lib/libwx_base_xml-2.5.so.2
+lib/libwx_base_xml-2.5.so.2.0.0
+lib/libwx_gtk2_adv-2.5.so
+lib/libwx_gtk2_adv-2.5.so.2
+lib/libwx_gtk2_adv-2.5.so.2.0.0
+lib/libwx_gtk2_core-2.5.so
+lib/libwx_gtk2_core-2.5.so.2
+lib/libwx_gtk2_core-2.5.so.2.0.0
+lib/libwx_gtk2_gl-2.5.so
+lib/libwx_gtk2_gl-2.5.so.2
+lib/libwx_gtk2_gl-2.5.so.2.0.0
+lib/libwx_gtk2_html-2.5.so
+lib/libwx_gtk2_html-2.5.so.2
+lib/libwx_gtk2_html-2.5.so.2.0.0
+@dirrm include/wx/include/gtk2-2.5/wx
+@dirrm include/wx/include/gtk2-2.5
+@dirrm include/wx/include