aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-04 16:22:52 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-04 16:22:52 +0000
commit1b75d7344f5d9aaea20580c23e6bd847f33834fc (patch)
treefcead275dffbb828a3f39f42ecceb2263a41ef65 /x11-toolkits
parentea7c07d1dcbad3a3d8c0d5d20adca6d88263bfa8 (diff)
downloadports-1b75d7344f5d9aaea20580c23e6bd847f33834fc.tar.gz
ports-1b75d7344f5d9aaea20580c23e6bd847f33834fc.zip
add viewklass 0.52
C++ Framework for Motif
Notes
Notes: svn path=/head/; revision=60605
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/Makefile1
-rw-r--r--x11-toolkits/viewklass/Makefile30
-rw-r--r--x11-toolkits/viewklass/distinfo1
-rw-r--r--x11-toolkits/viewklass/files/patch-VkTrace.C10
-rw-r--r--x11-toolkits/viewklass/pkg-comment1
-rw-r--r--x11-toolkits/viewklass/pkg-descr11
-rw-r--r--x11-toolkits/viewklass/pkg-plist72
7 files changed, 126 insertions, 0 deletions
diff --git a/x11-toolkits/Makefile b/x11-toolkits/Makefile
index ac3e36bd4499..6009299f171e 100644
--- a/x11-toolkits/Makefile
+++ b/x11-toolkits/Makefile
@@ -138,6 +138,7 @@
SUBDIR += vdk
SUBDIR += vdkbuilder
SUBDIR += viewkit
+ SUBDIR += viewklass
SUBDIR += whistlerk
SUBDIR += wxgtk
SUBDIR += wxgtk-devel
diff --git a/x11-toolkits/viewklass/Makefile b/x11-toolkits/viewklass/Makefile
new file mode 100644
index 000000000000..961d26fed377
--- /dev/null
+++ b/x11-toolkits/viewklass/Makefile
@@ -0,0 +1,30 @@
+# ex:ts=8
+# Ports collection makefile for: viewklass
+# Date created: Jun 4, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= viewklass
+PORTVERSION= 0.5.2
+CATEGORIES= x11-toolkits
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ViewKlass-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_MOTIF= yes
+GNU_CONFIGURE= yes
+
+post-patch:
+ @${PERL} -pi -e "s/^CFLAGS=/CFLAGS+=/g ; s/^CXXFLAGS=/CXXFLAGS+=/g ; \
+ s/-g -Wall//g" ${WRKSRC}/Makefile.in
+
+post-install:
+.for file in libvk.a libvkhelp.a
+ @${STRIP_CMD} ${PREFIX}/lib/${file}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/viewklass/distinfo b/x11-toolkits/viewklass/distinfo
new file mode 100644
index 000000000000..a2bf24f07c76
--- /dev/null
+++ b/x11-toolkits/viewklass/distinfo
@@ -0,0 +1 @@
+MD5 (ViewKlass-0.5.2.tar.gz) = 9cb60f02db6e502b36d13ce641d49631
diff --git a/x11-toolkits/viewklass/files/patch-VkTrace.C b/x11-toolkits/viewklass/files/patch-VkTrace.C
new file mode 100644
index 000000000000..7c4491357130
--- /dev/null
+++ b/x11-toolkits/viewklass/files/patch-VkTrace.C
@@ -0,0 +1,10 @@
+--- VkTrace.C.orig Wed Jun 5 00:04:51 2002
++++ VkTrace.C Wed Jun 5 00:05:25 2002
+@@ -28,6 +28,7 @@
+ #include <stdio.h>
+ #include <time.h>
+ #include <string.h>
++#include <stdarg.h>
+
+ #include <Vk/VkTrace.h>
+
diff --git a/x11-toolkits/viewklass/pkg-comment b/x11-toolkits/viewklass/pkg-comment
new file mode 100644
index 000000000000..67db82f02107
--- /dev/null
+++ b/x11-toolkits/viewklass/pkg-comment
@@ -0,0 +1 @@
+C++ Framework for Motif
diff --git a/x11-toolkits/viewklass/pkg-descr b/x11-toolkits/viewklass/pkg-descr
new file mode 100644
index 000000000000..8a72e65f840b
--- /dev/null
+++ b/x11-toolkits/viewklass/pkg-descr
@@ -0,0 +1,11 @@
+ViewKlass is a C++ framework for developing applications which use the
+LessTif, OpenMotif or OSF/Motif[TM] user interface toolkits. In particular
+it provides classes which support the creation of reusable components. This
+helps to simplify the development of applications using object-oriented
+techniques.
+
+It also provides classes which encapsulate some of the more difficult and
+tedious aspects of Motif development. These include classes which handle
+the creation of windows, dialogs and menus.
+
+WWW: http://viewklass.sourceforge.net/
diff --git a/x11-toolkits/viewklass/pkg-plist b/x11-toolkits/viewklass/pkg-plist
new file mode 100644
index 000000000000..0869e25a494b
--- /dev/null
+++ b/x11-toolkits/viewklass/pkg-plist
@@ -0,0 +1,72 @@
+include/Vk/VkAction.h
+include/Vk/VkAlignmentGroup.h
+include/Vk/VkApp.h
+include/Vk/VkBackground.h
+include/Vk/VkBusyDialog.h
+include/Vk/VkCallbackList.h
+include/Vk/VkCallbackObject.h
+include/Vk/VkCheckBox.h
+include/Vk/VkComponent.h
+include/Vk/VkComponentList.h
+include/Vk/VkConfig.h
+include/Vk/VkCursorList.h
+include/Vk/VkDialogManager.h
+include/Vk/VkErrorDialog.h
+include/Vk/VkFatalErrorDialog.h
+include/Vk/VkFileSelectionDialog.h
+include/Vk/VkFormat.h
+include/Vk/VkGangedGroup.h
+include/Vk/VkGenericDialog.h
+include/Vk/VkHelpAPI.h
+include/Vk/VkHelpPane.h
+include/Vk/VkInfoDialog.h
+include/Vk/VkInput.h
+include/Vk/VkInterruptDialog.h
+include/Vk/VkMenu.h
+include/Vk/VkMenuAction.h
+include/Vk/VkMenuBar.h
+include/Vk/VkMenuConfirmFirstAction.h
+include/Vk/VkMenuItem.h
+include/Vk/VkMenuLabel.h
+include/Vk/VkMenuSeparator.h
+include/Vk/VkMenuToggle.h
+include/Vk/VkMenuUndoManager.h
+include/Vk/VkModel.h
+include/Vk/VkNameList.h
+include/Vk/VkOptionMenu.h
+include/Vk/VkPeriodic.h
+include/Vk/VkPipe.h
+include/Vk/VkPopupMenu.h
+include/Vk/VkPrefCustom.h
+include/Vk/VkPrefDialog.h
+include/Vk/VkPrefEmpty.h
+include/Vk/VkPrefGroup.h
+include/Vk/VkPrefItem.h
+include/Vk/VkPrefLabel.h
+include/Vk/VkPrefList.h
+include/Vk/VkPrefOption.h
+include/Vk/VkPrefRadio.h
+include/Vk/VkPrefSeparator.h
+include/Vk/VkPrefText.h
+include/Vk/VkPrefToggle.h
+include/Vk/VkProgram.h
+include/Vk/VkProgressDialog.h
+include/Vk/VkPromptDialog.h
+include/Vk/VkQuestionDialog.h
+include/Vk/VkRadioBox.h
+include/Vk/VkRadioGroup.h
+include/Vk/VkRadioSubMenu.h
+include/Vk/VkRepeatButton.h
+include/Vk/VkResource.h
+include/Vk/VkSelectionDialog.h
+include/Vk/VkSimpleWindow.h
+include/Vk/VkSubMenu.h
+include/Vk/VkSubProcess.h
+include/Vk/VkTrace.h
+include/Vk/VkWarningDialog.h
+include/Vk/VkWidgetList.h
+include/Vk/VkWindow.h
+include/Vk/builtinbusy.h
+@dirrm include/Vk
+lib/libvk.a
+lib/libvkhelp.a