aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2016-05-24 11:14:01 +0000
committerKurt Jaeger <pi@FreeBSD.org>2016-05-24 11:14:01 +0000
commit34666b31741b466250f707819d62c1c5b797e166 (patch)
treef91e3987d63bbe6c821ecf422e75567487c9949b /x11-toolkits
parentf2780441e4e54ef9fa4b2638b0813a56211fd26f (diff)
downloadports-34666b31741b466250f707819d62c1c5b797e166.tar.gz
ports-34666b31741b466250f707819d62c1c5b797e166.zip
x11-toolkits/qt5-widgets: fix scaling / cropping for full-screen applications
- tcberner: Fix the fullscreen behaviour of VLC when using the Qt5 frontend. PR: 208185 Submitted by: nolden@kde.org (kde)
Notes
Notes: svn path=/head/; revision=415779
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/qt5-widgets/Makefile11
-rw-r--r--x11-toolkits/qt5-widgets/files/patch-cr-13906640
-rw-r--r--x11-toolkits/qt5-widgets/pkg-plist3
3 files changed, 53 insertions, 1 deletions
diff --git a/x11-toolkits/qt5-widgets/Makefile b/x11-toolkits/qt5-widgets/Makefile
index eeee48719bbb..de9dbc01c67b 100644
--- a/x11-toolkits/qt5-widgets/Makefile
+++ b/x11-toolkits/qt5-widgets/Makefile
@@ -2,6 +2,7 @@
PORTNAME= widgets
DISTVERSION= ${QT5_VERSION}
+PORTREVISION= 1
CATEGORIES= x11-toolkits
PKGNAMEPREFIX= qt5-
@@ -17,12 +18,15 @@ USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
BUILD_WRKSRC= ${WRKSRC}/src/${PORTNAME}
INSTALL_WRKSRC= ${BUILD_WRKSRC}
-MORE_WRKSRCS= src/tools/uic
+MORE_WRKSRCS= src/tools/uic \
+ src/plugins/platformthemes
QT_DEFINES= ACCESSIBILITY WIDGETS XSYNC
QT_CONFIG= accessibility accessibility-atspi-bridge xlib
OPTIONS_DEFINE= GTK2
+OPTIONS_SUB= yes
+
GTK2_DESC= GTK+-based Qt theme
GTK2_USE= GNOME=gtk20
@@ -39,6 +43,11 @@ QT_DEFINES+= -STYLE_GTK
QT_CONFIG+= -gtkstyle
.endif
+# libQt5PlatformSupport.a is installed by qt5-core but needed for the gtk style plugin
+post-configure:
+ ${LN} -s ${QT_LIBDIR}/libQt5PlatformSupport.a \
+ ${WRKSRC}/lib/libQt5PlatformSupport.a
+
pre-build:
@cd ${WRKSRC}/src/tools/uic && \
${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} \
diff --git a/x11-toolkits/qt5-widgets/files/patch-cr-139066 b/x11-toolkits/qt5-widgets/files/patch-cr-139066
new file mode 100644
index 000000000000..5fe07c079254
--- /dev/null
+++ b/x11-toolkits/qt5-widgets/files/patch-cr-139066
@@ -0,0 +1,40 @@
+From 0f68f8920573cdce1729a285a92ac8582df32841 Mon Sep 17 00:00:00 2001
+From: Ulf Hermann <ulf.hermann@theqtcompany.com>
+Date: Tue, 27 Oct 2015 15:25:42 +0100
+Subject: [PATCH] QtWidgets: Do hide/show via WA_OutsideWSRange for native
+ widgets
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+If a native widget has a width or height of 0 we don't have to
+invalidate its backing store as that is done by the window
+system. Certain applications rely on ... interesting ... behavior
+of certain window systems in this case.
+
+Task-number: QTBUG-48321
+Change-Id: I78ef29975181ee22429c9bd4b11d96d9e68b7a9c
+Reviewed-by: Dmitry Shachnev <mitya57@gmail.com>
+Reviewed-by: Alexander Volkov <a.volkov@rusbitech.ru>
+Reviewed-by: Lisandro Damián Nicanor Pérez Meyer <perezmeyer@gmail.com>
+Reviewed-by: Paul Olav Tvete <paul.tvete@theqtcompany.com>
+---
+ src/widgets/kernel/qwidget.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/widgets/kernel/qwidget.cpp b/src/widgets/kernel/qwidget.cpp
+index 7734715..4286130 100644
+--- src/widgets/kernel/qwidget.cpp
++++ src/widgets/kernel/qwidget.cpp
+@@ -7169,7 +7169,7 @@ void QWidgetPrivate::setGeometry_sys(int x, int y, int w, int h, bool isMove)
+
+ bool needsShow = false;
+
+- if (q->isWindow()) {
++ if (q->isWindow() || q->windowHandle()) {
+ if (!(data.window_state & Qt::WindowFullScreen) && (w == 0 || h == 0)) {
+ q->setAttribute(Qt::WA_OutsideWSRange, true);
+ if (q->isVisible() && q->testAttribute(Qt::WA_Mapped))
+--
+2.8.1
+
diff --git a/x11-toolkits/qt5-widgets/pkg-plist b/x11-toolkits/qt5-widgets/pkg-plist
index 16193d66122b..3877830c52b9 100644
--- a/x11-toolkits/qt5-widgets/pkg-plist
+++ b/x11-toolkits/qt5-widgets/pkg-plist
@@ -486,6 +486,7 @@
%%QT_INCDIR%%/QtWidgets/qwidgetaction.h
%%QT_INCDIR%%/QtWidgets/qwidgetsfunctions_wince.h
%%QT_INCDIR%%/QtWidgets/qwizard.h
+%%GTK2%%%%QT_LIBDIR%%/cmake/Qt5Gui/Qt5Gui_QGtk2ThemePlugin.cmake
%%QT_LIBDIR%%/cmake/Qt5Widgets/Qt5WidgetsConfig.cmake
%%QT_LIBDIR%%/cmake/Qt5Widgets/Qt5WidgetsConfigExtras.cmake
%%QT_LIBDIR%%/cmake/Qt5Widgets/Qt5WidgetsConfigVersion.cmake
@@ -498,6 +499,8 @@
%%DEBUG%%%%QT_LIBDIR%%/libQt5Widgets.so.%%FULLVER%%.debug
%%QT_BINDIR%%/uic
%%QT_MKSPECDIR%%/modules/qt_lib_widgets.pri
+%%GTK2%%%%QT_PLUGINDIR%%/platformthemes/libqgtk2.so
+%%GTK2%%%%DEBUG%%%%QT_PLUGINDIR%%/platformthemes/libqgtk2.so.debug
%%QT_MKSPECDIR%%/modules/qt_lib_widgets_private.pri
libdata/pkgconfig/Qt5Widgets.pc
share/pixmaps/qt5logo.png