aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2005-01-24 10:31:59 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2005-01-24 10:31:59 +0000
commit6007d776743c46210503e715d4a5b425d426abeb (patch)
treeed9695045a86e3f1efccd3af7522c52bace88b81 /x11-toolkits
parent3929de15e423a8beb36dee50d112a4f05f22e4d6 (diff)
downloadports-6007d776743c46210503e715d4a5b425d426abeb.tar.gz
ports-6007d776743c46210503e715d4a5b425d426abeb.zip
- Fix bad C++ code to unbreak with recent GCC
- Reindent Makefile (to make portlint(1) happy)
Notes
Notes: svn path=/head/; revision=127171
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/viewkit/Makefile33
1 files changed, 15 insertions, 18 deletions
diff --git a/x11-toolkits/viewkit/Makefile b/x11-toolkits/viewkit/Makefile
index 75ef65d79342..8fa8160593b4 100644
--- a/x11-toolkits/viewkit/Makefile
+++ b/x11-toolkits/viewkit/Makefile
@@ -1,38 +1,35 @@
-#
-# ports collection makefile for: Viewkit from Hungry Programming.
-# Date created: Aug 2000
-# Whom: peterho@ned.dem.csiro.au
+# New ports collection makefile for: Viewkit from Hungry Programming
+# Date created: Aug 2000
+# Whom: peterho@ned.dem.csiro.au
#
# $FreeBSD$
#
-#
-#
-PORTNAME= viewkit
-PORTVERSION= 0.00
+PORTNAME= viewkit
+PORTVERSION= 0.00
CATEGORIES= x11-toolkits
MASTER_SITES= ftp://ftp.hungry.com/pub/hungry/viewkit/ \
${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= fenner
-DISTNAME= libvk-Apr19-2243
+DISTNAME= libvk-Apr19-2243
MAINTAINER= ports@FreeBSD.org
COMMENT= ViewKit workalike from Hungry Programmers
WANT_AUTOCONF_VER= 253
-MOTIFPACKAGE?= open-motif
-USE_X_PREFIX= yes
-USE_MOTIF = yes
+MOTIFPACKAGE?= open-motif
+USE_X_PREFIX= yes
+USE_MOTIF= yes
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-${MOTIFPACKAGE}
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile (bad C++ code)"
-.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's/^friend/friend class/' ${WRKSRC}/Vk/VkAction.h \
+ ${WRKSRC}/Vk/VkApp.h ${WRKSRC}/Vk/VkMenu.h
+ @${REINPLACE_CMD} -E 's/\((VkPipe::handleInput)\)/\1/' ${WRKSRC}/VkPipe.C
pre-configure:
@cd ${WRKSRC}; ${CHMOD} +w configure; ${AUTOCONF}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>