aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2002-07-09 23:14:13 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2002-07-09 23:14:13 +0000
commit63affb72a92460afd09e8723009b71a6ab5c753d (patch)
tree85e23ba59adfec3464d897c7f2149b9acfcf331f /x11-toolkits
parent8dab0b4e49083ac622f1edb8b7b904fd9c28b148 (diff)
downloadports-63affb72a92460afd09e8723009b71a6ab5c753d.tar.gz
ports-63affb72a92460afd09e8723009b71a6ab5c753d.zip
Remove my previous patch in favor of a new patch to nautilus2. This new patch
is better as it preserves thead safety in eel. While I'm here, make this a REINPLACE port.
Notes
Notes: svn path=/head/; revision=62732
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/eel2/Makefile13
-rw-r--r--x11-toolkits/eel2/files/patch-eel_eel-gdk-pixbuf-extensions.c11
2 files changed, 7 insertions, 17 deletions
diff --git a/x11-toolkits/eel2/Makefile b/x11-toolkits/eel2/Makefile
index f6bb0eb468cc..9b89031404ed 100644
--- a/x11-toolkits/eel2/Makefile
+++ b/x11-toolkits/eel2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= eel2
PORTVERSION= 2.0.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11-toolkits gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= 2.0.0/releases/gnome-2.0-desktop-final
@@ -25,6 +25,7 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
USE_LIBTOOL= yes
+USE_REINPLACE= yes
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
--datadir=${PREFIX}/share/gnome \
@@ -35,11 +36,11 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g ; \
- s|\$\(libdir\)/pkgconfig|\$\(prefix\)/libdata/pkgconfig|g'
+ @find ${WRKSRC} -name "Makefile.in*" | xargs ${REINPLACE_CMD} -e \
+ 's|[(]datadir[)]/gnome/|(datadir)/|g ; \
+ s|[(]datadir[)]/locale|(prefix)/share/locale|g ; \
+ s|[(]libdir[)]/pkgconfig|(prefix)/libdata/pkgconfig|g'
.include <bsd.port.mk>
diff --git a/x11-toolkits/eel2/files/patch-eel_eel-gdk-pixbuf-extensions.c b/x11-toolkits/eel2/files/patch-eel_eel-gdk-pixbuf-extensions.c
deleted file mode 100644
index 1b0db66bd4d1..000000000000
--- a/x11-toolkits/eel2/files/patch-eel_eel-gdk-pixbuf-extensions.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- eel/eel-gdk-pixbuf-extensions.c.orig Sun Jul 7 03:24:52 2002
-+++ eel/eel-gdk-pixbuf-extensions.c Sun Jul 7 03:25:03 2002
-@@ -101,7 +101,7 @@
- {
- GnomeVFSResult result;
- GnomeVFSHandle *handle;
-- char buffer[LOAD_BUFFER_SIZE];
-+ static char buffer[LOAD_BUFFER_SIZE];
- GnomeVFSFileSize bytes_read;
- GdkPixbufLoader *loader;
- GdkPixbuf *pixbuf;