aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2015-09-19 17:15:16 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2015-09-19 17:15:16 +0000
commit6e632c70191f4ed2c0436de9971e82c0d7c56f6f (patch)
treec8ab989493ebbf08a7d30928ccc478b1b9678c2e /x11-toolkits
parent1b5026e7732a2e66574bb76c5ff8b3948eb3bf9c (diff)
downloadports-6e632c70191f4ed2c0436de9971e82c0d7c56f6f.tar.gz
ports-6e632c70191f4ed2c0436de9971e82c0d7c56f6f.zip
- Make dependency on `www/webkit-gtk2' optional: there's a configure switch
for this, and it is quite heavy while not necessarily always desirable - Remove bogus `+=' from LIB_DEPENDS and USES: the port is not being master for anyone, thus those were just confusing - Consistently put space before trailing backslash when wrapping long lines - Reword MSPACK_DESC (MS -> Microsoft) while I'm here
Notes
Notes: svn path=/head/; revision=397332
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/wxgtk30/Makefile38
-rw-r--r--x11-toolkits/wxgtk30/pkg-plist6
2 files changed, 23 insertions, 21 deletions
diff --git a/x11-toolkits/wxgtk30/Makefile b/x11-toolkits/wxgtk30/Makefile
index 592c492184d3..9a7793189454 100644
--- a/x11-toolkits/wxgtk30/Makefile
+++ b/x11-toolkits/wxgtk30/Makefile
@@ -11,39 +11,38 @@ DISTNAME= wxWidgets-${PORTVERSION}
MAINTAINER= portmaster@bsdforge.com
COMMENT= The wxWidgets GUI toolkit with GTK+ bindings
-LIB_DEPENDS+= libpng.so:${PORTSDIR}/graphics/png\
- libtiff.so:${PORTSDIR}/graphics/tiff\
- libexpat.so:${PORTSDIR}/textproc/expat2\
- libwebkitgtk-1.0.so:${PORTSDIR}/www/webkit-gtk2
+LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png \
+ libtiff.so:${PORTSDIR}/graphics/tiff \
+ libexpat.so:${PORTSDIR}/textproc/expat2
-USES+= compiler:c++11-lib gmake iconv jpeg pkgconfig tar:bzip2
+USES= compiler:c++11-lib gmake iconv jpeg pkgconfig tar:bzip2
USE_XORG= x11 sm xxf86vm xinerama
USE_GL= glu
USE_GNOME= gtk20
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-libpng=sys\
- --with-libjpeg=sys\
- --with-libtiff=sys\
- --with-zlib=sys\
- --with-expat=sys\
- --with-opengl\
- --with-libmspack\
- --with-gtk\
- --disable-backtrace\
- --enable-webview\
+CONFIGURE_ARGS= --with-libpng=sys \
+ --with-libjpeg=sys \
+ --with-libtiff=sys \
+ --with-zlib=sys \
+ --with-expat=sys \
+ --with-opengl \
+ --with-libmspack \
+ --with-gtk \
+ --disable-backtrace \
--enable-graphics_ctx \
--enable-compat26 \
--enable-compat28
CONFIGURE_ENV= X11BASE="${LOCALBASE}" \
ac_cv_header_sys_inotify_h=no
+
CPPFLAGS+= -I${LOCALBASE}/include
CXXFLAGS+= -std=c++11
LIBS+= -L${LOCALBASE}/lib
-OPTIONS_DEFINE= GSTREAMER MSPACK NLS
-OPTIONS_DEFAULT=GSTREAMER MSPACK
-MSPACK_DESC= MS archives support
+OPTIONS_DEFINE= GSTREAMER MSPACK NLS WEBKIT
+OPTIONS_DEFAULT=GSTREAMER MSPACK WEBKIT
+MSPACK_DESC= Microsoft archives support
OPTIONS_SUB= yes
NLS_USES= gettext
@@ -52,6 +51,9 @@ GSTREAMER_USE= GNOME=gconf2 GSTREAMER=yes
MSPACK_CONFIGURE_WITH= libmspack
MSPACK_LIB_DEPENDS= libmspack.so:${PORTSDIR}/archivers/libmspack
+WEBKIT_CONFIGURE_ENABLE= webview
+WEBKIT_LIB_DEPENDS= libwebkitgtk-1.0.so:${PORTSDIR}/www/webkit-gtk2
+
.include <bsd.port.pre.mk>
# PR 196703, 197031
diff --git a/x11-toolkits/wxgtk30/pkg-plist b/x11-toolkits/wxgtk30/pkg-plist
index 26ace74ba5fd..dd28777e9330 100644
--- a/x11-toolkits/wxgtk30/pkg-plist
+++ b/x11-toolkits/wxgtk30/pkg-plist
@@ -752,9 +752,9 @@ lib/libwx_gtk2u_richtext-3.0.so.0.2.0
lib/libwx_gtk2u_stc-3.0.so
lib/libwx_gtk2u_stc-3.0.so.0
lib/libwx_gtk2u_stc-3.0.so.0.2.0
-lib/libwx_gtk2u_webview-3.0.so
-lib/libwx_gtk2u_webview-3.0.so.0
-lib/libwx_gtk2u_webview-3.0.so.0.2.0
+%%WEBKIT%%lib/libwx_gtk2u_webview-3.0.so
+%%WEBKIT%%lib/libwx_gtk2u_webview-3.0.so.0
+%%WEBKIT%%lib/libwx_gtk2u_webview-3.0.so.0.2.0
lib/libwx_gtk2u_xrc-3.0.so
lib/libwx_gtk2u_xrc-3.0.so.0
lib/libwx_gtk2u_xrc-3.0.so.0.2.0