aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
authorTim Vanderhoek <hoek@FreeBSD.org>1998-07-27 21:36:08 +0000
committerTim Vanderhoek <hoek@FreeBSD.org>1998-07-27 21:36:08 +0000
commit8a135bbda0c193a88f9bbce611a6bf3148c67b96 (patch)
treed2e7890ad32ecd23c27e289d32418ef6f82c8da2 /x11-toolkits
parente19be50eb8eb0a5454ea46d5b1d0462d577aa948 (diff)
downloadports-8a135bbda0c193a88f9bbce611a6bf3148c67b96.tar.gz
ports-8a135bbda0c193a88f9bbce611a6bf3148c67b96.zip
Install a wish script that spits-out all the various names for wish. The
script handles for tclX and tkstep. This is as per several discussions on -ports. I expect one or two of the depending ports to break silently. I didn't touch the ja-ports, since INSTALL.wish might want translating? PR: bin/5894 Mention: Eivind, who wrote part of INSTALL.wish
Notes
Notes: svn path=/head/; revision=12168
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/tk80/Makefile7
-rw-r--r--x11-toolkits/tk80/pkg-install.wish31
-rw-r--r--x11-toolkits/tk82/Makefile7
-rw-r--r--x11-toolkits/tk82/pkg-install.wish31
-rw-r--r--x11-toolkits/tk83/Makefile7
-rw-r--r--x11-toolkits/tk83/pkg-install.wish31
-rw-r--r--x11-toolkits/tk84/Makefile7
-rw-r--r--x11-toolkits/tk84/pkg-install.wish31
-rw-r--r--x11-toolkits/tkstep80/Makefile7
9 files changed, 154 insertions, 5 deletions
diff --git a/x11-toolkits/tk80/Makefile b/x11-toolkits/tk80/Makefile
index 4f2bee8e55be..af7ed1b03147 100644
--- a/x11-toolkits/tk80/Makefile
+++ b/x11-toolkits/tk80/Makefile
@@ -3,7 +3,7 @@
# Date created: 19 August 1997
# Whom: jkh
#
-# $Id: Makefile,v 1.8 1998/03/18 00:56:23 jmz Exp $
+# $Id: Makefile,v 1.9 1998/07/03 23:07:13 steve Exp $
#
DISTNAME= tk8.0p2
@@ -34,8 +34,13 @@ pre-build:
post-install:
${LDCONFIG} -m ${PREFIX}/lib
+.if exists(${PKGDIR}/INSTALL.wish)
+ ${SH} ${PKGDIR}/INSTALL.wish
+.endif
test:
cd ${WRKSRC}; make test
.include <bsd.port.mk>
+
+PKG_ARGS+= -i ${PKGDIR}/INSTALL.wish
diff --git a/x11-toolkits/tk80/pkg-install.wish b/x11-toolkits/tk80/pkg-install.wish
new file mode 100644
index 000000000000..ad18109783f1
--- /dev/null
+++ b/x11-toolkits/tk80/pkg-install.wish
@@ -0,0 +1,31 @@
+#!/bin/sh
+
+# The user may have a wish they want to preserve
+if [ ! -f ${PKG_PREFIX}/bin/wish ] || [ \
+ `grep -a awieYJFnsuILOnfsYEW ${PKG_PREFIX}/bin/wish | sed -e 's/.*\*\*//'` \
+ -lt 001 ]
+then
+ [ -f ${PKG_PREFIX}/bin/wish ] && chmod u+w ${PKG_PREFIX}/bin/wish
+
+ cat > ${PKG_PREFIX}/bin/wish <<'EOF'
+#!/bin/sh
+# Installed by ports system. id: awieYJFnsuILOnfsYEW**001
+
+(
+echo "In FreeBSD, wish is named with a version number. This is because"
+echo "different versions of wish are not compatible with each other and"
+echo "they can not all be called \"wish\"! You may need multiple versions"
+echo "installed because a given port may depend on a specific version."
+echo
+echo "On your system, wish is installed under at least the following names:"
+echo
+for name in $(/bin/ls $(echo $PATH | sed 's/:/ /g') 2> /dev/null | egrep '^wish(step)?(x|([0-9]+\.[0-9]+))([a-z][a-z])?$')
+do
+ echo $name
+done
+[ "$name" = "" ] && echo "No wish installations found, sorry."
+) 1>&2
+exit 1
+EOF
+ chmod a+rx ${PKG_PREFIX}/bin/wish
+fi
diff --git a/x11-toolkits/tk82/Makefile b/x11-toolkits/tk82/Makefile
index 22070a3e53e1..54158bd12ee9 100644
--- a/x11-toolkits/tk82/Makefile
+++ b/x11-toolkits/tk82/Makefile
@@ -3,7 +3,7 @@
# Date created: 19 August 1997
# Whom: jkh
#
-# $Id: Makefile,v 1.11 1998/07/01 10:21:02 jseger Exp $
+# $Id: Makefile,v 1.12 1998/07/12 21:07:21 jdp Exp $
#
DISTNAME= tk8.1a2
@@ -23,8 +23,13 @@ CONFIGURE_ENV= PORTSDIR=${PORTSDIR}
post-install:
${LDCONFIG} -m ${PREFIX}/lib
+.if exists(${PORTSDIR}/x11/tk80/pkg/INSTALL.wish)
+ ${SH} ${PORTSDIR}/x11/tk80/pkg/INSTALL.wish
+.endif
test:
cd ${WRKSRC}; make test
.include <bsd.port.mk>
+
+PKG_ARGS+= -i ${PORTSDIR}/x11/tk80/pkg/INSTALL.wish
diff --git a/x11-toolkits/tk82/pkg-install.wish b/x11-toolkits/tk82/pkg-install.wish
new file mode 100644
index 000000000000..ad18109783f1
--- /dev/null
+++ b/x11-toolkits/tk82/pkg-install.wish
@@ -0,0 +1,31 @@
+#!/bin/sh
+
+# The user may have a wish they want to preserve
+if [ ! -f ${PKG_PREFIX}/bin/wish ] || [ \
+ `grep -a awieYJFnsuILOnfsYEW ${PKG_PREFIX}/bin/wish | sed -e 's/.*\*\*//'` \
+ -lt 001 ]
+then
+ [ -f ${PKG_PREFIX}/bin/wish ] && chmod u+w ${PKG_PREFIX}/bin/wish
+
+ cat > ${PKG_PREFIX}/bin/wish <<'EOF'
+#!/bin/sh
+# Installed by ports system. id: awieYJFnsuILOnfsYEW**001
+
+(
+echo "In FreeBSD, wish is named with a version number. This is because"
+echo "different versions of wish are not compatible with each other and"
+echo "they can not all be called \"wish\"! You may need multiple versions"
+echo "installed because a given port may depend on a specific version."
+echo
+echo "On your system, wish is installed under at least the following names:"
+echo
+for name in $(/bin/ls $(echo $PATH | sed 's/:/ /g') 2> /dev/null | egrep '^wish(step)?(x|([0-9]+\.[0-9]+))([a-z][a-z])?$')
+do
+ echo $name
+done
+[ "$name" = "" ] && echo "No wish installations found, sorry."
+) 1>&2
+exit 1
+EOF
+ chmod a+rx ${PKG_PREFIX}/bin/wish
+fi
diff --git a/x11-toolkits/tk83/Makefile b/x11-toolkits/tk83/Makefile
index 22070a3e53e1..54158bd12ee9 100644
--- a/x11-toolkits/tk83/Makefile
+++ b/x11-toolkits/tk83/Makefile
@@ -3,7 +3,7 @@
# Date created: 19 August 1997
# Whom: jkh
#
-# $Id: Makefile,v 1.11 1998/07/01 10:21:02 jseger Exp $
+# $Id: Makefile,v 1.12 1998/07/12 21:07:21 jdp Exp $
#
DISTNAME= tk8.1a2
@@ -23,8 +23,13 @@ CONFIGURE_ENV= PORTSDIR=${PORTSDIR}
post-install:
${LDCONFIG} -m ${PREFIX}/lib
+.if exists(${PORTSDIR}/x11/tk80/pkg/INSTALL.wish)
+ ${SH} ${PORTSDIR}/x11/tk80/pkg/INSTALL.wish
+.endif
test:
cd ${WRKSRC}; make test
.include <bsd.port.mk>
+
+PKG_ARGS+= -i ${PORTSDIR}/x11/tk80/pkg/INSTALL.wish
diff --git a/x11-toolkits/tk83/pkg-install.wish b/x11-toolkits/tk83/pkg-install.wish
new file mode 100644
index 000000000000..ad18109783f1
--- /dev/null
+++ b/x11-toolkits/tk83/pkg-install.wish
@@ -0,0 +1,31 @@
+#!/bin/sh
+
+# The user may have a wish they want to preserve
+if [ ! -f ${PKG_PREFIX}/bin/wish ] || [ \
+ `grep -a awieYJFnsuILOnfsYEW ${PKG_PREFIX}/bin/wish | sed -e 's/.*\*\*//'` \
+ -lt 001 ]
+then
+ [ -f ${PKG_PREFIX}/bin/wish ] && chmod u+w ${PKG_PREFIX}/bin/wish
+
+ cat > ${PKG_PREFIX}/bin/wish <<'EOF'
+#!/bin/sh
+# Installed by ports system. id: awieYJFnsuILOnfsYEW**001
+
+(
+echo "In FreeBSD, wish is named with a version number. This is because"
+echo "different versions of wish are not compatible with each other and"
+echo "they can not all be called \"wish\"! You may need multiple versions"
+echo "installed because a given port may depend on a specific version."
+echo
+echo "On your system, wish is installed under at least the following names:"
+echo
+for name in $(/bin/ls $(echo $PATH | sed 's/:/ /g') 2> /dev/null | egrep '^wish(step)?(x|([0-9]+\.[0-9]+))([a-z][a-z])?$')
+do
+ echo $name
+done
+[ "$name" = "" ] && echo "No wish installations found, sorry."
+) 1>&2
+exit 1
+EOF
+ chmod a+rx ${PKG_PREFIX}/bin/wish
+fi
diff --git a/x11-toolkits/tk84/Makefile b/x11-toolkits/tk84/Makefile
index 22070a3e53e1..54158bd12ee9 100644
--- a/x11-toolkits/tk84/Makefile
+++ b/x11-toolkits/tk84/Makefile
@@ -3,7 +3,7 @@
# Date created: 19 August 1997
# Whom: jkh
#
-# $Id: Makefile,v 1.11 1998/07/01 10:21:02 jseger Exp $
+# $Id: Makefile,v 1.12 1998/07/12 21:07:21 jdp Exp $
#
DISTNAME= tk8.1a2
@@ -23,8 +23,13 @@ CONFIGURE_ENV= PORTSDIR=${PORTSDIR}
post-install:
${LDCONFIG} -m ${PREFIX}/lib
+.if exists(${PORTSDIR}/x11/tk80/pkg/INSTALL.wish)
+ ${SH} ${PORTSDIR}/x11/tk80/pkg/INSTALL.wish
+.endif
test:
cd ${WRKSRC}; make test
.include <bsd.port.mk>
+
+PKG_ARGS+= -i ${PORTSDIR}/x11/tk80/pkg/INSTALL.wish
diff --git a/x11-toolkits/tk84/pkg-install.wish b/x11-toolkits/tk84/pkg-install.wish
new file mode 100644
index 000000000000..ad18109783f1
--- /dev/null
+++ b/x11-toolkits/tk84/pkg-install.wish
@@ -0,0 +1,31 @@
+#!/bin/sh
+
+# The user may have a wish they want to preserve
+if [ ! -f ${PKG_PREFIX}/bin/wish ] || [ \
+ `grep -a awieYJFnsuILOnfsYEW ${PKG_PREFIX}/bin/wish | sed -e 's/.*\*\*//'` \
+ -lt 001 ]
+then
+ [ -f ${PKG_PREFIX}/bin/wish ] && chmod u+w ${PKG_PREFIX}/bin/wish
+
+ cat > ${PKG_PREFIX}/bin/wish <<'EOF'
+#!/bin/sh
+# Installed by ports system. id: awieYJFnsuILOnfsYEW**001
+
+(
+echo "In FreeBSD, wish is named with a version number. This is because"
+echo "different versions of wish are not compatible with each other and"
+echo "they can not all be called \"wish\"! You may need multiple versions"
+echo "installed because a given port may depend on a specific version."
+echo
+echo "On your system, wish is installed under at least the following names:"
+echo
+for name in $(/bin/ls $(echo $PATH | sed 's/:/ /g') 2> /dev/null | egrep '^wish(step)?(x|([0-9]+\.[0-9]+))([a-z][a-z])?$')
+do
+ echo $name
+done
+[ "$name" = "" ] && echo "No wish installations found, sorry."
+) 1>&2
+exit 1
+EOF
+ chmod a+rx ${PKG_PREFIX}/bin/wish
+fi
diff --git a/x11-toolkits/tkstep80/Makefile b/x11-toolkits/tkstep80/Makefile
index 1c75ce3b666c..be7a92c03c0d 100644
--- a/x11-toolkits/tkstep80/Makefile
+++ b/x11-toolkits/tkstep80/Makefile
@@ -3,7 +3,7 @@
# Date created: 06 November 1997
# Whom: Thomas Gellekum <tg@FreeBSD.ORG>
#
-# $Id: Makefile,v 1.8 1998/05/04 20:23:12 jseger Exp $
+# $Id: Makefile,v 1.9 1998/07/03 23:07:17 steve Exp $
#
DISTNAME= tk8.0p2
@@ -39,8 +39,13 @@ post-install:
${PREFIX}/share/doc/tkstep
.endif
${LDCONFIG} -m ${PREFIX}/lib
+.if exists(${PORTSDIR}/x11/tk80/pkg/INSTALL.wish)
+ ${SH} ${PORTSDIR}/x11/tk80/pkg/INSTALL.wish
+.endif
test:
cd ${WRKSRC}; make test
.include <bsd.port.mk>
+
+PKG_ARGS+= -i ${PORTSDIR}/x11/tk80/pkg/INSTALL.wish