aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-06-28 11:51:05 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-06-28 11:51:05 +0000
commit932db7c46c9a269808dfa67ea02746b350c194d8 (patch)
tree5182ef394eeef9bff78abf27f4a3a05f7fb8ff43 /x11-toolkits
parentb9b5e71f19dfde1a969d42e0660cc786432b3500 (diff)
downloadports-932db7c46c9a269808dfa67ea02746b350c194d8.tar.gz
ports-932db7c46c9a269808dfa67ea02746b350c194d8.zip
New USES imake to handle the dependency on imake.
This uses accept 'env' as an argument for ports that do use their own or a different do-configure target. Modify xmkmf so it accept IMAKECPPFLAGS as default flags for imake and pass it to the called imake. Modify xorg-cf-files (the FreeBSD.cf configuration file) to allow CppCmd to be overwritten. Pass CppCmd CcCmd and CplusplusCmd via command line to each call of imake via IMAKECPPFLAGS Pass IMAKE_DEFINE with the above arguments to MAKE_ARGS so that imake spawned from Makefile generated by a previous imake also inherit the defined CppCmd CcCmd and CplusplusCmd. Make imake use devel/tradcpp all the time, so that when buidling with clang we do not depend on gcc's cpp. Make imake respect CC and CXX Make imake respect USE_GCC (if set imake will use gcc's cpp). While here: - Remove a couple of indefinite articles from comments - Trim headers - Fix a couple of ports to build with clang or use: USE_GCC=any - Fix a now useless redefinition of the extraction chain - Fix a typo in japanese/Wnn7-lib bundled imake template definitions - Fix some XMKMF execution with no env specified - Use options helper in x11/xautolock to simplify the port
Notes
Notes: svn path=/head/; revision=321957
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/Xaw3d/Makefile2
-rw-r--r--x11-toolkits/xview-clients/Makefile2
-rw-r--r--x11-toolkits/xview/Makefile2
3 files changed, 3 insertions, 3 deletions
diff --git a/x11-toolkits/Xaw3d/Makefile b/x11-toolkits/Xaw3d/Makefile
index 9ef8bb76f9f5..97e55f4d6819 100644
--- a/x11-toolkits/Xaw3d/Makefile
+++ b/x11-toolkits/Xaw3d/Makefile
@@ -14,8 +14,8 @@ COMMENT= 3-D Athena Widget set that looks like Motif
LICENSE= MIT
WRKSRC= ${WRKDIR}/xc/lib/Xaw3d
+USES= imake
USE_GCC= any
-USE_IMAKE= yes
USE_XORG= x11 xext xmu xt sm ice xpm
USE_LDCONFIG= yes
diff --git a/x11-toolkits/xview-clients/Makefile b/x11-toolkits/xview-clients/Makefile
index 9657a690f6cb..042f7d2dc7c0 100644
--- a/x11-toolkits/xview-clients/Makefile
+++ b/x11-toolkits/xview-clients/Makefile
@@ -21,7 +21,7 @@ PATCH_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/x11-toolkits/xview:patch
CONFIGURE_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/x11-toolkits/xview:configure
LIB_DEPENDS= xview.3:${PORTSDIR}/x11-toolkits/xview
-USE_IMAKE= yes
+USES= imake
USE_XORG= x11 xext
WRKSRC= ${WRKDIRPREFIX}${.CURDIR}/../xview/work/${DISTNAME}
ALL_TARGET= Clients
diff --git a/x11-toolkits/xview/Makefile b/x11-toolkits/xview/Makefile
index 1ebeb5b5da54..ac2d63a577df 100644
--- a/x11-toolkits/xview/Makefile
+++ b/x11-toolkits/xview/Makefile
@@ -20,7 +20,7 @@ BUILD_DEPENDS= mkfontdir:${PORTSDIR}/x11-fonts/mkfontdir \
ONLY_FOR_ARCHS= i386
REINPLACE_ARGS= -i ""
-USE_IMAKE= yes
+USES= imake
USE_XORG= x11
USE_LDCONFIG= yes
IMAKEINCLUDE= "-I${WRKSRC}/config -I${LOCALBASE}/lib/X11/config"