aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-06-30 07:08:01 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-06-30 07:08:01 +0000
commit9b4ff447e9d2248dcd1b2ad1cf8170ae1cc64771 (patch)
tree9c5e6cd9aef0bac2d888b0b5466d484de6384093 /x11-toolkits
parent0f305c1be270583d876a7744355e6da6905645a6 (diff)
downloadports-9b4ff447e9d2248dcd1b2ad1cf8170ae1cc64771.tar.gz
ports-9b4ff447e9d2248dcd1b2ad1cf8170ae1cc64771.zip
x11-toolkits/rubygem-gtk2: Fix build with Clang 15 and revert a4021dd9e20bca9ada21837282e476b6c1356f23
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/rubygem-gtk2/Makefile14
-rw-r--r--x11-toolkits/rubygem-gtk2/files/patch-clang1522
2 files changed, 24 insertions, 12 deletions
diff --git a/x11-toolkits/rubygem-gtk2/Makefile b/x11-toolkits/rubygem-gtk2/Makefile
index 738ee1fdb2c5..bcdb9980b672 100644
--- a/x11-toolkits/rubygem-gtk2/Makefile
+++ b/x11-toolkits/rubygem-gtk2/Makefile
@@ -11,21 +11,11 @@ WWW= https://ruby-gnome2.osdn.jp/
LICENSE= LGPL21+
LICENSE_FILE= ${WRKSRC}/COPYING.LIB
-LIB_DEPENDS= libharfbuzz.so:print/harfbuzz \
- libfontconfig.so:x11-fonts/fontconfig \
- libfreetype.so:print/freetype2
RUN_DEPENDS= rubygem-atk>=${PORTVERSION}:accessibility/rubygem-atk \
rubygem-gdk_pixbuf2>=${PORTVERSION}:graphics/rubygem-gdk_pixbuf2 \
rubygem-pango>=${PORTVERSION}:x11-toolkits/rubygem-pango
-USES= gem gnome xorg
-USE_GNOME= cairo gdkpixbuf2 gtk20 introspection
-USE_XORG= x11
-
-.include <bsd.port.options.mk>
-
-.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400079 || ( ${OSVERSION} >= 1302505 && ${OSVERSION} < 1400000 ))
-CONFIGURE_ARGS+= --with-cflags="-Wno-error=int-conversion"
-.endif
+USES= gem gnome
+USE_GNOME= gtk20
.include <bsd.port.mk>
diff --git a/x11-toolkits/rubygem-gtk2/files/patch-clang15 b/x11-toolkits/rubygem-gtk2/files/patch-clang15
new file mode 100644
index 000000000000..8f2fe28674b0
--- /dev/null
+++ b/x11-toolkits/rubygem-gtk2/files/patch-clang15
@@ -0,0 +1,22 @@
+--- ext/gtk2/rbgdkscreen.c.orig 2023-06-13 15:11:58 UTC
++++ ext/gtk2/rbgdkscreen.c
+@@ -255,7 +255,7 @@ rg_window_stack(VALUE self)
+ static void
+ child_setup(gpointer func)
+ {
+- if (! NIL_P(func)){
++ if (! NIL_P((VALUE) func)){
+ rb_funcall((VALUE)func, id_call, 0);
+ }
+ }
+--- ext/gtk2/rbgtkdrag.c.orig 2023-06-13 15:21:51 UTC
++++ ext/gtk2/rbgtkdrag.c
+@@ -358,7 +358,7 @@ static VALUE
+ rg_m_source_get_target_list(G_GNUC_UNUSED VALUE self, VALUE widget)
+ {
+ GtkTargetList* ret = gtk_drag_source_get_target_list(RVAL2WIDGET(widget));
+- return NIL_P(ret) ? Qnil : BOXED2RVAL(ret, GTK_TYPE_TARGET_LIST);
++ return NIL_P((VALUE) ret) ? Qnil : BOXED2RVAL(ret, GTK_TYPE_TARGET_LIST);
+ }
+
+ static VALUE