aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
authorAlberto Villa <avilla@FreeBSD.org>2017-01-04 12:30:30 +0000
committerAlberto Villa <avilla@FreeBSD.org>2017-01-04 12:30:30 +0000
commitb8e66bf773ef4aa5c7e4b8b82939b0434a83e583 (patch)
tree72e68ec9a23dc6c6d0ac71c5c8ecc19c0c72ca7c /x11-toolkits
parent4c964489a0baa98e5462f8087246eacf41d142db (diff)
downloadports-b8e66bf773ef4aa5c7e4b8b82939b0434a83e583.tar.gz
ports-b8e66bf773ef4aa5c7e4b8b82939b0434a83e583.zip
Diorite is a a grey to dark-grey intermediate intrusive igneous rock.
Diorite library is a utility and widget library for Nuvola Player project based on GLib, GIO and GTK+ 3. WWW: https://tiliado.eu/diorite
Notes
Notes: svn path=/head/; revision=430553
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/Makefile1
-rw-r--r--x11-toolkits/diorite/Makefile42
-rw-r--r--x11-toolkits/diorite/distinfo3
-rw-r--r--x11-toolkits/diorite/files/patch-src_gtk_application.vala20
-rw-r--r--x11-toolkits/diorite/pkg-descr5
-rw-r--r--x11-toolkits/diorite/pkg-plist11
6 files changed, 82 insertions, 0 deletions
diff --git a/x11-toolkits/Makefile b/x11-toolkits/Makefile
index ca20faa9058c..c457c685b549 100644
--- a/x11-toolkits/Makefile
+++ b/x11-toolkits/Makefile
@@ -11,6 +11,7 @@
SUBDIR += blt
SUBDIR += bwidget
SUBDIR += c++-gtk-utils
+ SUBDIR += diorite
SUBDIR += flowcanvas
SUBDIR += fltk
SUBDIR += fltk-devel
diff --git a/x11-toolkits/diorite/Makefile b/x11-toolkits/diorite/Makefile
new file mode 100644
index 000000000000..4052058f06f1
--- /dev/null
+++ b/x11-toolkits/diorite/Makefile
@@ -0,0 +1,42 @@
+# $FreeBSD$
+
+PORTNAME= diorite
+PORTVERSION= 0.2.1
+CATEGORIES= x11-toolkits devel
+
+MAINTAINER= avilla@FreeBSD.org
+COMMENT= Utility and widget library based on GLib and GTK+ 3
+
+LICENSE= BSD2CLAUSE
+
+BUILD_DEPENDS= valac:lang/vala
+
+USE_GITHUB= yes
+GH_ACCOUNT= tiliado
+
+USES= gnome pkgconfig shebangfix waf
+USE_GNOME= glib20 gtk30
+USE_XORG= x11
+SHEBANG_LANG= python3
+SHEBANG_FILES= testgen.py
+# --noopt is required to prevent a crash in ipcserver.c, as
+# the argument of diorite_ipc_server_process_connection_co() gets
+# optimized out in diorite_ipc_server_process_connection().
+CONFIGURE_ARGS= --noopt --platform=LINUX
+MAKE_ARGS= --no-ldconfig
+USE_LDCONFIG= yes
+
+.ifdef(WITH_DEBUG)
+CONFIGURE_ARGS+=--debug
+.else
+CONFIGURE_ARGS+=--no-debug
+.endif
+
+pre-configure:
+ @${REINPLACE_CMD} -e '/pkgconfig/ s,$${LIBDIR},${PREFIX}/libdata,' \
+ ${WRKSRC}/wscript
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/*.so
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/diorite/distinfo b/x11-toolkits/diorite/distinfo
new file mode 100644
index 000000000000..611f7fe7c77a
--- /dev/null
+++ b/x11-toolkits/diorite/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1483465885
+SHA256 (tiliado-diorite-0.2.1_GH0.tar.gz) = 188335b58e7fea03e81c89d6f2bb1694063bac34483de05ee1e600e1cf696dd0
+SIZE (tiliado-diorite-0.2.1_GH0.tar.gz) = 430369
diff --git a/x11-toolkits/diorite/files/patch-src_gtk_application.vala b/x11-toolkits/diorite/files/patch-src_gtk_application.vala
new file mode 100644
index 000000000000..e74e808d4967
--- /dev/null
+++ b/x11-toolkits/diorite/files/patch-src_gtk_application.vala
@@ -0,0 +1,20 @@
+--- src/gtk/application.vala.orig 2016-10-30 08:24:08 UTC
++++ src/gtk/application.vala
+@@ -26,7 +26,7 @@ private const string G_LOG_DOMAIN="Diori
+ namespace Diorite
+ {
+
+-#if LINUX
++#if __FALSE__
+ [CCode (cheader_filename = "sys/prctl.h", cname = "prctl")]
+ extern int prctl (int option, string arg2, ulong arg3, ulong arg4, ulong arg5);
+ #endif
+@@ -67,7 +67,7 @@ public abstract class Application : Gtk.
+ this.desktop_name = desktop_name;
+ this.app_id = app_id;
+ actions = new ActionsRegistry(this);
+- #if LINUX
++ #if __FALSE__
+ prctl(15, app_id, 0, 0, 0);
+ #endif
+ GLib.Environment.set_prgname(app_id);
diff --git a/x11-toolkits/diorite/pkg-descr b/x11-toolkits/diorite/pkg-descr
new file mode 100644
index 000000000000..30eed82e9453
--- /dev/null
+++ b/x11-toolkits/diorite/pkg-descr
@@ -0,0 +1,5 @@
+Diorite is a a grey to dark-grey intermediate intrusive igneous rock.
+Diorite library is a utility and widget library for Nuvola Player
+project based on GLib, GIO and GTK+ 3.
+
+WWW: https://tiliado.eu/diorite
diff --git a/x11-toolkits/diorite/pkg-plist b/x11-toolkits/diorite/pkg-plist
new file mode 100644
index 000000000000..d18ac6779b30
--- /dev/null
+++ b/x11-toolkits/diorite/pkg-plist
@@ -0,0 +1,11 @@
+bin/diorite-testgen-0.2
+include/diorite-1.0/dioriteglib-0.2.h
+include/diorite-1.0/dioritegtk-0.2.h
+lib/libdioriteglib-0.2.so
+lib/libdioritegtk-0.2.so
+libdata/pkgconfig/dioriteglib-0.2.pc
+libdata/pkgconfig/dioritegtk-0.2.pc
+share/vala/vapi/dioriteglib-0.2.deps
+share/vala/vapi/dioriteglib-0.2.vapi
+share/vala/vapi/dioritegtk-0.2.deps
+share/vala/vapi/dioritegtk-0.2.vapi