aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2012-06-08 08:46:17 +0000
committerMax Khon <fjoe@FreeBSD.org>2012-06-08 08:46:17 +0000
commitc43588496e087b8bddc2a45bff4e6555ab288b4f (patch)
tree62a2064195a54e9d16529a338600962f4440fe38 /x11-toolkits
parent17f176e1239813fa5b8ec66610ab94e62c0e8d74 (diff)
downloadports-c43588496e087b8bddc2a45bff4e6555ab288b4f.tar.gz
ports-c43588496e087b8bddc2a45bff4e6555ab288b4f.zip
- Add libinotify support.
- Bump PORTREVISION. Prodded by: Rainer Hurling
Notes
Notes: svn path=/head/; revision=298736
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/wxgtk29/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/x11-toolkits/wxgtk29/Makefile b/x11-toolkits/wxgtk29/Makefile
index a101fc6abaa5..d0d3a47b2a9a 100644
--- a/x11-toolkits/wxgtk29/Makefile
+++ b/x11-toolkits/wxgtk29/Makefile
@@ -19,7 +19,8 @@ COMMENT?= The wxWidgets GUI toolkit with GTK+ bindings
LIB_DEPENDS+= png15:${PORTSDIR}/graphics/png\
jpeg.11:${PORTSDIR}/graphics/jpeg\
tiff.4:${PORTSDIR}/graphics/tiff\
- expat.6:${PORTSDIR}/textproc/expat2
+ expat.6:${PORTSDIR}/textproc/expat2\
+ inotify.0:${PORTSDIR}/devel/libinotify
USE_BZIP2= yes
USE_XORG= x11 sm xxf86vm xinerama
@@ -40,7 +41,7 @@ CONFIGURE_ARGS= --with-libpng=sys\
--enable-mediactrl\
--disable-backtrace\
--enable-graphics_ctx
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"\
+CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS} -linotify"\
PTHREAD_LIBS="${PTHREAD_LIBS}"\
X11BASE="${LOCALBASE}"
CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}