aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-03-04 13:56:59 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-03-04 13:56:59 +0000
commite2ac5825bab836691cda42cbb703c94886e1565d (patch)
tree69ae058ee16d79e0b8fa1e59c532681da7d792aa /x11-toolkits
parenta4ce7ef0bff551234bc7feff856fca1e896532f5 (diff)
downloadports-e2ac5825bab836691cda42cbb703c94886e1565d.tar.gz
ports-e2ac5825bab836691cda42cbb703c94886e1565d.zip
- Unbreak for 8/9
PR: 154592 Submitted by: Tommy Scheunemann <net@arrishq.net>
Notes
Notes: svn path=/head/; revision=270283
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/efltk/Makefile4
-rw-r--r--x11-toolkits/efltk/distinfo1
-rw-r--r--x11-toolkits/efltk/files/patch-src-filename_list.cpp11
3 files changed, 13 insertions, 3 deletions
diff --git a/x11-toolkits/efltk/Makefile b/x11-toolkits/efltk/Makefile
index 52634274a964..56f4769c918e 100644
--- a/x11-toolkits/efltk/Makefile
+++ b/x11-toolkits/efltk/Makefile
@@ -40,8 +40,8 @@ USE_XORG= x11 xext
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 800501
-BROKEN= does not build
+.if ${OSVERSION} < 800069
+BROKEN= does not build
.endif
.include <bsd.port.post.mk>
diff --git a/x11-toolkits/efltk/distinfo b/x11-toolkits/efltk/distinfo
index 7e82fa1fbe80..44b2a68d5b28 100644
--- a/x11-toolkits/efltk/distinfo
+++ b/x11-toolkits/efltk/distinfo
@@ -1,3 +1,2 @@
-MD5 (efltk-2.0.8.tar.gz) = 0596f27273cfb8169856009bfb611a1d
SHA256 (efltk-2.0.8.tar.gz) = 900dff72052af24e68f989346df363b0f1d211795bd168b8f56d436010dd7ee6
SIZE (efltk-2.0.8.tar.gz) = 1579590
diff --git a/x11-toolkits/efltk/files/patch-src-filename_list.cpp b/x11-toolkits/efltk/files/patch-src-filename_list.cpp
new file mode 100644
index 000000000000..c7452a030a6f
--- /dev/null
+++ b/x11-toolkits/efltk/files/patch-src-filename_list.cpp
@@ -0,0 +1,11 @@
+--- src/core/filename_list.cpp 2010-11-12 00:31:17.000000000 +0100
++++ src/core/filename_list.cpp 2009-04-22 13:51:38.000000000 +0200
+@@ -59,7 +59,7 @@
+ // The vast majority of Unix systems want the sort function to have this
+ // prototype, most likely so that it can be passed to qsort without any
+ // changes:
+- return scandir(dir, list, 0, (int(*)(const void*,const void*))sort);
++ return scandir(dir, list, 0, (int(*)(const dirent **, const dirent **))sort);
+ #else
+ // This version is when we define our own scandir (WIN32 and perhaps
+ // some Unix systems) and apparently on Irix: