aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
authorDavid Naylor <dbn@FreeBSD.org>2014-04-24 20:04:48 +0000
committerDavid Naylor <dbn@FreeBSD.org>2014-04-24 20:04:48 +0000
commite7fbb4600d4cb4d895e7b4f92b70a08d8cce889a (patch)
treeecf95aafcba2a57544c22b197fc351fd873c5e40 /x11-toolkits
parenteb65cad0ab1a1bf072283f59528da6036846624f (diff)
downloadports-e7fbb4600d4cb4d895e7b4f92b70a08d8cce889a.tar.gz
ports-e7fbb4600d4cb4d895e7b4f92b70a08d8cce889a.zip
Update x11-toolkits/py-kivy to 1.8.0.
Changes: * Kivy now supports python 2 and 3 ChangeLog: - Python 3.3 support: It's finally here, using the same codebase! And we deliver also 3 portables for Windows, one that package Python 2.7 and another with Python 3.3! - New media player named GstPlayer, based on Gstreamer 1.0. This player is currently used as a implementation for Audio and Video core provider. This allow us to not only use the latest Gstreamer and all the improvements done by them, but also have a common player for both Python 2.7 and 3.3 on desktop platforms. - Scrollview has been slightly enhanced to support smoother scrolling utilizing Matrix transformation by default. It also now supports scrolling through bars or content or both. - Widgets now can be disabled simply by using `disabled` property. - Textinput now has support for selection handles. - New Widgets! - ActionBar: Mimics Android?s own ActionBar appearance and mechanisms - Behaviors: ButtonBehavior, ToggleButtonBehavior, DragBehavior, just subclass a behavior to an existing widgets, and you get the behavior! (eg. class ImageButton(ButtonBehavior, Image)) - PageLayout: A simple multi-page layout allowing flipping through pages using borders - SandBox (experimental): Runs itself and its children in an exception-catching sandbox
Notes
Notes: svn path=/head/; revision=352060
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/py-kivy/Makefile13
-rw-r--r--x11-toolkits/py-kivy/distinfo4
-rw-r--r--x11-toolkits/py-kivy/files/patch-kivy__core__window__sdl.pyx20
-rw-r--r--x11-toolkits/py-kivy/files/patch-setup.py59
-rw-r--r--x11-toolkits/py-kivy/pkg-plist161
5 files changed, 210 insertions, 47 deletions
diff --git a/x11-toolkits/py-kivy/Makefile b/x11-toolkits/py-kivy/Makefile
index 9a7f4ce2c721..572f8a8281f5 100644
--- a/x11-toolkits/py-kivy/Makefile
+++ b/x11-toolkits/py-kivy/Makefile
@@ -2,10 +2,9 @@
# $FreeBSD$
PORTNAME= kivy
-PORTVERSION= 1.7.2
-PORTREVISION= 2
+PORTVERSION= 1.8.0
CATEGORIES= x11-toolkits python
-MASTER_SITES= LOCAL/dbn/${PORTNAME}
+MASTER_SITES= GH LOCAL/dbn/${PORTNAME}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= dbn@FreeBSD.org
@@ -19,7 +18,7 @@ MAKE_ENV= KIVY_NO_CONFIG=yes KIVY_NO_FILELOG=yes PYTHONPATH=${WRKSRC}
MAKE_JOBS_UNSAFE= yes # does not (really) use make
USE_GITHUB= yes
GH_ACCOUNT= ${PORTNAME}
-GH_COMMIT= f4f6246
+GH_COMMIT= d602d4b
USES= shebangfix
USE_GL= gl
USE_PYDISTUTILS= yes
@@ -27,7 +26,7 @@ PYDISTUTILS_AUTOPLIST= yes
PYDISTUTILS_BUILD_TARGET= build_ext
PYDISTUTILS_BUILDARGS= --inplace
PYDISTUTILS_EGGINFO= Kivy-${PORTVERSION}-py${PYTHON_VER}.egg-info
-USE_PYTHON= 2
+USE_PYTHON= 2.7+
SHEBANG_FILES= kivy/lib/osc/OSC.py
OPTIONS_DEFINE= DOCS PDF TEST
@@ -137,9 +136,9 @@ do-build-docs:
-d ${WRKSRC}/doc/build/doctrees \
-D latex_paper=letter doc/sources ${WRKSRC}/doc/build/latex-letter)
${SETENV} ${MAKE_ENV} ${MAKE_CMD} -C ${WRKSRC}/doc/build/latex-a4 \
- all-pdf > /dev/null
+ all-pdf < /dev/null > /dev/null
${SETENV} ${MAKE_ENV} ${MAKE_CMD} -C ${WRKSRC}/doc/build/latex-letter \
- all-pdf > /dev/null
+ all-pdf < /dev/null > /dev/null
.endif
${REINPLACE_CMD} -i '' -e 's/#\(import pygame\.joystick\)/\1/' \
${WRKSRC}/kivy/input/providers/androidjoystick.py
diff --git a/x11-toolkits/py-kivy/distinfo b/x11-toolkits/py-kivy/distinfo
index 082998c11900..06b2a92edd3a 100644
--- a/x11-toolkits/py-kivy/distinfo
+++ b/x11-toolkits/py-kivy/distinfo
@@ -1,2 +1,2 @@
-SHA256 (kivy-1.7.2.tar.gz) = 14cf92a2000fbdee948076c6883e4059640b2e4b9e683c41c60bab216fb30690
-SIZE (kivy-1.7.2.tar.gz) = 13967455
+SHA256 (kivy-1.8.0.tar.gz) = 0043c5d921ec444ba0d2f3a00a1a97e607dc2b4708db951c9eace40645cbfb60
+SIZE (kivy-1.8.0.tar.gz) = 14702743
diff --git a/x11-toolkits/py-kivy/files/patch-kivy__core__window__sdl.pyx b/x11-toolkits/py-kivy/files/patch-kivy__core__window__sdl.pyx
new file mode 100644
index 000000000000..b0a8dfdcbea7
--- /dev/null
+++ b/x11-toolkits/py-kivy/files/patch-kivy__core__window__sdl.pyx
@@ -0,0 +1,20 @@
+--- kivy/core/window/sdl.pyx
++++ kivy/core/window/sdl.pyx
+@@ -35,7 +35,7 @@ cdef extern from "SDL.h":
+ unsigned int scancode
+ unsigned int sym
+ unsigned short mod
+- unsigned int unicode
++ unsigned int unused
+
+ ctypedef struct SDL_KeyboardEvent:
+ unsigned char state
+@@ -282,7 +282,7 @@ def poll():
+ action = 'keydown' if event.type == SDL_KEYDOWN else 'keyup'
+ mod = event.key.keysym.mod
+ scancode = event.key.keysym.scancode
+- unicode = event.key.keysym.unicode
++ unicode = event.key.keysym.unused
+ key = event.key.keysym.sym
+ return (action, mod, key, scancode, unicode)
+ elif event.type == SDL_TEXTINPUT:
diff --git a/x11-toolkits/py-kivy/files/patch-setup.py b/x11-toolkits/py-kivy/files/patch-setup.py
index 71729299da14..fbf44e8f1a00 100644
--- a/x11-toolkits/py-kivy/files/patch-setup.py
+++ b/x11-toolkits/py-kivy/files/patch-setup.py
@@ -1,46 +1,50 @@
---- setup.py.orig 2013-05-28 15:08:56.000000000 +0200
-+++ setup.py 2013-11-18 20:41:50.000000000 +0200
-@@ -6,9 +6,10 @@
- import sys
- from copy import deepcopy
- from os.path import join, dirname, sep, exists
--from os import walk, environ
-+from os import walk, environ, path
+--- setup.py
++++ setup.py
+@@ -12,6 +12,7 @@ from os import walk, environ
from distutils.core import setup
from distutils.extension import Extension
+ from collections import OrderedDict
+from subprocess import check_output
+ if sys.version > '3':
+ PY3 = True
+@@ -36,7 +37,6 @@ def pkgconfig(*packages, **kw):
+ kw.setdefault(flag, []).append(token[2:].decode('utf-8'))
+ return kw
+
+-
# -----------------------------------------------------------------------------
# Determine on which platform we are
-@@ -124,7 +125,7 @@
+
+@@ -178,7 +178,7 @@ elif platform == 'win32':
c_options['use_glew'] = True
else:
# searching GLES headers
- default_header_dirs = ['/usr/include', '/usr/local/include']
-+ default_header_dirs = ['/usr/include', path.join(environ.get('LOCALBASE', '/usr/local'), 'include')]
++ default_header_dirs = ['/usr/include', join(environ.get('LOCALBASE', '/usr/local'), 'include')]
found = False
for hdir in default_header_dirs:
filename = join(hdir, 'GLES2', 'gl2.h')
-@@ -201,6 +202,9 @@
- sysroot = '/System/Library/Frameworks/ApplicationServices.framework/Frameworks'
+@@ -283,6 +283,9 @@ def determine_base_flags():
+ 'ApplicationServices.framework/Frameworks')
flags['extra_compile_args'] += ['-F%s' % sysroot]
flags['extra_link_args'] += ['-F%s' % sysroot]
+ elif platform.startswith('freebsd'):
-+ flags['include_dirs'] += [path.join(environ.get('LOCALBASE', '/usr/local'), 'include')]
-+ flags['extra_link_args'] += ['-L', path.join(environ.get('LOCALBASE', '/usr/local'), 'lib')]
++ flags['include_dirs'] += [join(environ.get('LOCALBASE', '/usr/local'), 'include')]
++ flags['extra_link_args'] += ['-L', join(environ.get('LOCALBASE', '/usr/local'), 'lib')]
return flags
- def determine_gl_flags():
-@@ -214,8 +218,6 @@
- flags['extra_link_args'] = ['-framework', 'OpenGL', '-arch', 'x86_64']
- flags['extra_compile_args'] = ['-arch', 'x86_64']
+
+@@ -297,8 +300,6 @@ def determine_gl_flags():
+ flags['extra_link_args'] = ['-framework', 'OpenGL', '-arch', osx_arch]
+ flags['extra_compile_args'] = ['-arch', osx_arch]
elif platform.startswith('freebsd'):
- flags['include_dirs'] = ['/usr/local/include']
- flags['extra_link_args'] = ['-L', '/usr/local/lib']
flags['libraries'] = ['GL']
elif platform.startswith('openbsd'):
flags['include_dirs'] = ['/usr/X11R6/include']
-@@ -283,6 +285,11 @@
+@@ -367,6 +368,11 @@ def determine_sdl():
elif platform == 'darwin':
flags['extra_link_args'] += [
'-framework', 'ApplicationServices']
@@ -51,19 +55,4 @@
+ flags['libraries'] = ["SDL2_ttf", "SDL2_mixer"]
return flags
- def determine_graphics_pxd():
-@@ -491,13 +498,7 @@
- 'data/glsl/*.fs',
- 'tools/highlight/*.vim',
- 'tools/highlight/*.el',
-- 'tools/packaging/README.txt',
-- 'tools/packaging/win32/kivy.bat',
-- 'tools/packaging/win32/kivyenv.sh',
-- 'tools/packaging/win32/README.txt',
-- 'tools/packaging/osx/Info.plist',
-- 'tools/packaging/osx/InfoPlist.strings',
-- 'tools/packaging/osx/kivy.sh']},
-+ 'tools/packaging/README.txt']},
- data_files=examples.items(),
- classifiers=[
- 'Development Status :: 5 - Production/Stable',
+
diff --git a/x11-toolkits/py-kivy/pkg-plist b/x11-toolkits/py-kivy/pkg-plist
index d530c558aa9a..0b5b6a030421 100644
--- a/x11-toolkits/py-kivy/pkg-plist
+++ b/x11-toolkits/py-kivy/pkg-plist
@@ -4,6 +4,7 @@
%%DOCS%%%%DOCSDIR%%/_images/Events.png
%%DOCS%%%%DOCSDIR%%/_images/Kivy_App_Life_Cycle.png
%%DOCS%%%%DOCSDIR%%/_images/accordion.jpg
+%%DOCS%%%%DOCSDIR%%/_images/actionbar.png
%%DOCS%%%%DOCSDIR%%/_images/anchorlayout.gif
%%DOCS%%%%DOCSDIR%%/_images/anchorlayout1.gif
%%DOCS%%%%DOCSDIR%%/_images/anim_in_back.png
@@ -79,7 +80,7 @@
%%DOCS%%%%DOCSDIR%%/_images/property_events_binding.png
%%DOCS%%%%DOCSDIR%%/_images/quickstart.png
%%DOCS%%%%DOCSDIR%%/_images/rstdocument.png
-%%DOCS%%%%DOCSDIR%%/_images/settings_kivy.jpg
+%%DOCS%%%%DOCSDIR%%/_images/settingswithspinner_kivy.jpg
%%DOCS%%%%DOCSDIR%%/_images/size_hint[B].jpg
%%DOCS%%%%DOCSDIR%%/_images/size_hint[b_].jpg
%%DOCS%%%%DOCSDIR%%/_images/size_hint[bb].jpg
@@ -107,6 +108,119 @@
%%DOCS%%%%DOCSDIR%%/_images/win-step8.png
%%DOCS%%%%DOCSDIR%%/_images/win-step9.png
%%DOCS%%%%DOCSDIR%%/_images/windows.png
+%%DOCS%%%%DOCSDIR%%/_modules/index.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/adapters/adapter.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/adapters/dictadapter.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/adapters/listadapter.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/adapters/models.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/adapters/simplelistadapter.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/animation.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/app.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/atlas.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/base.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/cache.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/clock.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/compat.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/config.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/context.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/core/audio.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/core/camera.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/core/image.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/core/spelling.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/core/text.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/core/text/markup.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/core/video.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/core/window.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/effects/dampedscroll.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/effects/kinetic.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/effects/opacityscroll.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/effects/scroll.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/event.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/ext.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/factory.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/garden.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/geometry.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/gesture.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/graphics.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/input.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/input/factory.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/input/motionevent.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/input/postproc/dejitter.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/input/postproc/doubletap.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/input/postproc/ignorelist.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/input/postproc/retaintouch.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/input/postproc/tripletap.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/input/provider.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/input/providers/tuio.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/input/providers/wm_pen.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/input/providers/wm_touch.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/input/recorder.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/input/shape.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/interactive.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/lang.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/loader.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/logger.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/metrics.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/modules/inspector.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/network/urlrequest.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/parser.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/resources.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/storage.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/storage/dictstore.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/storage/jsonstore.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/storage/redisstore.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/support.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/uix/abstractview.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/uix/accordion.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/uix/actionbar.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/uix/anchorlayout.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/uix/behaviors.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/uix/boxlayout.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/uix/bubble.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/uix/button.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/uix/camera.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/uix/carousel.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/uix/checkbox.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/uix/codeinput.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/uix/colorpicker.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/uix/dropdown.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/uix/filechooser.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/uix/floatlayout.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/uix/gridlayout.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/uix/image.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/uix/label.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/uix/layout.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/uix/listview.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/uix/modalview.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/uix/pagelayout.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/uix/popup.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/uix/progressbar.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/uix/relativelayout.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/uix/rst.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/uix/sandbox.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/uix/scatter.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/uix/scatterlayout.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/uix/screenmanager.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/uix/scrollview.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/uix/settings.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/uix/slider.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/uix/spinner.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/uix/splitter.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/uix/stacklayout.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/uix/stencilview.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/uix/switch.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/uix/tabbedpanel.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/uix/textinput.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/uix/togglebutton.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/uix/treeview.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/uix/video.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/uix/videoplayer.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/uix/vkeyboard.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/uix/widget.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/utils.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/vector.html
+%%DOCS%%%%DOCSDIR%%/_modules/kivy/weakmethod.html
%%DOCS%%%%DOCSDIR%%/_sources/api-index.txt
%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.adapters.adapter.txt
%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.adapters.args_converters.txt
@@ -121,7 +235,9 @@
%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.base.txt
%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.cache.txt
%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.clock.txt
+%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.compat.txt
%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.config.txt
+%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.context.txt
%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.core.audio.txt
%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.core.camera.txt
%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.core.clipboard.txt
@@ -142,6 +258,7 @@
%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.ext.txt
%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.factory.txt
%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.garden.txt
+%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.geometry.txt
%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.gesture.txt
%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.graphics.compiler.txt
%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.graphics.context.txt
@@ -168,6 +285,7 @@
%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.input.provider.txt
%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.input.providers.androidjoystick.txt
%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.input.providers.hidinput.txt
+%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.input.providers.leapfinger.txt
%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.input.providers.linuxwacom.txt
%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.input.providers.mactouch.txt
%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.input.providers.mouse.txt
@@ -183,7 +301,7 @@
%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.input.txt
%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.interactive.txt
%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.lang.txt
-%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.lib.debug.txt
+%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.lib.gstplayer.txt
%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.lib.txt
%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.loader.txt
%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.logger.txt
@@ -195,16 +313,23 @@
%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.modules.screen.txt
%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.modules.touchring.txt
%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.modules.txt
+%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.modules.webdebugger.txt
%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.network.txt
%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.network.urlrequest.txt
%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.parser.txt
%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.properties.txt
%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.resources.txt
+%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.storage.dictstore.txt
+%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.storage.jsonstore.txt
+%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.storage.redisstore.txt
+%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.storage.txt
%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.support.txt
%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.txt
%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.uix.abstractview.txt
%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.uix.accordion.txt
+%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.uix.actionbar.txt
%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.uix.anchorlayout.txt
+%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.uix.behaviors.txt
%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.uix.boxlayout.txt
%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.uix.bubble.txt
%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.uix.button.txt
@@ -222,10 +347,12 @@
%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.uix.layout.txt
%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.uix.listview.txt
%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.uix.modalview.txt
+%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.uix.pagelayout.txt
%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.uix.popup.txt
%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.uix.progressbar.txt
%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.uix.relativelayout.txt
%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.uix.rst.txt
+%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.uix.sandbox.txt
%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.uix.scatter.txt
%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.uix.scatterlayout.txt
%%DOCS%%%%DOCSDIR%%/_sources/api-kivy.uix.screenmanager.txt
@@ -292,6 +419,7 @@
%%DOCS%%%%DOCSDIR%%/_sources/installation/installation-macosx.txt
%%DOCS%%%%DOCSDIR%%/_sources/installation/installation-windows.txt
%%DOCS%%%%DOCSDIR%%/_sources/installation/installation.txt
+%%DOCS%%%%DOCSDIR%%/_sources/installation/troubleshooting-macosx.txt
%%DOCS%%%%DOCSDIR%%/_sources/philosophy.txt
%%DOCS%%%%DOCSDIR%%/_sources/tutorials-index.txt
%%DOCS%%%%DOCSDIR%%/_sources/tutorials/firstwidget.txt
@@ -344,7 +472,9 @@
%%DOCS%%%%DOCSDIR%%/api-kivy.base.html
%%DOCS%%%%DOCSDIR%%/api-kivy.cache.html
%%DOCS%%%%DOCSDIR%%/api-kivy.clock.html
+%%DOCS%%%%DOCSDIR%%/api-kivy.compat.html
%%DOCS%%%%DOCSDIR%%/api-kivy.config.html
+%%DOCS%%%%DOCSDIR%%/api-kivy.context.html
%%DOCS%%%%DOCSDIR%%/api-kivy.core.audio.html
%%DOCS%%%%DOCSDIR%%/api-kivy.core.camera.html
%%DOCS%%%%DOCSDIR%%/api-kivy.core.clipboard.html
@@ -365,6 +495,7 @@
%%DOCS%%%%DOCSDIR%%/api-kivy.ext.html
%%DOCS%%%%DOCSDIR%%/api-kivy.factory.html
%%DOCS%%%%DOCSDIR%%/api-kivy.garden.html
+%%DOCS%%%%DOCSDIR%%/api-kivy.geometry.html
%%DOCS%%%%DOCSDIR%%/api-kivy.gesture.html
%%DOCS%%%%DOCSDIR%%/api-kivy.graphics.compiler.html
%%DOCS%%%%DOCSDIR%%/api-kivy.graphics.context.html
@@ -394,6 +525,7 @@
%%DOCS%%%%DOCSDIR%%/api-kivy.input.providers.androidjoystick.html
%%DOCS%%%%DOCSDIR%%/api-kivy.input.providers.hidinput.html
%%DOCS%%%%DOCSDIR%%/api-kivy.input.providers.html
+%%DOCS%%%%DOCSDIR%%/api-kivy.input.providers.leapfinger.html
%%DOCS%%%%DOCSDIR%%/api-kivy.input.providers.linuxwacom.html
%%DOCS%%%%DOCSDIR%%/api-kivy.input.providers.mactouch.html
%%DOCS%%%%DOCSDIR%%/api-kivy.input.providers.mouse.html
@@ -407,7 +539,7 @@
%%DOCS%%%%DOCSDIR%%/api-kivy.input.shape.html
%%DOCS%%%%DOCSDIR%%/api-kivy.interactive.html
%%DOCS%%%%DOCSDIR%%/api-kivy.lang.html
-%%DOCS%%%%DOCSDIR%%/api-kivy.lib.debug.html
+%%DOCS%%%%DOCSDIR%%/api-kivy.lib.gstplayer.html
%%DOCS%%%%DOCSDIR%%/api-kivy.lib.html
%%DOCS%%%%DOCSDIR%%/api-kivy.loader.html
%%DOCS%%%%DOCSDIR%%/api-kivy.logger.html
@@ -419,15 +551,22 @@
%%DOCS%%%%DOCSDIR%%/api-kivy.modules.recorder.html
%%DOCS%%%%DOCSDIR%%/api-kivy.modules.screen.html
%%DOCS%%%%DOCSDIR%%/api-kivy.modules.touchring.html
+%%DOCS%%%%DOCSDIR%%/api-kivy.modules.webdebugger.html
%%DOCS%%%%DOCSDIR%%/api-kivy.network.html
%%DOCS%%%%DOCSDIR%%/api-kivy.network.urlrequest.html
%%DOCS%%%%DOCSDIR%%/api-kivy.parser.html
%%DOCS%%%%DOCSDIR%%/api-kivy.properties.html
%%DOCS%%%%DOCSDIR%%/api-kivy.resources.html
+%%DOCS%%%%DOCSDIR%%/api-kivy.storage.dictstore.html
+%%DOCS%%%%DOCSDIR%%/api-kivy.storage.html
+%%DOCS%%%%DOCSDIR%%/api-kivy.storage.jsonstore.html
+%%DOCS%%%%DOCSDIR%%/api-kivy.storage.redisstore.html
%%DOCS%%%%DOCSDIR%%/api-kivy.support.html
%%DOCS%%%%DOCSDIR%%/api-kivy.uix.abstractview.html
%%DOCS%%%%DOCSDIR%%/api-kivy.uix.accordion.html
+%%DOCS%%%%DOCSDIR%%/api-kivy.uix.actionbar.html
%%DOCS%%%%DOCSDIR%%/api-kivy.uix.anchorlayout.html
+%%DOCS%%%%DOCSDIR%%/api-kivy.uix.behaviors.html
%%DOCS%%%%DOCSDIR%%/api-kivy.uix.boxlayout.html
%%DOCS%%%%DOCSDIR%%/api-kivy.uix.bubble.html
%%DOCS%%%%DOCSDIR%%/api-kivy.uix.button.html
@@ -446,10 +585,12 @@
%%DOCS%%%%DOCSDIR%%/api-kivy.uix.layout.html
%%DOCS%%%%DOCSDIR%%/api-kivy.uix.listview.html
%%DOCS%%%%DOCSDIR%%/api-kivy.uix.modalview.html
+%%DOCS%%%%DOCSDIR%%/api-kivy.uix.pagelayout.html
%%DOCS%%%%DOCSDIR%%/api-kivy.uix.popup.html
%%DOCS%%%%DOCSDIR%%/api-kivy.uix.progressbar.html
%%DOCS%%%%DOCSDIR%%/api-kivy.uix.relativelayout.html
%%DOCS%%%%DOCSDIR%%/api-kivy.uix.rst.html
+%%DOCS%%%%DOCSDIR%%/api-kivy.uix.sandbox.html
%%DOCS%%%%DOCSDIR%%/api-kivy.uix.scatter.html
%%DOCS%%%%DOCSDIR%%/api-kivy.uix.scatterlayout.html
%%DOCS%%%%DOCSDIR%%/api-kivy.uix.screenmanager.html
@@ -516,6 +657,7 @@
%%DOCS%%%%DOCSDIR%%/installation/installation-macosx.html
%%DOCS%%%%DOCSDIR%%/installation/installation-windows.html
%%DOCS%%%%DOCSDIR%%/installation/installation.html
+%%DOCS%%%%DOCSDIR%%/installation/troubleshooting-macosx.html
%%DOCS%%%%DOCSDIR%%/objects.inv
%%DOCS%%%%DOCSDIR%%/philosophy.html
%%DOCS%%%%DOCSDIR%%/py-modindex.html
@@ -535,5 +677,18 @@
%%DOCS%%@dirrm %%DOCSDIR%%/_sources/guide
%%DOCS%%@dirrm %%DOCSDIR%%/_sources/gettingstarted
%%DOCS%%@dirrm %%DOCSDIR%%/_sources
+%%DOCS%%@dirrm %%DOCSDIR%%/_modules/kivy/uix
+%%DOCS%%@dirrm %%DOCSDIR%%/_modules/kivy/storage
+%%DOCS%%@dirrm %%DOCSDIR%%/_modules/kivy/network
+%%DOCS%%@dirrm %%DOCSDIR%%/_modules/kivy/modules
+%%DOCS%%@dirrm %%DOCSDIR%%/_modules/kivy/input/providers
+%%DOCS%%@dirrm %%DOCSDIR%%/_modules/kivy/input/postproc
+%%DOCS%%@dirrm %%DOCSDIR%%/_modules/kivy/input
+%%DOCS%%@dirrm %%DOCSDIR%%/_modules/kivy/effects
+%%DOCS%%@dirrm %%DOCSDIR%%/_modules/kivy/core/text
+%%DOCS%%@dirrm %%DOCSDIR%%/_modules/kivy/core
+%%DOCS%%@dirrm %%DOCSDIR%%/_modules/kivy/adapters
+%%DOCS%%@dirrm %%DOCSDIR%%/_modules/kivy
+%%DOCS%%@dirrm %%DOCSDIR%%/_modules
%%DOCS%%@dirrm %%DOCSDIR%%/_images
%%DOCS%%@dirrm %%DOCSDIR%%