aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2016-12-02 11:29:19 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2016-12-02 11:29:19 +0000
commitf38d6cb92bbd96d100bae02b23ace94acea1cf8e (patch)
tree4a7d4f15f174993f2daa188caf85ddcea6b8a7f2 /x11-toolkits
parent3d8bb1a40a09ec3037ee92d70d3a3df08b1cdad0 (diff)
downloadports-f38d6cb92bbd96d100bae02b23ace94acea1cf8e.tar.gz
ports-f38d6cb92bbd96d100bae02b23ace94acea1cf8e.zip
Fix build of x11-toolkits/qt5-charts after r427356.
Unfortunately due to a wrong assumption, I missed the new port x11-toolkits/qt5-charts in r427356, so this port wrongly used QT_LIBDIR while not being part of QT_DIST (yet). While here, also add a patch to install the pkgconfig file to the proper location (another error, caused by not being QT_DIST-ed). Approved by: rakuco (mentor)
Notes
Notes: svn path=/head/; revision=427551
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/qt5-charts/Makefile1
-rw-r--r--x11-toolkits/qt5-charts/files/patch-src_charts_charts.pro14
-rw-r--r--x11-toolkits/qt5-charts/pkg-plist16
3 files changed, 23 insertions, 8 deletions
diff --git a/x11-toolkits/qt5-charts/Makefile b/x11-toolkits/qt5-charts/Makefile
index a8631b66cd1f..1082ed5f945f 100644
--- a/x11-toolkits/qt5-charts/Makefile
+++ b/x11-toolkits/qt5-charts/Makefile
@@ -3,6 +3,7 @@
PORTNAME= charts
DISTVERSIONPREFIX= release-
DISTVERSION= 2.1.0
+PORTREVISION= 1
CATEGORIES= x11-toolkits
PKGNAMEPREFIX= qt5-
diff --git a/x11-toolkits/qt5-charts/files/patch-src_charts_charts.pro b/x11-toolkits/qt5-charts/files/patch-src_charts_charts.pro
new file mode 100644
index 000000000000..fc5ccf1be5aa
--- /dev/null
+++ b/x11-toolkits/qt5-charts/files/patch-src_charts_charts.pro
@@ -0,0 +1,14 @@
+Fix the pkgconfig install path.
+
+--- src/charts/charts.pro.orig 2016-12-01 12:57:55 UTC
++++ src/charts/charts.pro
+@@ -17,6 +17,9 @@ load(qt_module)
+ QMAKE_TARGET_PRODUCT = "Qt Charts (Qt $$QT_VERSION)"
+ QMAKE_TARGET_DESCRIPTION = "Charts component for Qt."
+
++# Properly set up the pkgconfig install path -- relative to lib/
++QMAKE_PKGCONFIG_DESTDIR = ../libdata/pkgconfig
++
+ ############################# SOURCES ##########################################
+
+ SOURCES += \
diff --git a/x11-toolkits/qt5-charts/pkg-plist b/x11-toolkits/qt5-charts/pkg-plist
index 57c08cc4987c..a7ff93592491 100644
--- a/x11-toolkits/qt5-charts/pkg-plist
+++ b/x11-toolkits/qt5-charts/pkg-plist
@@ -225,14 +225,13 @@
%%QT_INCDIR%%/QtCharts/qxylegendmarker.h
%%QT_INCDIR%%/QtCharts/qxymodelmapper.h
%%QT_INCDIR%%/QtCharts/qxyseries.h
-%%QT_LIBDIR%%/cmake/Qt5Charts/Qt5ChartsConfig.cmake
-%%QT_LIBDIR%%/cmake/Qt5Charts/Qt5ChartsConfigVersion.cmake
-%%QT_LIBDIR%%/libQt5Charts.prl
-%%QT_LIBDIR%%/libQt5Charts.so
-%%QT_LIBDIR%%/libQt5Charts.so.2
-%%QT_LIBDIR%%/libQt5Charts.so.2.1
-%%QT_LIBDIR%%/libQt5Charts.so.2.1.0
-%%QT_LIBDIR%%/pkgconfig/Qt5Charts.pc
+lib/cmake/Qt5Charts/Qt5ChartsConfig.cmake
+lib/cmake/Qt5Charts/Qt5ChartsConfigVersion.cmake
+lib/libQt5Charts.prl
+lib/libQt5Charts.so
+lib/libQt5Charts.so.2
+lib/libQt5Charts.so.2.1
+lib/libQt5Charts.so.2.1.0
%%QT_MKSPECDIR%%/modules/qt_lib_charts.pri
%%QT_MKSPECDIR%%/modules/qt_lib_charts_private.pri
%%QT_QMLDIR%%/QtCharts/designer/ChartViewSpecifics.qml
@@ -288,3 +287,4 @@
%%QT_QMLDIR%%/QtCharts/libqtchartsqml2.so
%%QT_QMLDIR%%/QtCharts/plugins.qmltypes
%%QT_QMLDIR%%/QtCharts/qmldir
+libdata/pkgconfig/Qt5Charts.pc