aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/afterstep/Makefile
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1996-07-23 07:36:32 +0000
committerSatoshi Asami <asami@FreeBSD.org>1996-07-23 07:36:32 +0000
commit14a9fcd4190879bd6404adcc0083fd239c1a8f8d (patch)
treec707c2b46a1ce033a7b87806261baeebd5c9229d /x11-wm/afterstep/Makefile
parent0e6483b66918300558d538f0a38f1ebf2b7cf0da (diff)
downloadports-14a9fcd4190879bd6404adcc0083fd239c1a8f8d.tar.gz
ports-14a9fcd4190879bd6404adcc0083fd239c1a8f8d.zip
The afterstep window manager, replacing bowman. It's a NeXTstep wm
clone. Submitted by: James FitzGibbon <james@nexis.net>
Notes
Notes: svn path=/head/; revision=3419
Diffstat (limited to 'x11-wm/afterstep/Makefile')
-rw-r--r--x11-wm/afterstep/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/x11-wm/afterstep/Makefile b/x11-wm/afterstep/Makefile
new file mode 100644
index 000000000000..f3725e9aa751
--- /dev/null
+++ b/x11-wm/afterstep/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: afterstep
+# Version required: 0.98b16
+# Date created: 17 July 96
+# Whom: james@bdd.net
+#
+# $Id$
+#
+
+DISTNAME= as-b16
+PKGNAME= afterstep-0.98b16
+CATEGORIES+= x11
+MASTER_SITES= ftp://oak.sfasu.edu/pub/AfterStep/
+
+MAINTAINER= james@nexis.net
+
+LIB_DEPENDS= Xpm\\.4\\.:${PORTSDIR}/graphics/xpm
+RUN_DEPENDS= fvwm:${PORTSDIR}/x11/fvwm
+
+USE_X11= yes
+WRKSRC= ${WRKDIR}/AfterStep-0.98a16
+
+pre-build:
+ @cd ${WRKSRC}; sh MakeMakefiles
+
+post-install:
+ @mkdir -p ${PREFIX}/include/X11/pixmaps
+ @cp ${WRKSRC}/icons/*.xpm ${PREFIX}/include/X11/pixmaps
+ @cp ${WRKSRC}/icons/8bit/*.xpm ${PREFIX}/include/X11/pixmaps
+
+.include <bsd.port.mk>