aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/afterstep
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2014-08-03 14:27:11 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2014-08-03 14:27:11 +0000
commit3a0a4614ab5d9335a6d29a1685845d6d4717ebc7 (patch)
treeef7ee7965bcd3ef6aaed32284b91b3d7dd81bf6a /x11-wm/afterstep
parent22d7896c1731a371a072a9f3254f9f770ba01b97 (diff)
downloadports-3a0a4614ab5d9335a6d29a1685845d6d4717ebc7.tar.gz
ports-3a0a4614ab5d9335a6d29a1685845d6d4717ebc7.zip
- make HICOLOR_ICONS default
- rename patch files
Notes
Notes: svn path=/head/; revision=363905
Diffstat (limited to 'x11-wm/afterstep')
-rw-r--r--x11-wm/afterstep/Makefile17
-rw-r--r--x11-wm/afterstep/files/patch-alpha_header.h (renamed from x11-wm/afterstep/files/patch-afterstep__alpha_header.h)0
-rw-r--r--x11-wm/afterstep/files/patch-icons.c (renamed from x11-wm/afterstep/files/patch-afterstep__icons.c)0
3 files changed, 9 insertions, 8 deletions
diff --git a/x11-wm/afterstep/Makefile b/x11-wm/afterstep/Makefile
index 9bd18f22eb90..f463fe4a0f36 100644
--- a/x11-wm/afterstep/Makefile
+++ b/x11-wm/afterstep/Makefile
@@ -3,7 +3,7 @@
PORTNAME= afterstep
PORTVERSION= 1.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= x11-wm afterstep
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= dinoex
@@ -32,6 +32,7 @@ SRCDIRS= afterstep \
modules/Wharf/ASSound
OPTIONS_DEFINE= HICOLOR_ICONS
+OPTIONS_DEFAULT= HICOLOR_ICONS
HICOLOR_ICONS_DESC= Use hi-color icons
.include <bsd.port.options.mk>
@@ -42,20 +43,20 @@ post-patch:
${WRKSRC}/configure.h \
${WRKSRC}/sample.steprc
@ for i in ${SRCDIRS}; do \
- cd ${WRKSRC}/$$i; \
+ ( cd ${WRKSRC}/$$i; \
${MV} Imakefile Imakefile.orig; \
- ${SED} -e 's/#ifdef AlphaArchitecture/#if defined(AlphaArchitecture) \&\& !defined(FreeBSDArchitecture)/' < Imakefile.orig > Imakefile; \
+ ${SED} -e 's/#ifdef AlphaArchitecture/#if defined(AlphaArchitecture) \&\& !defined(FreeBSDArchitecture)/' < Imakefile.orig > Imakefile; ) \
done
pre-build:
- @ (cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${SH} MakeMakefiles)
+ (cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${SH} MakeMakefiles)
post-install:
- @ ${MKDIR} ${STAGEDIR}${PREFIX}/lib/X11/afterstep/backgrounds/
+ ${MKDIR} ${STAGEDIR}${PREFIX}/lib/X11/afterstep/backgrounds/
${INSTALL_DATA} ${WRKSRC}/backgrounds/* ${STAGEDIR}${PREFIX}/lib/X11/afterstep/backgrounds/
- @ ${MKDIR} ${STAGEDIR}${PREFIX}/lib/X11/afterstep/sounds/
+ ${MKDIR} ${STAGEDIR}${PREFIX}/lib/X11/afterstep/sounds/
${INSTALL_DATA} ${WRKSRC}/sounds/* ${STAGEDIR}${PREFIX}/lib/X11/afterstep/sounds/
- @ ${MKDIR} ${STAGEDIR}${PREFIX}/include/X11/pixmaps/
+ ${MKDIR} ${STAGEDIR}${PREFIX}/include/X11/pixmaps/
.if ${PORT_OPTIONS:MHICOLOR_ICONS}
${INSTALL_DATA} ${WRKSRC}/icons/*.xpm ${STAGEDIR}${PREFIX}/include/X11/pixmaps/
${INSTALL_DATA} ${FILESDIR}/monitor_bsd.xpm ${STAGEDIR}${PREFIX}/include/X11/pixmaps/
@@ -66,7 +67,7 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/icons/8bit/*.xpm ${STAGEDIR}${PREFIX}/include/X11/pixmaps/
${INSTALL_DATA} ${WRKSRC}/icons/eyecon.xpm ${STAGEDIR}${PREFIX}/include/X11/pixmaps/
.endif
- @ ${MKDIR} ${STAGEDIR}${PREFIX}/lib/X11/afterstep/doc/
+ ${MKDIR} ${STAGEDIR}${PREFIX}/lib/X11/afterstep/doc/
@for i in CHANGES CREDITS README README.8bit INSTALL FAQ module-interface.txt; do \
${INSTALL_DATA} ${WRKSRC}/$$i ${STAGEDIR}${PREFIX}/lib/X11/afterstep/doc/; \
done
diff --git a/x11-wm/afterstep/files/patch-afterstep__alpha_header.h b/x11-wm/afterstep/files/patch-alpha_header.h
index 8b4260bcd8c0..8b4260bcd8c0 100644
--- a/x11-wm/afterstep/files/patch-afterstep__alpha_header.h
+++ b/x11-wm/afterstep/files/patch-alpha_header.h
diff --git a/x11-wm/afterstep/files/patch-afterstep__icons.c b/x11-wm/afterstep/files/patch-icons.c
index 04bd11ae88a1..04bd11ae88a1 100644
--- a/x11-wm/afterstep/files/patch-afterstep__icons.c
+++ b/x11-wm/afterstep/files/patch-icons.c