aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/awesome2
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-12-12 18:58:57 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-12-12 18:58:57 +0000
commit20934e9167adc3cd3cb0e06222c9113a410de41c (patch)
tree5560dc9f2474832a613b7136dd70e9cdca9a9795 /x11-wm/awesome2
parent38515dc9d0bc190fe0840922055fbdf2a5a108a2 (diff)
downloadports-20934e9167adc3cd3cb0e06222c9113a410de41c.tar.gz
ports-20934e9167adc3cd3cb0e06222c9113a410de41c.zip
- Update to 2.0
PR: 118560 Submitted by: Nikos Ntarmos <ntarmos@ceid.upatras.gr> (maintainer)
Notes
Notes: svn path=/head/; revision=203385
Diffstat (limited to 'x11-wm/awesome2')
-rw-r--r--x11-wm/awesome2/Makefile32
-rw-r--r--x11-wm/awesome2/distinfo6
-rw-r--r--x11-wm/awesome2/files/extrapatch-lowerfloat29
-rw-r--r--x11-wm/awesome2/files/extrapatch-warp11
-rw-r--r--x11-wm/awesome2/files/patch-Makefile37
-rw-r--r--x11-wm/awesome2/files/patch-config.c11
-rw-r--r--x11-wm/awesome2/files/patch-config.mk22
-rw-r--r--x11-wm/awesome2/files/patch-statusbar.c11
-rw-r--r--x11-wm/awesome2/pkg-descr2
9 files changed, 64 insertions, 97 deletions
diff --git a/x11-wm/awesome2/Makefile b/x11-wm/awesome2/Makefile
index 2f86be2ccdaf..6a14744567b7 100644
--- a/x11-wm/awesome2/Makefile
+++ b/x11-wm/awesome2/Makefile
@@ -6,36 +6,28 @@
#
PORTNAME= awesome
-PORTVERSION= 1.3
-PORTREVISION= 1
+PORTVERSION= 2.0
CATEGORIES= x11-wm
MASTER_SITES= http://awesome.naquadah.org/download/
MAINTAINER= ntarmos@ceid.upatras.gr
-COMMENT= A tiling window manager initialy based on a dwm code rewriting
+COMMENT= A tiling window manager initially based on a dwm code rewriting
-LIB_DEPENDS= config.4:${PORTSDIR}/devel/libconfig
+BUILD_DEPENDS= asciidoc:${PORTSDIR}/textproc/asciidoc \
+ xmlto:${PORTSDIR}/textproc/xmlto
+LIB_DEPENDS= confuse.0:${PORTSDIR}/devel/libconfuse \
+ cairo.2:${PORTSDIR}/graphics/cairo \
+ freetype.9:${PORTSDIR}/print/freetype2
USE_XLIB= yes
-MAN1= awesome.1
-PLIST_FILES= bin/awesome
+MAN1= awesome.1 \
+ awesome-client.1
+PLIST_FILES= bin/awesome \
+ bin/awesome-client
PORTDOCS= AUTHORS LICENSE README
PORTEXAMPLES= awesomerc
-OPTIONS= LWRFLT "Support lowering of floating windows" on \
- WARP "Support mouse warping" on
-
-.include <bsd.port.pre.mk>
-
-.if defined(WITH_LWRFLT)
-EXTRA_PATCHES+= ${FILESDIR}/extrapatch-lowerfloat
-.endif
-
-.if defined(WITH_WARP)
-EXTRA_PATCHES+= ${FILESDIR}/extrapatch-warp
-.endif
-
post-install:
.if !defined(NOPORTDOCS)
@${ECHO_MSG} "installing additional documentation to ${DOCSDIR}"
@@ -50,4 +42,4 @@ post-install:
@${INSTALL_MAN} ${WRKSRC}/awesomerc ${EXAMPLESDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11-wm/awesome2/distinfo b/x11-wm/awesome2/distinfo
index 7cd015052c27..e71f60ad5a12 100644
--- a/x11-wm/awesome2/distinfo
+++ b/x11-wm/awesome2/distinfo
@@ -1,3 +1,3 @@
-MD5 (awesome-1.3.tar.gz) = c5625853e5f79ed7cde618b872928527
-SHA256 (awesome-1.3.tar.gz) = 72f8b6d9107e8c4d55eead8b13b71f4459b0d415cd67f2958c80ed32878f9635
-SIZE (awesome-1.3.tar.gz) = 40012
+MD5 (awesome-2.0.tar.gz) = b3e245bd9b8c05b759cc0acbec9f6a29
+SHA256 (awesome-2.0.tar.gz) = 933ce7f5f4339963a5f6229caf82c9f0fb8eb69e69293f72246737e13ffaa079
+SIZE (awesome-2.0.tar.gz) = 48600
diff --git a/x11-wm/awesome2/files/extrapatch-lowerfloat b/x11-wm/awesome2/files/extrapatch-lowerfloat
deleted file mode 100644
index cd23c3bce440..000000000000
--- a/x11-wm/awesome2/files/extrapatch-lowerfloat
+++ /dev/null
@@ -1,29 +0,0 @@
---- layout.c.orig 2007-09-26 12:08:27.000000000 +0300
-+++ layout.c 2007-09-26 17:41:42.000000000 +0300
-@@ -118,25 +118,7 @@
- drawstatusbar(disp, drawcontext, awesomeconf);
- if(!sel)
- return;
-- if(sel->isfloating || IS_ARRANGE(layout_floating))
-- XRaiseWindow(disp, sel->win);
-- if(!IS_ARRANGE(layout_floating))
-- {
-- wc.stack_mode = Below;
-- wc.sibling = awesomeconf->statusbar.window;
-- if(!sel->isfloating)
-- {
-- XConfigureWindow(disp, sel->win, CWSibling | CWStackMode, &wc);
-- wc.sibling = sel->win;
-- }
-- for(c = clients; c; c = c->next)
-- {
-- if(!IS_TILED(c, awesomeconf->screen, awesomeconf->tags, awesomeconf->ntags) || c == sel)
-- continue;
-- XConfigureWindow(disp, c->win, CWSibling | CWStackMode, &wc);
-- wc.sibling = c->win;
-- }
-- }
-+ XRaiseWindow(disp, sel->win);
- XSync(disp, False);
- while(XCheckMaskEvent(disp, EnterWindowMask, &ev));
- }
diff --git a/x11-wm/awesome2/files/extrapatch-warp b/x11-wm/awesome2/files/extrapatch-warp
deleted file mode 100644
index 76aa663e042e..000000000000
--- a/x11-wm/awesome2/files/extrapatch-warp
+++ /dev/null
@@ -1,11 +0,0 @@
---- layout.c.orig 2007-09-26 13:18:33.000000000 +0300
-+++ layout.c 2007-09-26 13:20:48.000000000 +0300
-@@ -114,6 +114,8 @@
- Client *c;
- XEvent ev;
- XWindowChanges wc;
-+ if(sel)
-+ XWarpPointer(disp, None, sel->win, 0, 0, 0, 0, sel->w / 2, sel->h / 2);
-
- drawstatusbar(disp, awesomeconf->screen, drawcontext, awesomeconf);
- if(!sel)
diff --git a/x11-wm/awesome2/files/patch-Makefile b/x11-wm/awesome2/files/patch-Makefile
new file mode 100644
index 000000000000..6e50397d077d
--- /dev/null
+++ b/x11-wm/awesome2/files/patch-Makefile
@@ -0,0 +1,37 @@
+--- Makefile.orig 2007-12-11 22:57:57.000000000 +0200
++++ Makefile 2007-12-11 22:58:58.000000000 +0200
+@@ -10,7 +10,7 @@
+ SRCCLIENT = awesome-client.c awesome-client-common.c util.c
+ OBJCLIENT = ${SRCCLIENT:.c=.o}
+
+-all: options awesome awesome-client
++all: options awesome awesome-client man
+
+ options:
+ @echo awesome build options:
+@@ -64,19 +64,19 @@
+
+ install: strip install-unstrip
+
+-install-unstrip: awesome awesome-client man
++install-unstrip: awesome awesome-client
+ @echo installing executable file to ${DESTDIR}${PREFIX}/bin
+ @install -d ${DESTDIR}${PREFIX}/bin
+ @install -m 755 awesome awesome-client ${DESTDIR}${PREFIX}/bin
+- @echo installing manual page to ${DESTDIR}${MANPREFIX}/man1
+- @install -d ${DESTDIR}${MANPREFIX}/man1
+- @install -m 644 ${DOCS:.txt=} ${DESTDIR}${MANPREFIX}/man1
++ @echo installing manual page to ${DESTDIR}${MANPREFIX}/man/man1
++ @install -d ${DESTDIR}${MANPREFIX}/man/man1
++ @install -m 644 ${DOCS:.txt=} ${DESTDIR}${MANPREFIX}/man/man1
+
+ uninstall:
+ @echo removing executable file from ${DESTDIR}${PREFIX}/bin
+ @rm ${DESTDIR}${PREFIX}/bin/awesome ${DESTDIR}${PREFIX}/bin/awesome-client
+- @echo removing manual page from ${DESTDIR}${MANPREFIX}/man1
+- @rm ${DESTDIR}${MANPREFIX}/man1/awesome.1 ${DESTDIR}${MANPREFIX}/man1/awesome-client.1
++ @echo removing manual page from ${DESTDIR}${MANPREFIX}/man/man1
++ @rm ${DESTDIR}${MANPREFIX}/man/man1/awesome.1 ${DESTDIR}${MANPREFIX}/man/man1/awesome-client.1
+
+ doc:
+ @echo generating documentation
diff --git a/x11-wm/awesome2/files/patch-config.c b/x11-wm/awesome2/files/patch-config.c
deleted file mode 100644
index 4e9fece82e4e..000000000000
--- a/x11-wm/awesome2/files/patch-config.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- config.c
-+++ config.c
-@@ -400,7 +400,7 @@ parse_config(Display * disp, int scr, DC * drawcontext, const char *confpatharg,
- awesomeconf->mwfact = f ? f : 0.6;
-
- /* resize_hints */
-- awesomeconf->resize_hints = config_lookup_float(&awesomelibconf, "awesome.resize_hints");
-+ awesomeconf->resize_hints = config_lookup_bool(&awesomelibconf, "awesome.resize_hints");
-
- /* colors */
- tmp = config_lookup_string(&awesomelibconf, "awesome.normal_border_color");
diff --git a/x11-wm/awesome2/files/patch-config.mk b/x11-wm/awesome2/files/patch-config.mk
index 26ccec6d6e7e..0e38337e4457 100644
--- a/x11-wm/awesome2/files/patch-config.mk
+++ b/x11-wm/awesome2/files/patch-config.mk
@@ -1,28 +1,28 @@
---- config.mk.orig 2007-09-26 11:41:29.000000000 +0300
-+++ config.mk 2007-09-26 11:42:35.000000000 +0300
-@@ -7,19 +7,19 @@
+--- config.mk.o 2007-11-18 06:20:55.000000000 +0200
++++ config.mk 2007-11-18 06:23:43.000000000 +0200
+@@ -8,20 +8,18 @@
LAYOUTS = layouts/tile.c layouts/floating.c layouts/max.c
# paths
-PREFIX = /usr/local
-MANPREFIX = ${PREFIX}/share/man
-+PREFIX?= /usr/local
-+MANPREFIX = ${PREFIX}/man
-X11INC = /usr/include/X11
-X11LIB = /usr/lib/X11
-+X11INC = ${X11BASE}/include
-+X11LIB = ${X11BASE}/lib
++X11INC = ${LOCALBASE}/include
++X11LIB = ${LOCALBASE}/lib
# includes and libs
- INCS = -I. -I/usr/include -I${X11INC} `pkg-config --cflags libconfig xft`
- LIBS = -L/usr/lib -lc -L${X11LIB} -lX11 `pkg-config --libs libconfig xft` -lXext -lXrandr -lXinerama
+ INCS = -I. -I/usr/include -I${X11INC} `pkg-config --cflags libconfuse xft cairo`
+ LIBS = -L/usr/lib -lc -L${X11LIB} -lX11 `pkg-config --libs libconfuse xft cairo` -lXext -lXrandr -lXinerama
# flags
--CFLAGS = -fgnu89-inline -std=gnu99 -ggdb3 -pipe -Wall -Wextra -W -Wchar-subscripts -Wundef -Wshadow -Wcast-align -Wwrite-strings -Wsign-compare -Wunused -Wuninitialized -Winit-self -Wpointer-arith -Wredundant-decls -Wno-format-zero-length -Wmissing-prototypes -Wmissing-format-attribute -Wmissing-noreturn -O3 ${INCS} -DVERSION=\"${VERSION}\"
+-CFLAGS = -fgnu89-inline -std=gnu99 -ggdb3 -pipe -Wall -Wextra -W -Wchar-subscripts -Wundef -Wshadow -Wcast-align -Wwrite-strings -Wsign-compare -Wunused -Wuninitialized -Winit-self -Wpointer-arith -Wredundant-decls -Wno-format-zero-length -Wmissing-prototypes -Wmissing-format-attribute -Wmissing-noreturn -O3 ${INCS} -DVERSION=\"${VERSION}\" -DRELEASE=\"${RELEASE}\"
-LDFLAGS = -ggdb3 ${LIBS}
-+CFLAGS+= -pipe -Wall -W -Wchar-subscripts -Wshadow -Wcast-align -Wwrite-strings -Wunused -Wuninitialized -Wpointer-arith -Wredundant-decls -Wmissing-prototypes ${INCS} -DVERSION=\"${VERSION}\"
+-CLIENTLDFLAGS = -ggdb3
++CFLAGS+= -pipe -Wall -W -Wchar-subscripts -Wshadow -Wcast-align -Wwrite-strings -Wunused -Wuninitialized -Wpointer-arith -Wredundant-decls -Wmissing-prototypes ${INCS} -DVERSION=\"${VERSION}\" -DRELEASE=\"${RELEASE}\"
+LDFLAGS+= ${LIBS}
++CLIENTLDFLAGS+= ${LIBS}
# compiler and linker
-CC = cc
diff --git a/x11-wm/awesome2/files/patch-statusbar.c b/x11-wm/awesome2/files/patch-statusbar.c
deleted file mode 100644
index 055d6d637bfe..000000000000
--- a/x11-wm/awesome2/files/patch-statusbar.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- statusbar.c
-+++ statusbar.c
-@@ -166,7 +166,7 @@ uicb_togglebar(Display *disp,
- const char *arg __attribute__ ((unused)))
- {
- if(awesomeconf->statusbar.position == BarOff)
-- awesomeconf->statusbar.position = (awesomeconf->statusbar.position == BarOff) ? BarTop : awesomeconf->statusbar_default_position;
-+ awesomeconf->statusbar.position = (awesomeconf->statusbar_default_position == BarOff) ? BarTop : awesomeconf->statusbar_default_position;
- else
- awesomeconf->statusbar.position = BarOff;
- updatebarpos(disp, awesomeconf->statusbar);
diff --git a/x11-wm/awesome2/pkg-descr b/x11-wm/awesome2/pkg-descr
index cb4a1fad6823..5a24aaaed4f8 100644
--- a/x11-wm/awesome2/pkg-descr
+++ b/x11-wm/awesome2/pkg-descr
@@ -1,4 +1,4 @@
-awesome is a tiling window manager initialy based on a dwm code
+awesome is a tiling window manager initially based on a dwm code
rewriting. It's extremely fast, small, dynamic and awesome.
Windows can be managed in several layouts: tiled and floating. Each