aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/boxtools/Makefile
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2005-03-18 21:20:26 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2005-03-18 21:20:26 +0000
commitb16723fd670e8305689626948a2bcb6608dcfda7 (patch)
treec016bdd4a74510ec4fdbeca153af056eb26f0103 /x11-wm/boxtools/Makefile
parent9ba60de158faec3d8ad27d3717666a6aaaf43285 (diff)
downloadports-b16723fd670e8305689626948a2bcb6608dcfda7.tar.gz
ports-b16723fd670e8305689626948a2bcb6608dcfda7.zip
- Add UPDATING entry about latest blackbox ports changes.
- Update boxtools to 0.70.0. - Update bbpager to 0.4.0. - Global cleanup in blackbox and bbkeys. PR: ports/78967 Submitted by: Andrew J. Caines <A.J.Caines@halplant.com>
Notes
Notes: svn path=/head/; revision=131590
Diffstat (limited to 'x11-wm/boxtools/Makefile')
-rw-r--r--x11-wm/boxtools/Makefile21
1 files changed, 17 insertions, 4 deletions
diff --git a/x11-wm/boxtools/Makefile b/x11-wm/boxtools/Makefile
index 09ee507037ab..3cca4ee3d292 100644
--- a/x11-wm/boxtools/Makefile
+++ b/x11-wm/boxtools/Makefile
@@ -6,30 +6,43 @@
#
PORTNAME= boxtools
-PORTVERSION= 0.65.0
+PORTVERSION= 0.70.0
CATEGORIES= x11-wm
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= blackboxwm
DISTNAME= blackbox-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= A.J.Caines@halplant.com
COMMENT= Style tools for the blackbox family of window managers
+CONFLICTS= blackbox-0.[7-9]*
+
MAN1= bsetbg.1 bsetroot.1
+PORTDOCS= README.bbtools README.bsetbg
+PLIST_FILES= bin/bsetbg bin/bsetroot
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
USE_REINPLACE= yes
+USE_ICONV= yes
+USE_GCC= 3.3+
pre-patch:
- ${REINPLACE_CMD} -e 's#PACKAGE=blackbox#PACKAGE=boxtools#' \
+ @${REINPLACE_CMD} -e 's#PACKAGE=blackbox#PACKAGE=boxtools#' \
-e 's#-pedantic##' ${WRKSRC}/configure
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/util/bsetbg ${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/util/bsetroot ${PREFIX}/bin
- cd ${WRKSRC}/nls && ${MAKE} install
${INSTALL_MAN} ${WRKSRC}/doc/bsetbg.1 ${PREFIX}/man/man1
${INSTALL_MAN} ${WRKSRC}/doc/bsetroot.1 ${PREFIX}/man/man1
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
+
.include <bsd.port.mk>