aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/compiz-fusion
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-04-22 08:33:19 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-04-22 08:33:19 +0000
commitecadb645fefa7f1206e8aacdac773f66389eb7fa (patch)
tree23d1c0ec0eadd014094480e88918cc2bdb7a7aab /x11-wm/compiz-fusion
parentd3f528a4c8bc527a2e854e9e1c9f1ec3d673a9f3 (diff)
downloadports-ecadb645fefa7f1206e8aacdac773f66389eb7fa.tar.gz
ports-ecadb645fefa7f1206e8aacdac773f66389eb7fa.zip
Support stage
Use options helpers
Notes
Notes: svn path=/head/; revision=351772
Diffstat (limited to 'x11-wm/compiz-fusion')
-rw-r--r--x11-wm/compiz-fusion/Makefile27
1 files changed, 7 insertions, 20 deletions
diff --git a/x11-wm/compiz-fusion/Makefile b/x11-wm/compiz-fusion/Makefile
index eb38e25baf8d..3d7f836301c3 100644
--- a/x11-wm/compiz-fusion/Makefile
+++ b/x11-wm/compiz-fusion/Makefile
@@ -12,12 +12,14 @@ EXTRACT_ONLY= # none
MAINTAINER= ports@FreeBSD.org
COMMENT= Metaport of compiz-fusion
-LIB_DEPENDS= compizconfig:${PORTSDIR}/x11-wm/libcompizconfig
+LIB_DEPENDS= libcompizconfig.so:${PORTSDIR}/x11-wm/libcompizconfig
RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/compiz.pc:${PORTSDIR}/x11-wm/compiz \
${LOCALBASE}/lib/compiz/libanimation.so:${PORTSDIR}/x11-wm/compiz-plugins-main \
${LOCALBASE}/bin/ccsm:${PORTSDIR}/x11-wm/ccsm
NO_BUILD= yes
+NO_INSTALL= yes
+NO_MTREE= yes
OPTIONS_DEFINE= EXTRA UNSUP EMERALD GCONF
OPTIONS_DEFAULT= GCONF EXTRA EMERALD
@@ -26,26 +28,11 @@ EXTRA_DESC= Enable extra plugins
UNSUP_DESC= Enable unsupported plugins
EMERALD_DESC= Enable emerald window decorator
-do-install: # empty
-
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MEXTRA}
-RUN_DEPENDS+= ${LOCALBASE}/lib/compiz/libaddhelper.so:${PORTSDIR}/x11-wm/compiz-plugins-extra
-.endif
-
-.if ${PORT_OPTIONS:MUNSUP}
-RUN_DEPENDS+= ${LOCALBASE}/lib/compiz/libfakeargb.so:${PORTSDIR}/x11-wm/compiz-plugins-unsupported
-.endif
-
-.if ${PORT_OPTIONS:MEMERALD}
-RUN_DEPENDS+= ${LOCALBASE}/bin/emerald:${PORTSDIR}/x11-wm/emerald \
+EXTRA_RUN_DEPENDS= ${LOCALBASE}/lib/compiz/libaddhelper.so:${PORTSDIR}/x11-wm/compiz-plugins-extra
+UNSUP_RUN_DEPENDS= ${LOCALBASE}/lib/compiz/libfakeargb.so:${PORTSDIR}/x11-wm/compiz-plugins-unsupported
+EMERALD_RUN_DEPENDS= ${LOCALBASE}/bin/emerald:${PORTSDIR}/x11-wm/emerald \
${LOCALBASE}/share/emerald/themes/Adonis_Mod/theme.ini:${PORTSDIR}/x11-themes/emerald-themes
-.endif
-.if ${PORT_OPTIONS:MGCONF}
-RUN_DEPENDS+= ${LOCALBASE}/lib/compizconfig/backends/libgconf.so:${PORTSDIR}/x11-wm/compizconfig-backend-gconf
-.endif
+GCONF_RUN_DEPENDS= ${LOCALBASE}/lib/compizconfig/backends/libgconf.so:${PORTSDIR}/x11-wm/compizconfig-backend-gconf
.include <bsd.port.mk>