aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/compiz-plugins-extra
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2011-08-23 18:39:19 +0000
committerKoop Mast <kwm@FreeBSD.org>2011-08-23 18:39:19 +0000
commitfe61bf1eb4f2758636a3c065686a833eb412df25 (patch)
tree1474457ea487adcafec2ab29e99ab61897a3e479 /x11-wm/compiz-plugins-extra
parent5732783897145621b6af3ab08fba8d9af40f338b (diff)
downloadports-fe61bf1eb4f2758636a3c065686a833eb412df25.tar.gz
ports-fe61bf1eb4f2758636a3c065686a833eb412df25.zip
Chase libnotify, libproxy and webkit-gtk2 shlib changes, and fix build where needed.
Notes
Notes: svn path=/head/; revision=280300
Diffstat (limited to 'x11-wm/compiz-plugins-extra')
-rw-r--r--x11-wm/compiz-plugins-extra/Makefile5
-rw-r--r--x11-wm/compiz-plugins-extra/files/patch-src_notification_notification.c11
2 files changed, 14 insertions, 2 deletions
diff --git a/x11-wm/compiz-plugins-extra/Makefile b/x11-wm/compiz-plugins-extra/Makefile
index 49c473f773ba..b9390dc6d045 100644
--- a/x11-wm/compiz-plugins-extra/Makefile
+++ b/x11-wm/compiz-plugins-extra/Makefile
@@ -7,14 +7,15 @@
PORTNAME= compiz-plugins-extra
PORTVERSION= 0.8.4
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= x11-wm
MASTER_SITES= http://releases.compiz.org/${PORTVERSION}/
MAINTAINER= ports@FreeBSD.org
COMMENT= Plugins for Compiz Composite Window Manager
-LIB_DEPENDS= cairo.2:${PORTSDIR}/graphics/cairo
+LIB_DEPENDS= cairo.2:${PORTSDIR}/graphics/cairo \
+ notify.4:${PORTSDIR}/devel/libnotify
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/compiz.pc:${PORTSDIR}/x11-wm/compiz \
${LOCALBASE}/libdata/pkgconfig/bcop.pc:${PORTSDIR}/devel/compiz-bcop \
${LOCALBASE}/libdata/pkgconfig/compiz-text.pc:${PORTSDIR}/x11-wm/compiz-plugins-main
diff --git a/x11-wm/compiz-plugins-extra/files/patch-src_notification_notification.c b/x11-wm/compiz-plugins-extra/files/patch-src_notification_notification.c
new file mode 100644
index 000000000000..a7489f11d058
--- /dev/null
+++ b/x11-wm/compiz-plugins-extra/files/patch-src_notification_notification.c
@@ -0,0 +1,11 @@
+--- src/notification/notification.c.orig 2011-08-15 19:54:26.000000000 +0200
++++ src/notification/notification.c 2011-08-15 19:54:44.000000000 +0200
+@@ -103,7 +103,7 @@ notifyLogMessage (const char *componen
+
+ n = notify_notification_new (logLevel,
+ message,
+- iconUri, NULL);
++ iconUri);
+
+ notify_notification_set_timeout (n, nd->timeout);
+