aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/compiz-plugins-unsupported/Makefile
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2007-08-22 17:58:54 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2007-08-22 17:58:54 +0000
commitab7e0f97dea29248b91bbf141a108f9aaa2a946d (patch)
tree466ff783039498885e8d042707e6fc35034a61a9 /x11-wm/compiz-plugins-unsupported/Makefile
parent790a24a947a4eb0e162d239bb7337f1d98a90423 (diff)
downloadports-ab7e0f97dea29248b91bbf141a108f9aaa2a946d.tar.gz
ports-ab7e0f97dea29248b91bbf141a108f9aaa2a946d.zip
Add compiz-fusion-plugins-unsupported, the unsupported set of plugins for
Compiz fusion. PR: ports/115728 Submitted by: Robert Noland <rnoland@2hip.net>
Notes
Notes: svn path=/head/; revision=198148
Diffstat (limited to 'x11-wm/compiz-plugins-unsupported/Makefile')
-rw-r--r--x11-wm/compiz-plugins-unsupported/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/x11-wm/compiz-plugins-unsupported/Makefile b/x11-wm/compiz-plugins-unsupported/Makefile
new file mode 100644
index 000000000000..a11c5d4275fc
--- /dev/null
+++ b/x11-wm/compiz-plugins-unsupported/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: compiz-fusion-plugins-unsupported
+# Date created: 2007-08-17
+# Whom: Robert Noland <rnoland@2hip.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= compiz-fusion-plugins-unsupported
+PORTVERSION= 0.5.2
+#PORTREVISION= 0
+CATEGORIES= x11-wm
+MASTER_SITES= http://releases.compiz-fusion.org/${PORTVERSION}/
+
+MAINTAINER= rnoland@2hip.net
+COMMENT= Plugins for Compiz Composite Window Manager
+
+LIB_DEPENDS= cairo.2:${PORTSDIR}/graphics/cairo
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/compiz.pc:${PORTSDIR}/x11-wm/compiz \
+ ${LOCALBASE}/libdata/pkgconfig/bcop.pc:${PORTSDIR}/devel/compiz-bcop
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+GNU_CONFIGURE= yes
+USE_GL= yes
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_GNOME= gnomehack
+USE_XORG= glproto
+USE_GETTEXT= yes
+USE_LDCONFIG= yes
+USE_AUTOTOOLS= libtool:15
+
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+
+.include <bsd.port.pre.mk>
+.include <bsd.port.post.mk>