aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/compiz
diff options
context:
space:
mode:
authorMateusz Piotrowski <0mp@FreeBSD.org>2019-05-02 15:37:51 +0000
committerMateusz Piotrowski <0mp@FreeBSD.org>2019-05-02 15:37:51 +0000
commit08bb75576c714eb6dec8e30420a3a0f98e412ecd (patch)
tree26c9aadcc6a7e9d57c6b9f864ed7e3c9f5c55e35 /x11-wm/compiz
parent9bbc1e70f7967740ade12ca5838360ca430aabcb (diff)
downloadports-08bb75576c714eb6dec8e30420a3a0f98e412ecd.tar.gz
ports-08bb75576c714eb6dec8e30420a3a0f98e412ecd.zip
x11-wm/compiz: Clean up port's makefile
- Add modesetting to the drivers whitelist - Use upstream name xfwm4 instead of xfwm to properly fall back - Remove reference to former option GNOME - Simplify option DBUS - Add missing dependencies - Add LICENSE - Add USES=gnome, USES=gl and USE_GL=gl - Reorder the variables to pet portlint - Regenerate patch files to pet portlint Metacity migrated to GTK+ 3 while Compiz still uses GTK+ 2. This incompatibility was left unseen at make time because of a reference to former option GNOME in an assertion which resulted in METACITY being always disabled. Committer's changes: - Remove broken option METACITY - Further lint the makefile PR: 230894 Submitted by: Samy Mahmoudi <samy.mahmoudi@gmail.com> Reviewed by: mat Approved by: portmgr (maintainer timeout: > 14 days) Differential Revision: https://reviews.freebsd.org/D19467
Notes
Notes: svn path=/head/; revision=500666
Diffstat (limited to 'x11-wm/compiz')
-rw-r--r--x11-wm/compiz/Makefile85
-rw-r--r--x11-wm/compiz/files/compiz-manager.in4
-rw-r--r--x11-wm/compiz/files/patch-plugins_fuse.c4
-rw-r--r--x11-wm/compiz/files/patch-src-Makefile.in6
4 files changed, 49 insertions, 50 deletions
diff --git a/x11-wm/compiz/Makefile b/x11-wm/compiz/Makefile
index 90858488a43a..a20370506a7e 100644
--- a/x11-wm/compiz/Makefile
+++ b/x11-wm/compiz/Makefile
@@ -2,29 +2,51 @@
PORTNAME= compiz
PORTVERSION= 0.8.8
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= x11-wm
MASTER_SITES= http://releases.compiz.org/${PORTVERSION}/
MAINTAINER= freebsd-ports@dan.me.uk
COMMENT= Compiz Composite/Window Manager
-LIB_DEPENDS= libpng.so:graphics/png \
+LICENSE= GPLv2+ LGPL21+ MIT
+LICENSE_COMB= multi
+LICENSE_FILE_GPLv2+ = ${WRKSRC}/COPYING.GPL
+LICENSE_FILE_LGPL21+ = ${WRKSRC}/COPYING.LGPL
+LICENSE_FILE_MIT= ${WRKSRC}/COPYING.MIT
+
+LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2 \
libgtop-2.0.so:devel/libgtop \
+ libpng.so:graphics/png \
libstartup-notification-1.so:x11/startup-notification
RUN_DEPENDS= glxinfo:graphics/mesa-demos \
nvidia-settings:x11/nvidia-settings
+USES= gettext-runtime gettext-tools gl gmake gnome libtool \
+ localbase pathfix tar:bzip2
+USE_GL= gl glu
+USE_GNOME= cairo gconf2 intltool libxslt
+USE_LDCONFIG= yes
+USE_XORG= ice sm x11 xcomposite xdamage xext xfixes xinerama \
+ xorgproto xrandr xrender
XORG_CAT= app
+
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-kde4 \
+ --disable-kde \
+ --disable-gnome \
+ --disable-gnome-keybindings \
+ --disable-metacity
INSTALL_TARGET= install-strip
-USES= gettext gmake libtool pathfix tar:bzip2
-USE_GL= glu
-USE_GNOME= gconf2 libxslt intltool
-USE_XORG= xorgproto ice sm x11 xcomposite xdamage xext xfixes xinerama \
- xrandr xrender
-USE_LDCONFIG= yes
+SUB_FILES= compiz-manager
+DESKTOP_ENTRIES= "Compiz Manager" \
+ "Wrapper script for starting compiz" \
+ "" \
+ "compiz-manager" \
+ "System;Core;" \
+ false
GCONF_SCHEMAS= gwd.schemas \
compiz-annotate.schemas \
compiz-blur.schemas \
@@ -59,54 +81,31 @@ GCONF_SCHEMAS= gwd.schemas \
compiz-wobbly.schemas \
compiz-zoom.schemas
-CONFIGURE_ARGS= --disable-kde4 --disable-kde \
- --disable-gnome --disable-gnome-keybindings
-CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib
-
-OPTIONS_DEFINE= SVG GTK2 METACITY DBUS FUSE
-OPTIONS_DEFAULT= SVG GTK2 METACITY DBUS
-
-METACITY_DESC= Enable Metacity support
+OPTIONS_DEFINE= DBUS FUSE GTK2 SVG
+OPTIONS_DEFAULT=DBUS GTK2 SVG
+OPTIONS_SUB= yes
-SUB_FILES= compiz-manager
-DESKTOP_ENTRIES= "Compiz Manager" \
- "Wrapper script for starting compiz" \
- "" \
- "compiz-manager" \
- "System;Core;" \
- false
+DBUS_CONFIGURE_ENABLE= dbus
+DBUS_BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/dbus-1.pc:devel/dbus
+DBUS_RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/dbus-1.pc:devel/dbus
-OPTIONS_SUB= yes
-SVG_CONFIGURE_ENABLE= librsvg
-SVG_USE= GNOME=librsvg2
+FUSE_CONFIGURE_ENABLE= fuse
+FUSE_USES= fuse
GTK2_CONFIGURE_ENABLE= gtk
GTK2_USE= GNOME=glib20,libwnck
-FUSE_CONFIGURE_ENABLE= fuse
-FUSE_USES= fuse
+SVG_CONFIGURE_ENABLE= librsvg
+SVG_USE= GNOME=librsvg2
.include <bsd.port.options.mk>
-.if !empty(PORT_OPTIONS:MMETACITY) && !empty(PORT_OPTIONS:MGNOME) && !empty(PORT_OPTIONS:MGTK2)
-CONFIGURE_ARGS+= --enable-metacity
-USE_GNOME+= metacity
-.else
-CONFIGURE_ARGS+= --disable-metacity
-.endif
-
-.if ${PORT_OPTIONS:MDBUS}
-CONFIGURE_ARGS+= --enable-dbus
-BUILD_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/dbus-1.pc:devel/dbus
-RUN_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/dbus-1.pc:devel/dbus
-.if ${PORT_OPTIONS:MGTK2} && ${PORT_OPTIONS:MGNOME}
+.if ${PORT_OPTIONS:MDBUS} && ${PORT_OPTIONS:MGTK2}
CONFIGURE_ARGS+= --enable-dbus-glib
BUILD_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/dbus-glib-1.pc:devel/dbus-glib
RUN_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/dbus-glib-1.pc:devel/dbus-glib
-.endif
.else
-CONFIGURE_ARGS+= --disable-dbus --disable-dbus-glib
+CONFIGURE_ARGS+= --disable-dbus-glib
.endif
post-install:
diff --git a/x11-wm/compiz/files/compiz-manager.in b/x11-wm/compiz/files/compiz-manager.in
index c5a521d14b5a..358dd14ae61a 100644
--- a/x11-wm/compiz/files/compiz-manager.in
+++ b/x11-wm/compiz/files/compiz-manager.in
@@ -32,7 +32,7 @@ PLUGIN_PATH="%%LOCALBASE%%/lib/compiz/"
GLXINFO="%%LOCALBASE%%/bin/glxinfo"
KWIN="%%LOCALBASE%%/bin/kwin"
METACITY="%%LOCALBASE%%/bin/metacity"
-XFWM="%%LOCALBASE%%/bin/xfwm"
+XFWM="%%LOCALBASE%%/bin/xfwm4"
COMPIZ_NAME="compiz" # Final name for compiz (compiz.real)
# For Xgl LD_PRELOAD
@@ -59,7 +59,7 @@ fi
FALLBACKWM_OPTIONS="--replace $@"
# Driver whitelist
-WHITELIST="nvidia intel ati radeon i810"
+WHITELIST="nvidia intel ati radeon i810 modesetting"
# blacklist based on the pci ids
# See http://wiki.compiz-fusion.org/Hardware/Blacklist for details
diff --git a/x11-wm/compiz/files/patch-plugins_fuse.c b/x11-wm/compiz/files/patch-plugins_fuse.c
index 48a0a68b9287..561653a5a7d0 100644
--- a/x11-wm/compiz/files/patch-plugins_fuse.c
+++ b/x11-wm/compiz/files/patch-plugins_fuse.c
@@ -1,5 +1,5 @@
---- plugins/fuse.c.orig Mon Apr 2 14:15:28 2007
-+++ plugins/fuse.c Mon May 7 20:07:09 2007
+--- plugins/fuse.c.orig 2010-05-21 11:18:14 UTC
++++ plugins/fuse.c
@@ -28,6 +28,8 @@
#include <errno.h>
#include <poll.h>
diff --git a/x11-wm/compiz/files/patch-src-Makefile.in b/x11-wm/compiz/files/patch-src-Makefile.in
index f9ed9ce4cd13..199e8fc8a61f 100644
--- a/x11-wm/compiz/files/patch-src-Makefile.in
+++ b/x11-wm/compiz/files/patch-src-Makefile.in
@@ -1,6 +1,6 @@
---- src/Makefile.in.orig 2014-06-02 19:14:25.669435783 +0100
-+++ src/Makefile.in 2014-06-02 19:14:34.064435780 +0100
-@@ -292,7 +292,7 @@
+--- src/Makefile.in.orig 2018-08-24 22:46:14 UTC
++++ src/Makefile.in
+@@ -292,7 +292,7 @@ INCLUDES = \
-DIMAGEDIR=\"$(imagedir)\" \
-DMETADATADIR=\"$(metadatadir)\"