aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/compton
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2017-02-05 22:33:58 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2017-02-05 22:33:58 +0000
commitd56cc4030667e72fe5a95ea651e60593673bd7d9 (patch)
treed972c3f0d2233ba4b523a90b05a357f64135ed63 /x11-wm/compton
parent696ac89fbd9e85b7fa5ca0097c3b3d074cf09146 (diff)
downloadports-d56cc4030667e72fe5a95ea651e60593673bd7d9.tar.gz
ports-d56cc4030667e72fe5a95ea651e60593673bd7d9.zip
- Allow to build without `devel/libconfig' and Xinerama support
- Provide better DRM and OpenGL option descriptions - Define LICENSE_FILE and remove banal comment in the Makefile
Notes
Notes: svn path=/head/; revision=433464
Diffstat (limited to 'x11-wm/compton')
-rw-r--r--x11-wm/compton/Makefile20
1 files changed, 14 insertions, 6 deletions
diff --git a/x11-wm/compton/Makefile b/x11-wm/compton/Makefile
index 87d91a4226af..a2589130ad1b 100644
--- a/x11-wm/compton/Makefile
+++ b/x11-wm/compton/Makefile
@@ -2,14 +2,15 @@
PORTNAME= compton
PORTVERSION= 20160907
+PORTREVISION= 1
CATEGORIES= x11-wm
MAINTAINER= femc7488@gmail.com
COMMENT= Feature-rich compositing window manager for X11
LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
-LIB_DEPENDS= libconfig.so:devel/libconfig
RUN_DEPENDS= xprop:x11/xprop \
xwininfo:x11/xwininfo
@@ -18,19 +19,24 @@ GH_ACCOUNT= chjj
GH_TAGNAME= b7f43ee
USES= gmake pkgconfig
-USE_XORG= x11 xcomposite xdamage xext xfixes xrandr xrender xinerama
+USE_XORG= x11 xcomposite xdamage xext xfixes xrandr xrender
MAKE_ARGS= COMPTON_VERSION=git-${PORTVERSION}-${GH_TAGNAME} \
XDGDIR=${LOCALBASE}/etc/xdg
ALL_TARGET= ${PORTNAME}
-OPTIONS_DEFINE= PCRE DRM OPENGL DBUS DOCS
-OPTIONS_DEFAULT= PCRE DRM OPENGL DBUS
+OPTIONS_DEFINE= CONFIG PCRE DRM OPENGL DBUS XINERAMA DOCS
+OPTIONS_DEFAULT= CONFIG PCRE DRM OPENGL DBUS XINERAMA
+CONFIG_DESC= Configuration file parsing support
PCRE_DESC= Blacklist support (via libpcre)
-DRM_DESC= DRM support
+DRM_DESC= DRM VSync method support
+OPENGL_DESC= GLX backend, OpenGL VSync method, etc.
DOCS_DESC= Build manpages (requires AsciiDoc/DocBook)
+CONFIG_LIB_DEPENDS= libconfig.so:devel/libconfig
+CONFIG_MAKE_ARGS_OFF= NO_LIBCONFIG=yes
+
PCRE_LIB_DEPENDS= libpcre.so:devel/pcre
PCRE_MAKE_ARGS_OFF= NO_REGEX_PCRE=yes
@@ -43,6 +49,9 @@ OPENGL_MAKE_ARGS_OFF= NO_VSYNC_OPENGL=yes
DBUS_LIB_DEPENDS= libdbus-1.so:devel/dbus
DBUS_MAKE_ARGS_OFF= NO_DBUS=yes
+XINERAMA_USE= XORG=xinerama
+XINERAMA_MAKE_ARGS_OFF= NO_XINERAMA=yes
+
DOCS_BUILD_DEPENDS= a2x:textproc/asciidoc \
xsltproc:textproc/libxslt \
docbook-xml>0:textproc/docbook-xml \
@@ -53,7 +62,6 @@ DOCS_PLIST_FILES= man/man1/compton.1.gz man/man1/compton-trans.1.gz
DOCS_PORTDOCS= README.md cdbus-driver.sh
post-patch:
-# Adjust the location of configuration file
@${REINPLACE_CMD} -e '/config_system_dir/s|/etc|${LOCALBASE}&|' \
${WRKSRC}/src/compton.c