aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/cwm
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2017-10-02 15:04:37 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2017-10-02 15:04:37 +0000
commit7caab4aac66e00abd0a3dc01323ebd8c304f4119 (patch)
tree99d577c41f7f761de4b9eeeedb3e31a6422c7f59 /x11-wm/cwm
parent202acd95e4cef619fa8faaadd7dd9947092104de (diff)
downloadports-7caab4aac66e00abd0a3dc01323ebd8c304f4119.tar.gz
ports-7caab4aac66e00abd0a3dc01323ebd8c304f4119.zip
x11-wm/cwm: Update to 5.6-201-g5a46349
A lot of things have changed for the better since version 5.6 in cwm, but upstream has stopped tagging new releases. This updates the port to use a more recent commit to match cwm in OpenBSD more closely. This is important because configuration options have changed which makes it harder to share config files between systems. While here - Fix license which appears to not be BSD 2-clause but the ISC license - Update WWW. The old site is gone. - Remove MASTER_SITES which wasn't really used Changes: https://github.com/chneukirchen/cwm/compare/v5.6...linux PR: 222423 Approved by: braakvaak@aol.com (maintainer timeout, 2 weeks)
Notes
Notes: svn path=/head/; revision=451080
Diffstat (limited to 'x11-wm/cwm')
-rw-r--r--x11-wm/cwm/Makefile27
-rw-r--r--x11-wm/cwm/distinfo5
-rw-r--r--x11-wm/cwm/files/patch-Makefile11
-rw-r--r--x11-wm/cwm/files/patch-kbfunc.c11
-rw-r--r--x11-wm/cwm/pkg-descr5
5 files changed, 25 insertions, 34 deletions
diff --git a/x11-wm/cwm/Makefile b/x11-wm/cwm/Makefile
index abcdd6a3156e..9b0114da9ac9 100644
--- a/x11-wm/cwm/Makefile
+++ b/x11-wm/cwm/Makefile
@@ -1,29 +1,44 @@
# $FreeBSD$
PORTNAME= cwm
-PORTVERSION= 5.6
DISTVERSIONPREFIX= v
+DISTVERSION= 5.6-201
+DISTVERSIONSUFFIX= -g5a46349
CATEGORIES= x11-wm
-MASTER_SITES= http://chneukirchen.org/releases/ \
MAINTAINER= braakvaak@aol.com
COMMENT= Minimalistic window manager for X11 based on evilwm
-LICENSE= BSD2CLAUSE
+LICENSE= ISCL
-LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig
+LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2
-USES= pkgconfig:build
-USE_XORG= x11 xft xinerama xrandr
+USES= pkgconfig shebangfix
USE_GITHUB= yes
GH_ACCOUNT= chneukirchen
+USE_XORG= x11 xft xinerama xrandr
PLIST_FILES= bin/cwm \
+ bin/cwm-migrate-config.pl \
man/man1/cwm.1.gz \
man/man5/cwmrc.5.gz
+SHEBANG_FILES= migrate-config.pl
+
+.include <bsd.port.options.mk>
+
+post-patch:
+ @${REINPLACE_CMD} 's@/usr/X11R6@${LOCALBASE}@' ${WRKSRC}/cwmrc.5
+ @${REINPLACE_CMD} -e 's@strlcpy.o strlcat.o@@' \
+ -e 's@strtonum.o@@' ${WRKSRC}/Makefile
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1100072
+ @${REINPLACE_CMD} 's@reallocarray.o@@' ${WRKSRC}/Makefile
+.endif
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/cwm ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/migrate-config.pl \
+ ${STAGEDIR}${PREFIX}/bin/cwm-migrate-config.pl
${INSTALL_MAN} ${WRKSRC}/cwm.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
${INSTALL_MAN} ${WRKSRC}/cwmrc.5 ${STAGEDIR}${MAN5PREFIX}/man/man5
diff --git a/x11-wm/cwm/distinfo b/x11-wm/cwm/distinfo
index d16bf4175b5c..cd1080de7c1d 100644
--- a/x11-wm/cwm/distinfo
+++ b/x11-wm/cwm/distinfo
@@ -1,2 +1,3 @@
-SHA256 (chneukirchen-cwm-v5.6_GH0.tar.gz) = 006320bb1716cc0f93bac5634dcccd01f21d468263b5fc9d1be2dd11078a0625
-SIZE (chneukirchen-cwm-v5.6_GH0.tar.gz) = 50799
+TIMESTAMP = 1505255816
+SHA256 (chneukirchen-cwm-v5.6-201-g5a46349_GH0.tar.gz) = 0ef72de4dcffc5d1ea848d8e1e24884ae6436147c042f56166d996f28d46ebb8
+SIZE (chneukirchen-cwm-v5.6-201-g5a46349_GH0.tar.gz) = 51003
diff --git a/x11-wm/cwm/files/patch-Makefile b/x11-wm/cwm/files/patch-Makefile
deleted file mode 100644
index d4993a575254..000000000000
--- a/x11-wm/cwm/files/patch-Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.orig 2015-03-26 00:34:30 UTC
-+++ Makefile
-@@ -16,7 +16,7 @@ OBJS= calmwm.o screen.o xmalloc.o clien
-
- CPPFLAGS+= `pkg-config --cflags fontconfig x11 xft xinerama xrandr`
-
--CFLAGS?= -Wall -O2 -g -D_GNU_SOURCE
-+CFLAGS?= -Wall -g -pthread
-
- LDFLAGS+= `pkg-config --libs fontconfig x11 xft xinerama xrandr`
-
diff --git a/x11-wm/cwm/files/patch-kbfunc.c b/x11-wm/cwm/files/patch-kbfunc.c
deleted file mode 100644
index b8d1e8b8cc28..000000000000
--- a/x11-wm/cwm/files/patch-kbfunc.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- kbfunc.c.orig 2015-03-26 00:09:51 UTC
-+++ kbfunc.c
-@@ -324,7 +324,7 @@ kbfunc_ssh(struct client_ctx *cc, union
- struct menu_q menuq;
- FILE *fp;
- char *buf, *lbuf, *p;
-- char hostbuf[HOST_NAME_MAX+1];
-+ char hostbuf[_POSIX_HOST_NAME_MAX+1];
- char path[PATH_MAX];
- int l;
- size_t len;
diff --git a/x11-wm/cwm/pkg-descr b/x11-wm/cwm/pkg-descr
index 1fdf27049c98..e75defa39769 100644
--- a/x11-wm/cwm/pkg-descr
+++ b/x11-wm/cwm/pkg-descr
@@ -2,7 +2,4 @@ cwm is a window manager for X11 initially inspired by evilwm. cwm has several
novel features, including the ability to search for windows. it features a
very simple and attractive aesthetic.
-This port is based on OpenBSD's continued work on cwm, as development on the
-project seems to have halted.
-
-WWW: http://monkey.org/~marius/pages/?page=cwm
+WWW: https://github.com/chneukirchen/cwm